From: Len Brown <lenb@kernel.org>
To: Bjorn Helgaas <bjorn.helgaas@hp.com>
Cc: linux-acpi@vger.kernel.org
Subject: Re: [PATCH 00/20] ACPI: PCI: simplify _PRT handling
Date: Tue, 30 Dec 2008 23:17:12 -0500 (EST) [thread overview]
Message-ID: <alpine.LFD.2.00.0812302316320.17126@localhost.localdomain> (raw)
In-Reply-To: <20081209042833.26415.24906.stgit@bob.kio>
series looks good -- applied all 20.
thanks,
-- Len Brown, Intel Open Source Technology Center
On Mon, 8 Dec 2008, Bjorn Helgaas wrote:
> This series simplifies the code that handles ACPI _PRTs (PCI routing
> tables). My goal is to make this look more like the corresponding
> code in other architectures, especially in terms of swizzling, e.g.,
> the various implementations of common_swizzle() and simple_swizzle(),
> and the x86 non-ACPI code in pirq_enable_irq().
>
> There should be no functional changes in this series.
>
> Comments welcome.
>
> Bjorn
>
> ---
>
> Bjorn Helgaas (20):
> ACPI: PCI: add HP copyright
> ACPI: PCI: whitespace and useless initialization cleanup
> ACPI: PCI: expand acpi_pci_allocate_irq() and acpi_pci_free_irq() inline
> ACPI: PCI: simplify struct acpi_prt_entry
> ACPI: PCI: simplify list of _PRT entries
> ACPI: PCI: combine lookup and derive
> ACPI: PCI: follow typical PCI INTx swizzling pattern
> ACPI: PCI: use positive logic to simplify code
> ACPI: PCI: remove callback from acpi_pci_irq_lookup & acpi_pci_irq_derive
> ACPI: PCI: tweak _PRT lookup debug
> ACPI: PCI: lookup _PRT entry by PCI dev and pin, not segment/bus/dev/pin
> ACPI: PCI: use 1-based encoding for _PRT quirks
> ACPI: PCI: always use the PCI INTx pin values, not the _PRT ones
> ACPI: PCI: add a helper to convert _PRT INTx pin number to name
> ACPI: PCI: move struct acpi_prt_entry declaration out of public header file
> ACPI: PCI: fix GSI/IRQ naming confusion
> ACPI: PCI: ignore _PRT function information
> ACPI: PCI: simplify buffer management for evaluating _PRT
> ACPI: PCI: remove unnecessary null pointer checks
> ACPI: PCI: use conventional PCI address format
>
>
> drivers/acpi/pci_bind.c | 12 +
> drivers/acpi/pci_irq.c | 416 +++++++++++++++--------------------------------
> include/linux/acpi.h | 16 --
> 3 files changed, 136 insertions(+), 308 deletions(-)
>
prev parent reply other threads:[~2008-12-31 4:17 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-12-09 4:30 [PATCH 00/20] ACPI: PCI: simplify _PRT handling Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 01/20] ACPI: PCI: use conventional PCI address format Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 02/20] ACPI: PCI: remove unnecessary null pointer checks Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 03/20] ACPI: PCI: simplify buffer management for evaluating _PRT Bjorn Helgaas
2008-12-31 4:15 ` [PATCH] ACPI: simplify buffer management for acpi_pci_bind() etc Len Brown
2008-12-09 4:30 ` [PATCH 04/20] ACPI: PCI: ignore _PRT function information Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 05/20] ACPI: PCI: fix GSI/IRQ naming confusion Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 06/20] ACPI: PCI: move struct acpi_prt_entry declaration out of public header file Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 07/20] ACPI: PCI: add a helper to convert _PRT INTx pin number to name Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 08/20] ACPI: PCI: always use the PCI INTx pin values, not the _PRT ones Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 09/20] ACPI: PCI: use 1-based encoding for _PRT quirks Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 10/20] ACPI: PCI: lookup _PRT entry by PCI dev and pin, not segment/bus/dev/pin Bjorn Helgaas
2008-12-09 4:30 ` [PATCH 11/20] ACPI: PCI: tweak _PRT lookup debug Bjorn Helgaas
2008-12-09 4:31 ` [PATCH 12/20] ACPI: PCI: remove callback from acpi_pci_irq_lookup & acpi_pci_irq_derive Bjorn Helgaas
2008-12-09 4:31 ` [PATCH 13/20] ACPI: PCI: use positive logic to simplify code Bjorn Helgaas
2008-12-09 4:31 ` [PATCH 14/20] ACPI: PCI: follow typical PCI INTx swizzling pattern Bjorn Helgaas
2008-12-09 4:31 ` [PATCH 15/20] ACPI: PCI: combine lookup and derive Bjorn Helgaas
2008-12-09 4:31 ` [PATCH 16/20] ACPI: PCI: simplify list of _PRT entries Bjorn Helgaas
2008-12-09 4:31 ` [PATCH 17/20] ACPI: PCI: simplify struct acpi_prt_entry Bjorn Helgaas
2008-12-09 4:31 ` [PATCH 18/20] ACPI: PCI: expand acpi_pci_allocate_irq() and acpi_pci_free_irq() inline Bjorn Helgaas
2008-12-09 4:31 ` [PATCH 19/20] ACPI: PCI: whitespace and useless initialization cleanup Bjorn Helgaas
2008-12-09 4:31 ` [PATCH 20/20] ACPI: PCI: add HP copyright Bjorn Helgaas
2008-12-31 4:17 ` Len Brown [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LFD.2.00.0812302316320.17126@localhost.localdomain \
--to=lenb@kernel.org \
--cc=bjorn.helgaas@hp.com \
--cc=linux-acpi@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox