From: "David Hildenbrand (Arm)" <david@kernel.org>
To: Li Zhe <lizhe.67@bytedance.com>
Cc: akpm@linux-foundation.org, apopple@nvidia.com, arnd@arndb.de,
bp@alien8.de, dave.hansen@linux.intel.com, kees@kernel.org,
linux-arch@vger.kernel.org, linux-hardening@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-mm@kvack.org,
mingo@redhat.com, rppt@kernel.org, tglx@kernel.org,
x86@kernel.org
Subject: Re: [PATCH v5 3/8] mm: add a set_page_section_from_pfn() helper
Date: Mon, 6 Jul 2026 15:48:16 +0200 [thread overview]
Message-ID: <efd55e0c-8caf-4633-b876-18e8e788493a@kernel.org> (raw)
In-Reply-To: <20260706115213.50375-1-lizhe.67@bytedance.com>
On 7/6/26 13:52, Li Zhe wrote:
> On Mon, Jul 6, 2026 at 11:15:36AM +0200, david@kernel.org wrote:
>
>>> diff --git a/include/linux/mm.h b/include/linux/mm.h
>>> index 485df9c2dbdd..f78afa63dd3d 100644
>>> --- a/include/linux/mm.h
>>> +++ b/include/linux/mm.h
>>> @@ -2541,11 +2541,26 @@ static inline void set_page_section(struct page *page, unsigned long section)
>>> page->flags.f |= (section & SECTIONS_MASK) << SECTIONS_PGSHIFT;
>>> }
>>>
>>> +static inline void set_page_section_from_pfn(struct page *page,
>>> + unsigned long pfn)
>>
>> Two tab indent.
>
> Thanks, I will fix the indentation in v6.
>
>>> +{
>>> + set_page_section(page, pfn_to_section_nr(pfn));
>>> +}
>>> +
>>> static inline unsigned long memdesc_section(memdesc_flags_t mdf)
>>> {
>>> return (mdf.f >> SECTIONS_PGSHIFT) & SECTIONS_MASK;
>>> }
>>> #else /* !SECTION_IN_PAGE_FLAGS */
>>> +static inline void set_page_section(struct page *page, unsigned long section)
>>> +{
>>> +}
>>
>> Why do we need this?
>
> The empty set_page_section() helper is not needed. I will drop it in
> v6.
>
>>> +
>>> +static inline void set_page_section_from_pfn(struct page *page,
>>> + unsigned long pfn)
>>> +{
>>> +}
>>
>> Dito.
>
> The no-op set_page_section_from_pfn() helper is still needed for
> !SECTION_IN_PAGE_FLAGS so callers can use a single helper without
> open-coding #ifdef SECTION_IN_PAGE_FLAGS at each callsite.
Sorry, I meant two-tab indent :) Why we need that was clear to me.
--
Cheers,
David
next prev parent reply other threads:[~2026-07-06 13:48 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-01 9:05 [PATCH v5 0/8] mm: optimize zone-device memmap initialization Li Zhe
2026-07-01 9:05 ` [PATCH v5 1/8] mm: fix stale ZONE_DEVICE refcount comment Li Zhe
2026-07-06 9:11 ` David Hildenbrand (Arm)
2026-07-01 9:05 ` [PATCH v5 2/8] mm: factor zone-device page init helpers out of __init_zone_device_page Li Zhe
2026-07-06 9:13 ` David Hildenbrand (Arm)
2026-07-06 11:50 ` Li Zhe
2026-07-06 13:47 ` David Hildenbrand (Arm)
2026-07-01 9:05 ` [PATCH v5 3/8] mm: add a set_page_section_from_pfn() helper Li Zhe
2026-07-06 9:15 ` David Hildenbrand (Arm)
2026-07-06 11:52 ` Li Zhe
2026-07-06 13:48 ` David Hildenbrand (Arm) [this message]
2026-07-01 9:05 ` [PATCH v5 4/8] mm: add a template-based fast path for zone-device page init Li Zhe
2026-07-03 14:06 ` Mike Rapoport
2026-07-06 7:45 ` Li Zhe
2026-07-01 9:05 ` [PATCH v5 5/8] mm: extend the template fast path to zone-device compound tails Li Zhe
2026-07-01 9:05 ` [PATCH v5 6/8] string: introduce memcpy_nt() helpers Li Zhe
2026-07-02 2:16 ` Borislav Petkov
2026-07-02 7:36 ` Li Zhe
2026-07-06 9:18 ` David Hildenbrand (Arm)
2026-07-06 11:53 ` Li Zhe
2026-07-06 13:49 ` David Hildenbrand (Arm)
2026-07-01 9:05 ` [PATCH v5 7/8] x86/string: extend memcpy_flushcache() fixed-size fastpaths Li Zhe
2026-07-02 2:23 ` Borislav Petkov
2026-07-02 7:37 ` Li Zhe
2026-07-03 19:56 ` Borislav Petkov
2026-07-06 7:43 ` Li Zhe
2026-07-06 17:19 ` Borislav Petkov
2026-07-01 9:05 ` [PATCH v5 8/8] mm: use memcpy_nt() in zone-device template copies Li Zhe
2026-07-01 23:28 ` [PATCH v5 0/8] mm: optimize zone-device memmap initialization Andrew Morton
2026-07-02 2:24 ` Borislav Petkov
2026-07-02 7:39 ` Li Zhe
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=efd55e0c-8caf-4633-b876-18e8e788493a@kernel.org \
--to=david@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=apopple@nvidia.com \
--cc=arnd@arndb.de \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=kees@kernel.org \
--cc=linux-arch@vger.kernel.org \
--cc=linux-hardening@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=lizhe.67@bytedance.com \
--cc=mingo@redhat.com \
--cc=rppt@kernel.org \
--cc=tglx@kernel.org \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox