Linux-ARM-Kernel Archive on lore.kernel.org
 help / color / mirror / Atom feed
* ARM: MACH_CPUIMX27 or MACH_EUKREA_CPUIMX27?
@ 2014-06-10 14:35 Paul Bolle
  2014-06-10 15:01 ` Russell King - ARM Linux
  0 siblings, 1 reply; 2+ messages in thread
From: Paul Bolle @ 2014-06-10 14:35 UTC (permalink / raw)
  To: linux-arm-kernel

0) Summary: either the Kconfig symbol MACH_CPUIMX27 or the reference to
CONFIG_MACH_EUKREA_CPUIMX27 in arch/arm/tools/mach-types should probably
be renamed (once again).

1) An entry for CONFIG_MACH_CPUIMX27 was added to mach-types in v2.6.29.

2) The Kconfig symbol MACH_EUKREA_CPUIMX27 was added in v2.6.32.

3) That Kconfig symbol was renamed to MACH_CPUIMX27 in v2.6.34, too
match the reference in mach-types mentioned in 1).

4) But then the reference in mach-types was also renamed, to
MACH_EUKREA_CPUIMX27, in v3.1.

5) The net effect is that machine_is_eukrea_cpuimx27() equals 0 since
v3.1. That macro is used only once, in sound/soc/fsl/eukrea-tlv320.c. If
people still care about it then either the Kconfig symbol or the
reference in mach-types should be renamed.


Paul Bolle

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2014-06-10 15:01 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2014-06-10 14:35 ARM: MACH_CPUIMX27 or MACH_EUKREA_CPUIMX27? Paul Bolle
2014-06-10 15:01 ` Russell King - ARM Linux

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox