* [PATCH] ARM: mvebu: rename mvebu_defconfig to mvebu_v7_defconfig
@ 2014-02-10 18:19 Thomas Petazzoni
2014-02-10 18:33 ` Andrew Lunn
2014-02-11 19:11 ` Jason Cooper
0 siblings, 2 replies; 3+ messages in thread
From: Thomas Petazzoni @ 2014-02-10 18:19 UTC (permalink / raw)
To: linux-arm-kernel
With the merge of the Kirkwood support into arch/arm/mach-mvebu/, the
mvebu platform will no longer only contain ARMv7 compatible processors
(Armada 370, Armada XP, and soon Armada 375, Armada 38x and Dove), but
also ARMv5 compatible processors (Kirkwood, and hopefully Orion5x in
the future).
However, a single mvebu_defconfig cannot work, since it is not
possible to build a kernel that supports both ARMv5 and ARMv7
platforms in the same binary. As a consequence, this commit renames
mvebu_defconfig to mvebu_v7_defconfig, which is the configuration that
will build a kernel that supports all ARMv7 mvebu platforms. As
Kirkwood support gets merged into mach-mvebu, an additional
mvebu_v5_defconfig will be added.
Even though we already have a multi_v7_defconfig, the mvebu developers
found it more convenient for development to have a defconfig that
builds only the mvebu platforms.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
arch/arm/configs/{mvebu_defconfig => mvebu_v7_defconfig} | 0
1 file changed, 0 insertions(+), 0 deletions(-)
rename arch/arm/configs/{mvebu_defconfig => mvebu_v7_defconfig} (100%)
diff --git a/arch/arm/configs/mvebu_defconfig b/arch/arm/configs/mvebu_v7_defconfig
similarity index 100%
rename from arch/arm/configs/mvebu_defconfig
rename to arch/arm/configs/mvebu_v7_defconfig
--
1.8.3.2
^ permalink raw reply [flat|nested] 3+ messages in thread* [PATCH] ARM: mvebu: rename mvebu_defconfig to mvebu_v7_defconfig
2014-02-10 18:19 [PATCH] ARM: mvebu: rename mvebu_defconfig to mvebu_v7_defconfig Thomas Petazzoni
@ 2014-02-10 18:33 ` Andrew Lunn
2014-02-11 19:11 ` Jason Cooper
1 sibling, 0 replies; 3+ messages in thread
From: Andrew Lunn @ 2014-02-10 18:33 UTC (permalink / raw)
To: linux-arm-kernel
On Mon, Feb 10, 2014 at 07:19:59PM +0100, Thomas Petazzoni wrote:
> With the merge of the Kirkwood support into arch/arm/mach-mvebu/, the
> mvebu platform will no longer only contain ARMv7 compatible processors
> (Armada 370, Armada XP, and soon Armada 375, Armada 38x and Dove), but
> also ARMv5 compatible processors (Kirkwood, and hopefully Orion5x in
> the future).
>
> However, a single mvebu_defconfig cannot work, since it is not
> possible to build a kernel that supports both ARMv5 and ARMv7
> platforms in the same binary. As a consequence, this commit renames
> mvebu_defconfig to mvebu_v7_defconfig, which is the configuration that
> will build a kernel that supports all ARMv7 mvebu platforms. As
> Kirkwood support gets merged into mach-mvebu, an additional
> mvebu_v5_defconfig will be added.
>
> Even though we already have a multi_v7_defconfig, the mvebu developers
> found it more convenient for development to have a defconfig that
> builds only the mvebu platforms.
>
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
> arch/arm/configs/{mvebu_defconfig => mvebu_v7_defconfig} | 0
> 1 file changed, 0 insertions(+), 0 deletions(-)
> rename arch/arm/configs/{mvebu_defconfig => mvebu_v7_defconfig} (100%)
>
> diff --git a/arch/arm/configs/mvebu_defconfig b/arch/arm/configs/mvebu_v7_defconfig
> similarity index 100%
> rename from arch/arm/configs/mvebu_defconfig
> rename to arch/arm/configs/mvebu_v7_defconfig
Acked-by: Andrew Lunn <andrew@lunn.ch>
Thanks Thomas,
Andrew
^ permalink raw reply [flat|nested] 3+ messages in thread* [PATCH] ARM: mvebu: rename mvebu_defconfig to mvebu_v7_defconfig
2014-02-10 18:19 [PATCH] ARM: mvebu: rename mvebu_defconfig to mvebu_v7_defconfig Thomas Petazzoni
2014-02-10 18:33 ` Andrew Lunn
@ 2014-02-11 19:11 ` Jason Cooper
1 sibling, 0 replies; 3+ messages in thread
From: Jason Cooper @ 2014-02-11 19:11 UTC (permalink / raw)
To: linux-arm-kernel
On Mon, Feb 10, 2014 at 07:19:59PM +0100, Thomas Petazzoni wrote:
> With the merge of the Kirkwood support into arch/arm/mach-mvebu/, the
> mvebu platform will no longer only contain ARMv7 compatible processors
> (Armada 370, Armada XP, and soon Armada 375, Armada 38x and Dove), but
> also ARMv5 compatible processors (Kirkwood, and hopefully Orion5x in
> the future).
>
> However, a single mvebu_defconfig cannot work, since it is not
> possible to build a kernel that supports both ARMv5 and ARMv7
> platforms in the same binary. As a consequence, this commit renames
> mvebu_defconfig to mvebu_v7_defconfig, which is the configuration that
> will build a kernel that supports all ARMv7 mvebu platforms. As
> Kirkwood support gets merged into mach-mvebu, an additional
> mvebu_v5_defconfig will be added.
>
> Even though we already have a multi_v7_defconfig, the mvebu developers
> found it more convenient for development to have a defconfig that
> builds only the mvebu platforms.
>
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
> ---
> arch/arm/configs/{mvebu_defconfig => mvebu_v7_defconfig} | 0
> 1 file changed, 0 insertions(+), 0 deletions(-)
> rename arch/arm/configs/{mvebu_defconfig => mvebu_v7_defconfig} (100%)
>
> diff --git a/arch/arm/configs/mvebu_defconfig b/arch/arm/configs/mvebu_v7_defconfig
> similarity index 100%
> rename from arch/arm/configs/mvebu_defconfig
> rename to arch/arm/configs/mvebu_v7_defconfig
Applied to mvebu/defconfig with Andrew's Ack.
thx,
Jason.
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2014-02-11 19:11 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2014-02-10 18:19 [PATCH] ARM: mvebu: rename mvebu_defconfig to mvebu_v7_defconfig Thomas Petazzoni
2014-02-10 18:33 ` Andrew Lunn
2014-02-11 19:11 ` Jason Cooper
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox