Linux-ARM-Kernel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Will Deacon <will@kernel.org>
To: Viresh Kumar <viresh.kumar@linaro.org>
Cc: Rafael Wysocki <rjw@rjwysocki.net>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Sudeep Holla <sudeep.holla@arm.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	"Rafael J. Wysocki" <rafael@kernel.org>,
	linux-pm@vger.kernel.org,
	Vincent Guittot <vincent.guittot@linaro.org>,
	Ionela Voinescu <ionela.voinescu@arm.com>,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH V5 1/2] topology: Allow multiple entities to provide sched_freq_tick() callback
Date: Tue, 9 Mar 2021 09:19:00 +0000	[thread overview]
Message-ID: <20210309091900.GA27747@willie-the-truck> (raw)
In-Reply-To: <20210309041643.tcyv6rpto4k3sv5v@vireshk-i7>

On Tue, Mar 09, 2021 at 09:46:43AM +0530, Viresh Kumar wrote:
> On 08-03-21, 14:52, Will Deacon wrote:
> > On Mon, Mar 01, 2021 at 12:21:17PM +0530, Viresh Kumar wrote:
> > > +EXPORT_SYMBOL_GPL(topology_set_scale_freq_source);
> > 
> > I don't get why you need to export this in this patch. The arm64 topology
> > code is never built as a module.
> > 
> > > +EXPORT_SYMBOL_GPL(topology_clear_scale_freq_source);
> > 
> > Same here.
> > 
> > > +EXPORT_SYMBOL_GPL(freq_scale);
> > 
> > And here.
> 
> After this patch, any part of the kernel can use these
> helpers/variables to run their own implementation of tick-freq-scale
> and so this patch looked to be the right place for that to me.
> 
> And the second patch in the series updates the CPPC cpufreq driver
> (tristate) to use these exported symbols, so we have the first user
> who needs the exported symbols as well.

Ok, then how about putting the exports in their own patch that immediately
precedes the patch which uses them? I think that would make it much clearer.

> > This one probably wants a less generic name as well if it's going
> > to be exported.
> 
> x86 names it arch_freq_scale, perhaps we should stick to that instead.

Sounds like a improvement, thanks.

Will

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2021-03-09  9:20 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-01  6:51 [PATCH V5 0/2] cpufreq: cppc: Add support for frequency invariance Viresh Kumar
2021-03-01  6:51 ` [PATCH V5 1/2] topology: Allow multiple entities to provide sched_freq_tick() callback Viresh Kumar
2021-03-08 14:52   ` Will Deacon
2021-03-09  4:16     ` Viresh Kumar
2021-03-09  9:19       ` Will Deacon [this message]
2021-03-09 15:11   ` Ionela Voinescu
2021-03-10  2:54     ` Viresh Kumar

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210309091900.GA27747@willie-the-truck \
    --to=will@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=ionela.voinescu@arm.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=rafael@kernel.org \
    --cc=rjw@rjwysocki.net \
    --cc=sudeep.holla@arm.com \
    --cc=vincent.guittot@linaro.org \
    --cc=viresh.kumar@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox