* [PATCH v2] ARM: imx_v6_v7_defconfig: Update ONBOARD_USB_HUB to ONBOAD_USB_DEV
@ 2024-04-08 13:40 Fabio Estevam
2024-04-08 13:51 ` Javier Carrasco
0 siblings, 1 reply; 2+ messages in thread
From: Fabio Estevam @ 2024-04-08 13:40 UTC (permalink / raw)
To: shawnguo; +Cc: linux-arm-kernel, javier.carrasco, broonie, Fabio Estevam
From: Fabio Estevam <festevam@denx.de>
The onboard_usb_hub driver has been updated to support non-hub devices,
which has led to some renaming. Update to the new name accordingly.
Update to the new name (ONBOARD_USB_DEV) accordingly.
Based on similar fixes done by Javier Carrasco for other defconfigs.
Fixes: 31e7f6c015d9 ("usb: misc: onboard_hub: rename to onboard_dev")
Signed-off-by: Fabio Estevam <festevam@denx.de>
---
arch/arm/configs/imx_v6_v7_defconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/configs/imx_v6_v7_defconfig b/arch/arm/configs/imx_v6_v7_defconfig
index b06128da94e5..cf2480dce285 100644
--- a/arch/arm/configs/imx_v6_v7_defconfig
+++ b/arch/arm/configs/imx_v6_v7_defconfig
@@ -336,7 +336,7 @@ CONFIG_USB_SERIAL_FTDI_SIO=m
CONFIG_USB_SERIAL_OPTION=m
CONFIG_USB_TEST=m
CONFIG_USB_EHSET_TEST_FIXTURE=m
-CONFIG_USB_ONBOARD_HUB=y
+CONFIG_USB_ONBOARD_DEV=y
CONFIG_NOP_USB_XCEIV=y
CONFIG_USB_MXS_PHY=y
CONFIG_USB_GADGET=y
--
2.34.1
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
^ permalink raw reply related [flat|nested] 2+ messages in thread* Re: [PATCH v2] ARM: imx_v6_v7_defconfig: Update ONBOARD_USB_HUB to ONBOAD_USB_DEV
2024-04-08 13:40 [PATCH v2] ARM: imx_v6_v7_defconfig: Update ONBOARD_USB_HUB to ONBOAD_USB_DEV Fabio Estevam
@ 2024-04-08 13:51 ` Javier Carrasco
0 siblings, 0 replies; 2+ messages in thread
From: Javier Carrasco @ 2024-04-08 13:51 UTC (permalink / raw)
To: Fabio Estevam, shawnguo; +Cc: linux-arm-kernel, broonie, Fabio Estevam
On 4/8/24 15:40, Fabio Estevam wrote:
> From: Fabio Estevam <festevam@denx.de>
>
> The onboard_usb_hub driver has been updated to support non-hub devices,
> which has led to some renaming. Update to the new name accordingly.
>
> Update to the new name (ONBOARD_USB_DEV) accordingly.
>
> Based on similar fixes done by Javier Carrasco for other defconfigs.
>
> Fixes: 31e7f6c015d9 ("usb: misc: onboard_hub: rename to onboard_dev")
> Signed-off-by: Fabio Estevam <festevam@denx.de>
> ---
> arch/arm/configs/imx_v6_v7_defconfig | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/arm/configs/imx_v6_v7_defconfig b/arch/arm/configs/imx_v6_v7_defconfig
> index b06128da94e5..cf2480dce285 100644
> --- a/arch/arm/configs/imx_v6_v7_defconfig
> +++ b/arch/arm/configs/imx_v6_v7_defconfig
> @@ -336,7 +336,7 @@ CONFIG_USB_SERIAL_FTDI_SIO=m
> CONFIG_USB_SERIAL_OPTION=m
> CONFIG_USB_TEST=m
> CONFIG_USB_EHSET_TEST_FIXTURE=m
> -CONFIG_USB_ONBOARD_HUB=y
> +CONFIG_USB_ONBOARD_DEV=y
> CONFIG_NOP_USB_XCEIV=y
> CONFIG_USB_MXS_PHY=y
> CONFIG_USB_GADGET=y
Is that not a fix to 0bb36055c049 ("ARM: imx_v6_v7_defconfig: Select
CONFIG_USB_ONBOARD_HUB")?
The rename seems to be older in the history of linux-next.
Best regards,
Javier Carrasco
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2024-04-08 13:52 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2024-04-08 13:40 [PATCH v2] ARM: imx_v6_v7_defconfig: Update ONBOARD_USB_HUB to ONBOAD_USB_DEV Fabio Estevam
2024-04-08 13:51 ` Javier Carrasco
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).