* Re: [PATCH net-next v13 02/10] dt-bindings: phy: document the serdes PHY on sa8255p
[not found] <20260713-qcom-sa8255p-emac-v13-2-119f8699ef8e@oss.qualcomm.com>
@ 2026-07-24 22:45 ` Jakub Kicinski
0 siblings, 0 replies; only message in thread
From: Jakub Kicinski @ 2026-07-24 22:45 UTC (permalink / raw)
To: bartosz.golaszewski
Cc: Jakub Kicinski, andersson, konradybcio, robh, krzk+dt, conor+dt,
andrew+netdev, davem, edumazet, pabeni, mcoquelin.stm32,
alexandre.torgue, vkoul, peppe.cavallaro, wens, jernej.skrabec,
neil.armstrong, khilman, jbrunet, shawnguo, festevam, jan.petrous,
s32, mohd.anwar, romain.gantois, geert+renesas, magnus.damm,
mripard, christophe.roullier, brgl, radu, linux-arm-msm,
devicetree, linux-kernel, netdev, linux-stm32, linux-arm-kernel,
dfustini, linux-sunxi, linux-amlogic, linux-mips, imx,
linux-renesas-soc, linux-rockchip, sophgo, linux-riscv,
bartosz.golaszewski
This is an AI-generated review of your patch. The human sending this
email has considered the AI review valid, or at least plausible.
---
dt-bindings: phy: document the serdes PHY on sa8255p
This patch adds a YAML binding describing the SGMII/SerDes PHY present on
Qualcomm sa8255p platforms, where the same hardware as on sa8775p rev3 is
managed by firmware over SCMI.
> diff --git a/Documentation/devicetree/bindings/phy/qcom,sa8255p-dwmac-sgmii-phy.yaml b/Documentation/devicetree/bindings/phy/qcom,sa8255p-dwmac-sgmii-phy.yaml
> new file mode 100644
> index 000000000000..9e846e381555
> --- /dev/null
> +++ b/Documentation/devicetree/bindings/phy/qcom,sa8255p-dwmac-sgmii-phy.yaml
> @@ -0,0 +1,50 @@
[ ... ]
> + power-domains:
> + maxItems: 1
> +
> + power-domain-names:
> + maxItems: 1
[Low]
This isn't a bug, but would it be worth tightening the power-domain-names
schema to constrain the actual string value, along the lines of:
power-domain-names:
items:
- const: serdes
As written, only the number of entries is constrained and any arbitrary
string would pass validation, whereas the example uses "serdes":
power-domains = <&scmi7_dvfs 0>;
power-domain-names = "serdes";
Would matching the example with a const also help keep naming consistent
across DTs using this binding?
[ ... ]
--
pw-bot: cr
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2026-07-24 22:46 UTC | newest]
Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
[not found] <20260713-qcom-sa8255p-emac-v13-2-119f8699ef8e@oss.qualcomm.com>
2026-07-24 22:45 ` [PATCH net-next v13 02/10] dt-bindings: phy: document the serdes PHY on sa8255p Jakub Kicinski
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox