Linux-ARM-Kernel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "CK Hu (胡俊光)" <ck.hu@mediatek.com>
To: "angelogioacchino.delregno@collabora.com"
	<angelogioacchino.delregno@collabora.com>,
	"chunkuang.hu@kernel.org" <chunkuang.hu@kernel.org>
Cc: "linux-mediatek@lists.infradead.org"
	<linux-mediatek@lists.infradead.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"wenst@chromium.org" <wenst@chromium.org>,
	"kernel@collabora.com" <kernel@collabora.com>,
	"Nancy Lin (林欣螢)" <Nancy.Lin@mediatek.com>,
	"daniel@ffwll.ch" <daniel@ffwll.ch>,
	"p.zabel@pengutronix.de" <p.zabel@pengutronix.de>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"Nathan Lu (呂東霖)" <Nathan.Lu@mediatek.com>,
	"airlied@gmail.com" <airlied@gmail.com>,
	"linux-arm-kernel@lists.infradead.org"
	<linux-arm-kernel@lists.infradead.org>,
	"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>
Subject: Re: [PATCH 3/3] drm/mediatek: drm_ddp_comp: Add mtk_ddp_is_simple_comp() internal helper
Date: Fri, 22 Mar 2024 08:57:14 +0000	[thread overview]
Message-ID: <8de69b0bb56a36374a9dac87da9bbd6ea3143a7e.camel@mediatek.com> (raw)
In-Reply-To: <20240201125304.218467-4-angelogioacchino.delregno@collabora.com>

Hi, Angelo:

On Thu, 2024-02-01 at 13:53 +0100, AngeloGioacchino Del Regno wrote:
> Move the simple component check to a new mtk_ddp_is_simple_comp()
> internal helper to reduce code duplication.

Reviewed-by: CK Hu <ck.hu@mediatek.com>

> 
> Signed-off-by: AngeloGioacchino Del Regno <
> angelogioacchino.delregno@collabora.com>
> ---
>  drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c | 57 +++++++++++------
> ----
>  1 file changed, 31 insertions(+), 26 deletions(-)
> 
> diff --git a/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> b/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> index 539b526a6b0a..4ca2a02ada3c 100644
> --- a/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> +++ b/drivers/gpu/drm/mediatek/mtk_drm_ddp_comp.c
> @@ -575,6 +575,29 @@ unsigned int
> mtk_drm_find_possible_crtc_by_comp(struct drm_device *drm,
>  	return ret;
>  }
>  
> +static bool mtk_ddp_is_simple_comp(enum mtk_ddp_comp_type type)
> +{
> +	switch (type) {
> +	case MTK_DISP_AAL:
> +	case MTK_DISP_BLS:
> +	case MTK_DISP_CCORR:
> +	case MTK_DISP_COLOR:
> +	case MTK_DISP_GAMMA:
> +	case MTK_DISP_MERGE:
> +	case MTK_DISP_OVL:
> +	case MTK_DISP_OVL_2L:
> +	case MTK_DISP_OVL_ADAPTOR:
> +	case MTK_DISP_PWM:
> +	case MTK_DISP_RDMA:
> +	case MTK_DP_INTF:
> +	case MTK_DPI:
> +	case MTK_DSI:
> +		return false;
> +	default:
> +		return true;
> +	}
> +}
> +
>  int mtk_ddp_comp_init(struct device_node *node, struct mtk_ddp_comp
> *comp,
>  		      unsigned int comp_id)
>  {
> @@ -605,19 +628,13 @@ int mtk_ddp_comp_init(struct device_node *node,
> struct mtk_ddp_comp *comp,
>  	}
>  	comp->dev = &comp_pdev->dev;
>  
> -	if (type == MTK_DISP_AAL ||
> -	    type == MTK_DISP_BLS ||
> -	    type == MTK_DISP_CCORR ||
> -	    type == MTK_DISP_COLOR ||
> -	    type == MTK_DISP_GAMMA ||
> -	    type == MTK_DISP_MERGE ||
> -	    type == MTK_DISP_OVL ||
> -	    type == MTK_DISP_OVL_2L ||
> -	    type == MTK_DISP_PWM ||
> -	    type == MTK_DISP_RDMA ||
> -	    type == MTK_DPI ||
> -	    type == MTK_DP_INTF ||
> -	    type == MTK_DSI)
> +	/*
> +	 * Resources for simple components are retrieved here as those
> are
> +	 * managed in here without the need of more complex drivers;
> for
> +	 * the latter, their respective probe function will do the job,
> so
> +	 * we must avoid getting their resources here.
> +	 */
> +	if (!mtk_ddp_is_simple_comp(type))
>  		return 0;
>  
>  	priv = devm_kzalloc(comp->dev, sizeof(*priv), GFP_KERNEL);
> @@ -651,19 +668,7 @@ void mtk_ddp_comp_destroy(struct mtk_ddp_comp
> *comp)
>  		return;
>  
>  	/* Complex components are destroyed with their own remove
> callback */
> -	if (type == MTK_DISP_AAL ||
> -	    type == MTK_DISP_BLS ||
> -	    type == MTK_DISP_CCORR ||
> -	    type == MTK_DISP_COLOR ||
> -	    type == MTK_DISP_GAMMA ||
> -	    type == MTK_DISP_MERGE ||
> -	    type == MTK_DISP_OVL ||
> -	    type == MTK_DISP_OVL_2L ||
> -	    type == MTK_DISP_PWM ||
> -	    type == MTK_DISP_RDMA ||
> -	    type == MTK_DPI ||
> -	    type == MTK_DP_INTF ||
> -	    type == MTK_DSI)
> +	if (!mtk_ddp_is_simple_comp(mtk_ddp_matches[comp->id].type))
>  		return;
>  
>  	priv = dev_get_drvdata(comp->dev);
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2024-03-22  8:58 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-02-01 12:53 [PATCH 0/3] drm/mediatek: Fixes for DDP component search/destroy AngeloGioacchino Del Regno
2024-02-01 12:53 ` [PATCH 1/3] drm/mediatek: drm_ddp_comp: Fix and cleanup DDP component CRTC search AngeloGioacchino Del Regno
2024-03-22  7:30   ` CK Hu (胡俊光)
2024-02-01 12:53 ` [PATCH 2/3] drm/mediatek: Perform iounmap on simple DDP component destruction AngeloGioacchino Del Regno
2024-03-22  8:48   ` CK Hu (胡俊光)
2024-04-01 14:18     ` Chun-Kuang Hu
2024-02-01 12:53 ` [PATCH 3/3] drm/mediatek: drm_ddp_comp: Add mtk_ddp_is_simple_comp() internal helper AngeloGioacchino Del Regno
2024-03-22  8:57   ` CK Hu (胡俊光) [this message]
2024-03-21  9:05 ` [PATCH 0/3] drm/mediatek: Fixes for DDP component search/destroy AngeloGioacchino Del Regno

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8de69b0bb56a36374a9dac87da9bbd6ea3143a7e.camel@mediatek.com \
    --to=ck.hu@mediatek.com \
    --cc=Nancy.Lin@mediatek.com \
    --cc=Nathan.Lu@mediatek.com \
    --cc=airlied@gmail.com \
    --cc=angelogioacchino.delregno@collabora.com \
    --cc=chunkuang.hu@kernel.org \
    --cc=daniel@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=kernel@collabora.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=p.zabel@pengutronix.de \
    --cc=wenst@chromium.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox