Linux-ARM-Kernel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Suzuki K Poulose <suzuki.poulose@arm.com>
To: Marc Zyngier <maz@kernel.org>
Cc: kvm@vger.kernel.org, kvmarm@lists.linux.dev, will@kernel.org,
	catalin.marinas@arm.com, linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, steven.price@arm.com,
	aneesh.kumar@kernel.org, oupton@kernel.org, gshan@redhat.com,
	joey.gouly@arm.com, tabba@google.com, yuzenghui@huawei.com,
	linux-coco@lists.linux.dev, gankulkarni@os.amperecomputing.com,
	sdonthineni@nvidia.com, alpergun@google.com,
	fj0570is@fujitsu.com, WeiLin.Chang@arm.com,
	lpieralisi@kernel.org, enju.kohei@fujitsu.com
Subject: Re: [PATCH v17 05/20] KVM: arm64: Add vcpu load/put call backs for flavors
Date: Sun, 13 Sep 2026 17:50:00 +0100	[thread overview]
Message-ID: <90100d75-85a6-4ccb-8939-33446857536d@arm.com> (raw)
In-Reply-To: <867bkp78gs.wl-maz@kernel.org>

On 13/09/2026 11:26, Marc Zyngier wrote:
> On Tue, 08 Sep 2026 17:22:08 +0100,
> Suzuki K Poulose <suzuki.poulose@arm.com> wrote:
>>
>> Add VM flavor specific handlers for VCPU load/put, in an effort to make it
>> easier to follow the code.
>>
>> Based on a patch by Marc Zyngier
>>
>> Suggested-by: Marc Zyngier <maz@kernel.org>
>> Signed-off-by: Suzuki K Poulose <suzuki.poulose@arm.com>
>> ---
>>   arch/arm64/include/asm/kvm_host.h |   6 ++
>>   arch/arm64/kvm/arm.c              | 156 ++++++++++++++++++++++--------
>>   2 files changed, 123 insertions(+), 39 deletions(-)
>>
>> diff --git a/arch/arm64/include/asm/kvm_host.h b/arch/arm64/include/asm/kvm_host.h
>> index d0dccc9ad6aa8..b2e99c5cb1cd3 100644
>> --- a/arch/arm64/include/asm/kvm_host.h
>> +++ b/arch/arm64/include/asm/kvm_host.h
>> @@ -150,6 +150,11 @@ struct kvm_vmid {
>>   	atomic64_t id;

...

>> diff --git a/arch/arm64/kvm/arm.c b/arch/arm64/kvm/arm.c
>> index 51fc651267157..9af3bbb2f8c24 100644
>> --- a/arch/arm64/kvm/arm.c
>> +++ b/arch/arm64/kvm/arm.c
>> @@ -74,6 +74,8 @@ struct kvm_ioctl_cap_map {
>>   	long ext;
>>   };

...

>> +
>> +static void nvhe_vcpu_load(struct kvm_vcpu *vcpu, int cpu)
>> +{
>> +	vcpu_prepare_mmu(vcpu);
>> +	/*
>> +	 * The timer must be loaded before the vgic to correctly set up physical
>> +	 * interrupt deactivation in nested state (e.g. timer interrupt).
>> +	 */
> 
> This comment makes no sense here -- it is strictly for VHE, which is
> the only mode to implement NV. Same thing for the pKVM vcpu_load().

Ack, removed everywhere except for VHE.

> 
>> +	kvm_timer_vcpu_load(vcpu);
>> +	kvm_vgic_load(vcpu);
>> +	kvm_vcpu_load_debug(vcpu);
>> +	kvm_vcpu_load_fgt(vcpu);
>> +	kvm_arch_vcpu_load_fp(vcpu);
>> +	kvm_vcpu_pmu_restore_guest(vcpu);
>> +
>> +	vcpu_load_pvtime(vcpu);
>> +	vcpu_set_wfx_traps(vcpu);
>> +	vcpu_set_pauth_traps(vcpu);
>> +}
>> +
>> +static void pkvm_vcpu_load(struct kvm_vcpu *vcpu, int cpu)
>> +{
>> +	/*
>> +	 * The timer must be loaded before the vgic to correctly set up physical
>> +	 * interrupt deactivation in nested state (e.g. timer interrupt).
>> +	 */
>> +	kvm_timer_vcpu_load(vcpu);
>> +	kvm_vgic_load(vcpu);
>> +	kvm_vcpu_load_debug(vcpu);
>> +	kvm_vcpu_load_fgt(vcpu);
>> +	kvm_arch_vcpu_load_fp(vcpu);
>> +	kvm_vcpu_pmu_restore_guest(vcpu);
>> +
>> +	vcpu_load_pvtime(vcpu);
>> +	vcpu_set_wfx_traps(vcpu);
>> +
>> +	kvm_call_hyp_nvhe(__pkvm_vcpu_load,
>> +			  vcpu->kvm->arch.pkvm.handle,
>> +			  vcpu->vcpu_idx, vcpu->arch.hcr_el2);
>> +	kvm_call_hyp(__vgic_v3_restore_vmcr_aprs,
>> +		     &vcpu->arch.vgic_cpu.vgic_v3);
> 
> This can also be turned into a kvm_call_hyp_nvhe().

Ack

> 
>> +}
>> +

...

>> +
>> +static void pkvm_vcpu_put(struct kvm_vcpu *vcpu)
>> +{
>> +	kvm_call_hyp(__vgic_v3_save_aprs, &vcpu->arch.vgic_cpu.vgic_v3);
> 
> Same thing here about kvm_call_hyp_nvhe().

Ack

> 
>> +	kvm_call_hyp_nvhe(__pkvm_vcpu_put);
>> +
>> +	/* __pkvm_vcpu_put implies a sync of the state */
>> +	if (!kvm_vm_is_protected(vcpu->kvm))
>> +		vcpu_set_flag(vcpu, PKVM_HOST_STATE_DIRTY);
>> +
>> +	nvhe_vcpu_put(vcpu);
> 
> I'm not overly fond of this. Yes, that was in my original patch. But
> for example, we end-up calling kvm_arm_vmid_clear_active() for pKVM.
> This is harmless, but conceptually wrong.
> 
> I'd rather you expand the whole thing.

Done

> 
>> +}
>> +
>> +void kvm_arch_vcpu_put(struct kvm_vcpu *vcpu)
>> +{
>> +	vcpu->arch.vcpu_ops->vcpu_put(vcpu);
>>   	vcpu_clear_on_unsupported_cpu(vcpu);
>>   	vcpu->cpu = -1;
>>   }
>> @@ -2136,6 +2192,28 @@ int kvm_arch_vm_ioctl(struct file *filp, unsigned int ioctl, unsigned long arg)
>>   	}
>>   }

>> +
>> +static const struct kvm_vcpu_ops *arm64_vcpu_ops[] = {
>> +	[VM_VHE] = &vhe_vcpu_ops,
>> +	[VM_NVHE] = &nvhe_vcpu_ops,
>> +	[VM_PKVM] = &pkvm_vcpu_ops,
>> +	[VM_PROTECTED_PKVM] = &pkvm_vcpu_ops,
> 
> nit: my OCD-self wants to align all the '=' signs vertically...

I have switched to a macro initialiser, consistent with vm_s2_mmu_ops. 
So it looks much cleaner

Cheers
Suzuki



  reply	other threads:[~2026-09-13 16:50 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-08 16:22 [PATCH v17 00/20] KVM: arm64: CCA: Add basic plumbing for Realms Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 01/20] KVM: arm64: Include kvm_emulate.h in kvm/arm_psci.h Suzuki K Poulose
2026-09-09 11:20   ` Fuad Tabba
2026-09-08 16:22 ` [PATCH v17 02/20] KVM: arm64: Avoid including linux/kvm_host.h in kvm_pgtable.h Suzuki K Poulose
2026-09-09 11:22   ` Fuad Tabba
2026-09-09 11:24     ` Suzuki K Poulose
2026-09-10  3:40   ` Gavin Shan
2026-09-08 16:22 ` [PATCH v17 03/20] KVM: arm64: Track the type of VM in kvm_arch Suzuki K Poulose
2026-09-09 11:28   ` Fuad Tabba
2026-09-09 11:30     ` Suzuki K Poulose
2026-09-10  3:39   ` Gavin Shan
2026-09-10  6:35     ` Suzuki K Poulose
2026-09-11 16:14   ` Marc Zyngier
2026-09-11 17:06     ` Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 04/20] KVM: arm64: Refactor the vcpu_load to allow for VM specific callbacks Suzuki K Poulose
2026-09-10  4:00   ` Gavin Shan
2026-09-10 10:21     ` Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 05/20] KVM: arm64: Add vcpu load/put call backs for flavors Suzuki K Poulose
2026-09-10  5:33   ` Gavin Shan
2026-09-10  8:40     ` Suzuki K Poulose
2026-09-13 10:26   ` Marc Zyngier
2026-09-13 16:50     ` Suzuki K Poulose [this message]
2026-09-08 16:22 ` [PATCH v17 06/20] KVM: arm64: CCA: Add a new mode for supporting Realm guests Suzuki K Poulose
2026-09-09  3:26   ` Kohei Enju
2026-09-09 10:48     ` Marc Zyngier
2026-09-10  4:49       ` Kohei Enju
2026-09-10  5:53   ` Gavin Shan
2026-09-10  8:43     ` Suzuki K Poulose
2026-09-10  9:40       ` Gavin Shan
2026-09-08 16:22 ` [PATCH v17 07/20] KVM: arm64: CCA: Introduce Realms Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 08/20] KVM: arm64: coco: Add a helper to check if a VM is confidential compute guest Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 09/20] KVM: arm64: coco: arch_timer: Prevent timer offset configuration Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 10/20] KVM: arm64: coco: Disable Steal time accounting for coco guests Suzuki K Poulose
2026-09-09 11:45   ` Fuad Tabba
2026-09-09 11:52     ` Suzuki K Poulose
2026-09-09 12:23       ` Fuad Tabba
2026-09-10 10:27         ` Suzuki K Poulose
2026-09-10 12:42           ` Fuad Tabba
2026-09-10 12:44             ` Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 11/20] KVM: arm64: coco: Don't handle MMIO with no ISV Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 12/20] KVM: arm64: CCA: Support timers in realm RECs Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 13/20] KVM: arm64: CCA: Add VCPU load/put for Realms Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 14/20] KVM: arm64: CCA: Don't expose unsupported capabilities for realm guests Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 15/20] KVM: arm64: CCA: WARN on injected undef exceptions Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 16/20] KVM: arm64: CCA: Provide register list for unfinalized RECs Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 17/20] KVM: arm64: CCA: Provide an accurate register list Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 18/20] KVM: arm64: Reuse kvm_stage2_unmap_range in kvm_unmap_gfn_range Suzuki K Poulose
2026-09-09 11:50   ` Fuad Tabba
2026-09-08 16:22 ` [PATCH v17 19/20] KVM: arm64: Add VM specific callback for S2 MMU operations Suzuki K Poulose
2026-09-08 16:22 ` [PATCH v17 20/20] KVM: arm64: Abstract out memory abort handling Suzuki K Poulose
2026-09-09 13:18 ` [PATCH v17 00/20] KVM: arm64: CCA: Add basic plumbing for Realms Fuad Tabba
2026-09-09 13:52   ` Suzuki K Poulose

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=90100d75-85a6-4ccb-8939-33446857536d@arm.com \
    --to=suzuki.poulose@arm.com \
    --cc=WeiLin.Chang@arm.com \
    --cc=alpergun@google.com \
    --cc=aneesh.kumar@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=enju.kohei@fujitsu.com \
    --cc=fj0570is@fujitsu.com \
    --cc=gankulkarni@os.amperecomputing.com \
    --cc=gshan@redhat.com \
    --cc=joey.gouly@arm.com \
    --cc=kvm@vger.kernel.org \
    --cc=kvmarm@lists.linux.dev \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lpieralisi@kernel.org \
    --cc=maz@kernel.org \
    --cc=oupton@kernel.org \
    --cc=sdonthineni@nvidia.com \
    --cc=steven.price@arm.com \
    --cc=tabba@google.com \
    --cc=will@kernel.org \
    --cc=yuzenghui@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox