* [PATCH RESEND] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array
@ 2026-07-18 17:25 Uwe Kleine-König (The Capable Hub)
2026-07-19 13:15 ` Sven Peter
0 siblings, 1 reply; 2+ messages in thread
From: Uwe Kleine-König (The Capable Hub) @ 2026-07-18 17:25 UTC (permalink / raw)
To: Sven Peter, Janne Grunau, Marcel Holtmann, Luiz Augusto von Dentz
Cc: Neal Gompa, asahi, linux-arm-kernel, linux-bluetooth,
linux-kernel
Initializing a struct using list initializers is hard to read, compared
to that using named initializers is more ideomatic. Convert the macro
used to assign values in the driver's pci_device_id array accordingly.
This change doesn't introduce any changes to the compiled array on an
x86 and an arm64 build.
Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
---
Hello,
it seems in the bluetooth patchwork patches are archived automatically
after a month. And that even if there is recent activity. I consider
that very annoying for contributors.
So to get back on the list of considered patches, here comes a resend.
The original submission can be found at
https://lore.kernel.org/linux-bluetooth/20260504160940.2168650-2-u.kleine-koenig@baylibre.com
or
https://patchwork.kernel.org/project/bluetooth/patch/20260504160940.2168650-2-u.kleine-koenig@baylibre.com/
.
Best regards
Uwe
drivers/bluetooth/hci_bcm4377.c | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/bluetooth/hci_bcm4377.c b/drivers/bluetooth/hci_bcm4377.c
index 925d0a635945..89c317561bfb 100644
--- a/drivers/bluetooth/hci_bcm4377.c
+++ b/drivers/bluetooth/hci_bcm4377.c
@@ -2525,11 +2525,12 @@ static const struct bcm4377_hw bcm4377_hw_variants[] = {
},
};
-#define BCM4377_DEVID_ENTRY(id) \
- { \
- PCI_VENDOR_ID_BROADCOM, BCM##id##_DEVICE_ID, PCI_ANY_ID, \
- PCI_ANY_ID, PCI_CLASS_NETWORK_OTHER << 8, 0xffff00, \
- BCM##id \
+#define BCM4377_DEVID_ENTRY(id) \
+ { \
+ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, BCM ## id ## _DEVICE_ID), \
+ .class = PCI_CLASS_NETWORK_OTHER << 8, \
+ .class_mask = 0xffff00, \
+ .driver_data = BCM ## id, \
}
static const struct pci_device_id bcm4377_devid_table[] = {
base-commit: 0718283ab28bc3907e10b61a6b4be6fefa1cbb2f
--
2.55.0.11.g153666a7d9bb
^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [PATCH RESEND] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array
2026-07-18 17:25 [PATCH RESEND] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array Uwe Kleine-König (The Capable Hub)
@ 2026-07-19 13:15 ` Sven Peter
0 siblings, 0 replies; 2+ messages in thread
From: Sven Peter @ 2026-07-19 13:15 UTC (permalink / raw)
To: Uwe Kleine-König (The Capable Hub), Janne Grunau,
Marcel Holtmann, Luiz Augusto von Dentz
Cc: Neal Gompa, asahi, linux-arm-kernel, linux-bluetooth,
linux-kernel
On 7/18/26 19:25, Uwe Kleine-König (The Capable Hub) wrote:
> Initializing a struct using list initializers is hard to read, compared
> to that using named initializers is more ideomatic. Convert the macro
> used to assign values in the driver's pci_device_id array accordingly.
>
> This change doesn't introduce any changes to the compiled array on an
> x86 and an arm64 build.
>
> Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
> ---
Acked-by: Sven Peter <sven@kernel.org>
Best,
Sven
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-07-19 13:15 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-18 17:25 [PATCH RESEND] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array Uwe Kleine-König (The Capable Hub)
2026-07-19 13:15 ` Sven Peter
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox