From: Richard Guy Briggs <rgb@redhat.com>
To: Paul Moore <paul@paul-moore.com>
Cc: "Serge E. Hallyn" <serge.hallyn@ubuntu.com>,
James Morris <james.l.morris@oracle.com>,
linux-security-module@vger.kernel.org, linux-audit@redhat.com,
Andy Lutomirski <luto@kernel.org>,
Kees Cook <keescook@chromium.org>, Eric Paris <eparis@redhat.com>,
Paul Moore <pmoore@redhat.com>, Steve Grubb <sgrubb@redhat.com>
Subject: Re: [PATCH V4 00/10] capabilities: do not audit log BPRM_FCAPS on set*id
Date: Thu, 14 Sep 2017 01:54:05 -0400 [thread overview]
Message-ID: <20170914055405.GT3405@madcap2.tricolour.ca> (raw)
In-Reply-To: <CAHC9VhTa_f+5zMq0OMmMgofCF-5FnMS-dwtiPZb4iEhg4P7a3A@mail.gmail.com>
On 2017-09-08 13:02, Paul Moore wrote:
> On Tue, Sep 5, 2017 at 2:46 AM, Richard Guy Briggs <rgb@redhat.com> wrote:
> > The audit subsystem is adding a BPRM_FCAPS record when auditing setuid
> > application execution (SYSCALL execve). This is not expected as it was
> > supposed to be limited to when the file system actually had capabilities
> > in an extended attribute. It lists all capabilities making the event
> > really ugly to parse what is happening. The PATH record correctly
> > records the setuid bit and owner. Suppress the BPRM_FCAPS record on
> > set*id.
> >
> > See: https://github.com/linux-audit/audit-kernel/issues/16
> >
> > The first to eighth just massage the logic to make it easier to
> > understand. Some of them could be squashed together.
> >
> > The patch that resolves this issue is the ninth.
> >
> > It would be possible to address the original issue with a change of
> > "!uid_eq(new->euid, root_uid) || !uid_eq(new->uid, root_uid)"
> > to
> > "!(uid_eq(new->euid, root_uid) || uid_eq(new->uid, root_uid))"
> > but it took me long enough to understand this logic that I don't think
> > I'd be doing any favours by leaving it this difficult to understand.
> >
> > The final patch attempts to address all the conditions that need logging
> > based on mailing list conversations, recoginizing there is probably some
> > duplication in the logic.
> >
> > Passes: (ltp 20170516)
> > ./runltp -f syscalls -s cap
> > ./runltp -f securebits
> > ./runltp -f cap_bounds
> > ./runltp -f filecaps
> > make TARGETS=capabilities kselftest (when run locally, fails over nfs)
> >
> > v4
> > rebase on kees' 4.13 commoncap changes
> > minor local func renames
> >
> > v3
> > refactor into several sub-functions
> > convert most macros to inline funcs
> >
> > v2
> > use macros to clarify intent of calculations
> > fix original logic error
> > address additional audit logging conditions
> >
> > Richard Guy Briggs (10):
> > capabilities: factor out cap_bprm_set_creds privileged root
> > capabilities: intuitive names for cap gain status
> > capabilities: rename has_cap to has_fcap
> > capabilities: use root_priveleged inline to clarify logic
> > capabilities: use intuitive names for id changes
> > capabilities: move audit log decision to function
> > capabilities: remove a layer of conditional logic
> > capabilities: invert logic for clarity
> > capabilities: fix logic for effective root or real root
> > capabilities: audit log other surprising conditions
> >
> > security/commoncap.c | 179 ++++++++++++++++++++++++++++++++------------------
> > 1 files changed, 114 insertions(+), 65 deletions(-)
>
> I took a quick look at this latest revision and aside from some
> disagreements on style/formatting it looks okayish to me. However, I
> am going to walk back my previous I-can-take-this-via-the-audit-tree
> comments, I think this probably should go in via the capabilities
> (Serge) and/or linux-security (James) tree.
"okayish"? That sounds positive. :-) Can you offer a clear ack or reviewed-by?
> paul moore
- RGB
--
Richard Guy Briggs <rgb@redhat.com>
Sr. S/W Engineer, Kernel Security, Base Operating Systems
Remote, Ottawa, Red Hat Canada
IRC: rgb, SunRaycer
Voice: +1.647.777.2635, Internal: (81) 32635
next prev parent reply other threads:[~2017-09-14 5:54 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-09-05 6:46 [PATCH V4 00/10] capabilities: do not audit log BPRM_FCAPS on set*id Richard Guy Briggs
2017-09-05 6:46 ` [PATCH V4 01/10] capabilities: factor out cap_bprm_set_creds privileged root Richard Guy Briggs
2017-09-06 6:05 ` James Morris
2017-09-07 19:42 ` Kees Cook
2017-09-05 6:46 ` [PATCH V4 02/10] capabilities: intuitive names for cap gain status Richard Guy Briggs
2017-09-07 19:57 ` Kees Cook
2017-09-05 6:46 ` [PATCH V4 03/10] capabilities: rename has_cap to has_fcap Richard Guy Briggs
2017-09-08 18:15 ` Kees Cook
2017-09-05 6:46 ` [PATCH V4 04/10] capabilities: use root_priveleged inline to clarify logic Richard Guy Briggs
2017-09-08 18:18 ` Kees Cook
2017-09-05 6:46 ` [PATCH V4 05/10] capabilities: use intuitive names for id changes Richard Guy Briggs
2017-09-08 18:22 ` Kees Cook
2017-09-05 6:46 ` [PATCH V4 06/10] capabilities: move audit log decision to function Richard Guy Briggs
2017-09-08 18:23 ` Kees Cook
2017-09-05 6:46 ` [PATCH V4 07/10] capabilities: remove a layer of conditional logic Richard Guy Briggs
2017-09-08 18:26 ` Kees Cook
2017-09-05 6:46 ` [PATCH V4 08/10] capabilities: invert logic for clarity Richard Guy Briggs
2017-09-08 18:27 ` Kees Cook
2017-09-05 6:46 ` [PATCH V4 09/10] capabilities: fix logic for effective root or real root Richard Guy Briggs
2017-09-08 18:34 ` Kees Cook
2017-09-20 22:11 ` Paul Moore
2017-09-20 22:25 ` Kees Cook
2017-09-20 22:27 ` Paul Moore
2017-09-05 6:46 ` [PATCH V4 10/10] capabilities: audit log other surprising conditions Richard Guy Briggs
2017-09-08 18:36 ` Kees Cook
2017-09-20 22:22 ` Paul Moore
2017-09-08 17:02 ` [PATCH V4 00/10] capabilities: do not audit log BPRM_FCAPS on set*id Paul Moore
2017-09-14 5:54 ` Richard Guy Briggs [this message]
2017-09-14 6:46 ` Paul Moore
2017-09-14 6:49 ` Paul Moore
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170914055405.GT3405@madcap2.tricolour.ca \
--to=rgb@redhat.com \
--cc=eparis@redhat.com \
--cc=james.l.morris@oracle.com \
--cc=keescook@chromium.org \
--cc=linux-audit@redhat.com \
--cc=linux-security-module@vger.kernel.org \
--cc=luto@kernel.org \
--cc=paul@paul-moore.com \
--cc=pmoore@redhat.com \
--cc=serge.hallyn@ubuntu.com \
--cc=sgrubb@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox