* [PATCH] Bluetooth: Rename __l2cap_connect() to l2cap_connect()
@ 2012-10-12 11:40 Gustavo Padovan
2012-10-12 12:04 ` Andrei Emeltchenko
2012-10-12 23:48 ` Marcel Holtmann
0 siblings, 2 replies; 3+ messages in thread
From: Gustavo Padovan @ 2012-10-12 11:40 UTC (permalink / raw)
To: linux-bluetooth; +Cc: Gustavo Padovan
From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
Use of "__" usually means we need to call the function with a lock held,
which is not the case here.
Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
---
net/bluetooth/l2cap_core.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/net/bluetooth/l2cap_core.c b/net/bluetooth/l2cap_core.c
index 1d773b9..9060eec 100644
--- a/net/bluetooth/l2cap_core.c
+++ b/net/bluetooth/l2cap_core.c
@@ -3389,7 +3389,7 @@ static inline int l2cap_command_rej(struct l2cap_conn *conn,
return 0;
}
-static void __l2cap_connect(struct l2cap_conn *conn, struct l2cap_cmd_hdr *cmd,
+static void l2cap_connect(struct l2cap_conn *conn, struct l2cap_cmd_hdr *cmd,
u8 *data, u8 rsp_code, u8 amp_id)
{
struct l2cap_conn_req *req = (struct l2cap_conn_req *) data;
@@ -3508,7 +3508,7 @@ sendresp:
static int l2cap_connect_req(struct l2cap_conn *conn,
struct l2cap_cmd_hdr *cmd, u8 *data)
{
- __l2cap_connect(conn, cmd, data, L2CAP_CONN_RSP, 0);
+ l2cap_connect(conn, cmd, data, L2CAP_CONN_RSP, 0);
return 0;
}
--
1.7.11.4
^ permalink raw reply related [flat|nested] 3+ messages in thread
* Re: [PATCH] Bluetooth: Rename __l2cap_connect() to l2cap_connect()
2012-10-12 11:40 [PATCH] Bluetooth: Rename __l2cap_connect() to l2cap_connect() Gustavo Padovan
@ 2012-10-12 12:04 ` Andrei Emeltchenko
2012-10-12 23:48 ` Marcel Holtmann
1 sibling, 0 replies; 3+ messages in thread
From: Andrei Emeltchenko @ 2012-10-12 12:04 UTC (permalink / raw)
To: Gustavo Padovan; +Cc: linux-bluetooth, Gustavo Padovan
Hi Gustavo,
On Fri, Oct 12, 2012 at 07:40:40PM +0800, Gustavo Padovan wrote:
> From: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
>
> Use of "__" usually means we need to call the function with a lock held,
> which is not the case here.
I think it is OK to leave the function as is. We do not have such a strong
convention and we have too many locks anyway.
Best regards
Andrei Emeltchenko
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] Bluetooth: Rename __l2cap_connect() to l2cap_connect()
2012-10-12 11:40 [PATCH] Bluetooth: Rename __l2cap_connect() to l2cap_connect() Gustavo Padovan
2012-10-12 12:04 ` Andrei Emeltchenko
@ 2012-10-12 23:48 ` Marcel Holtmann
1 sibling, 0 replies; 3+ messages in thread
From: Marcel Holtmann @ 2012-10-12 23:48 UTC (permalink / raw)
To: Gustavo Padovan; +Cc: linux-bluetooth, Gustavo Padovan
Hi Gustavo,
> Use of "__" usually means we need to call the function with a lock held,
> which is not the case here.
>
> Signed-off-by: Gustavo Padovan <gustavo.padovan@collabora.co.uk>
> ---
> net/bluetooth/l2cap_core.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
Acked-by: Marcel Holtmann <marcel@holtmann.org>
> diff --git a/net/bluetooth/l2cap_core.c b/net/bluetooth/l2cap_core.c
> index 1d773b9..9060eec 100644
> --- a/net/bluetooth/l2cap_core.c
> +++ b/net/bluetooth/l2cap_core.c
> @@ -3389,7 +3389,7 @@ static inline int l2cap_command_rej(struct l2cap_conn *conn,
> return 0;
> }
>
> -static void __l2cap_connect(struct l2cap_conn *conn, struct l2cap_cmd_hdr *cmd,
> +static void l2cap_connect(struct l2cap_conn *conn, struct l2cap_cmd_hdr *cmd,
> u8 *data, u8 rsp_code, u8 amp_id)
Don't you need to fix the coding style for the indentation of the second
line.
Regards
Marcel
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2012-10-12 23:48 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2012-10-12 11:40 [PATCH] Bluetooth: Rename __l2cap_connect() to l2cap_connect() Gustavo Padovan
2012-10-12 12:04 ` Andrei Emeltchenko
2012-10-12 23:48 ` Marcel Holtmann
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox