* [PATCH] core: Rename authentication to key_type in mgmt_ltk_info
@ 2014-02-01 2:46 Marcel Holtmann
2014-02-02 2:01 ` Johan Hedberg
0 siblings, 1 reply; 2+ messages in thread
From: Marcel Holtmann @ 2014-02-01 2:46 UTC (permalink / raw)
To: linux-bluetooth
---
lib/mgmt.h | 2 +-
src/adapter.c | 8 ++++----
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/lib/mgmt.h b/lib/mgmt.h
index 58a651c1b10e..afd4e8b29ea3 100644
--- a/lib/mgmt.h
+++ b/lib/mgmt.h
@@ -177,7 +177,7 @@ struct mgmt_cp_load_link_keys {
struct mgmt_ltk_info {
struct mgmt_addr_info addr;
- uint8_t authenticated;
+ uint8_t type;
uint8_t master;
uint8_t enc_size;
uint16_t ediv;
diff --git a/src/adapter.c b/src/adapter.c
index 649fc7a957cf..18601eaa13dd 100644
--- a/src/adapter.c
+++ b/src/adapter.c
@@ -2444,7 +2444,7 @@ static void load_ltks(struct btd_adapter *adapter, GSList *keys)
memcpy(key->val, info->val, sizeof(info->val));
memcpy(key->rand, info->rand, sizeof(info->rand));
memcpy(&key->ediv, &info->ediv, sizeof(key->ediv));
- key->authenticated = info->authenticated;
+ key->type = info->authenticated;
key->master = info->master;
key->enc_size = info->enc_size;
}
@@ -5371,8 +5371,8 @@ static void new_long_term_key_callback(uint16_t index, uint16_t length,
ba2str(&addr->bdaddr, dst);
- DBG("hci%u new LTK for %s authenticated %u enc_size %u",
- adapter->dev_id, dst, ev->key.authenticated, ev->key.enc_size);
+ DBG("hci%u new LTK for %s type %u enc_size %u",
+ adapter->dev_id, dst, ev->key.type, ev->key.enc_size);
device = btd_adapter_get_device(adapter, &addr->bdaddr, addr->type);
if (!device) {
@@ -5386,7 +5386,7 @@ static void new_long_term_key_callback(uint16_t index, uint16_t length,
store_longtermkey(bdaddr, &key->addr.bdaddr,
key->addr.type, key->val, key->master,
- key->authenticated, key->enc_size,
+ key->type, key->enc_size,
key->ediv, key->rand);
device_set_bonded(device, TRUE);
--
1.8.5.3
^ permalink raw reply related [flat|nested] 2+ messages in thread
end of thread, other threads:[~2014-02-02 2:01 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2014-02-01 2:46 [PATCH] core: Rename authentication to key_type in mgmt_ltk_info Marcel Holtmann
2014-02-02 2:01 ` Johan Hedberg
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox