From: Szymon Janc <szymon.janc@tieto.com>
To: Lukasz Rymanowski <lukasz.rymanowski@tieto.com>
Cc: linux-bluetooth@vger.kernel.org
Subject: Re: [PATCH 0/8] shared/hfp: Add support for HFP HF - part 2
Date: Fri, 31 Oct 2014 20:32:49 +0100 [thread overview]
Message-ID: <2651171.yOGlzQfTJK@leonov> (raw)
In-Reply-To: <1412898652-12281-1-git-send-email-lukasz.rymanowski@tieto.com>
Hi Łukasz,
On Friday 10 of October 2014 01:50:44 Lukasz Rymanowski wrote:
> Following patches applies on:
> [PATCH v4 00/11] shared/hfp: Add support for HFP HF
>
> This is last part of patches for HFP HF in shared code. Next ones
> will be done in android part.
>
> This set mostly affects functions which help to parse hfp response.
> This has been unified so it can be used by hfp gw and hf.
>
> Also handling of +CME ERROR has been added and couple of unit tests.
>
> Sending it now as I want to get early comments on approach. Future work
> depends on it very much so I want to avoid too much rebasing.
>
> Lukasz Rymanowski (8):
> shared/hfp: Rename hfp_gw_result to hfp_context
> shared/hfp: Rename hfp_hf_result to common hfp_context
> shared/hfp: Rename functions operating on context
> shared/hfp: Add handling +CME ERROR to parser
> shared/hfp: Minor fix in container close function
> shared/hfp: Add hfp_context_get_range function
> unit/hfp: Add unit tests for parsing hfp_context
> unit/hfp: Add test for +CME ERROR: response
>
> android/handsfree.c | 184 +++++++++++++++++++++++-----------------------
> src/shared/hfp.c | 207
> ++++++++++++++++++++++++++++++++-------------------- src/shared/hfp.h |
> 28 ++++---
> unit/test-hfp.c | 111 +++++++++++++++++++++++++---
> 4 files changed, 334 insertions(+), 196 deletions(-)
Those looks OK to me. Please send rebased version (and add clarifying comment
in 4/8). Thanks.
--
BR
Szymon Janc
prev parent reply other threads:[~2014-10-31 19:32 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-10-09 23:50 [PATCH 0/8] shared/hfp: Add support for HFP HF - part 2 Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 1/8] shared/hfp: Rename hfp_gw_result to hfp_context Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 2/8] shared/hfp: Rename hfp_hf_result to common hfp_context Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 3/8] shared/hfp: Rename functions operating on context Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 4/8] shared/hfp: Add handling +CME ERROR to parser Lukasz Rymanowski
2014-10-30 9:43 ` Marcin Kraglak
2014-10-30 15:53 ` Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 5/8] shared/hfp: Minor fix in container close function Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 6/8] shared/hfp: Add hfp_context_get_range function Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 7/8] unit/hfp: Add unit tests for parsing hfp_context Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 8/8] unit/hfp: Add test for +CME ERROR: response Lukasz Rymanowski
2014-10-29 23:34 ` [PATCH 0/8] shared/hfp: Add support for HFP HF - part 2 Lukasz Rymanowski
2014-10-31 19:32 ` Szymon Janc [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2651171.yOGlzQfTJK@leonov \
--to=szymon.janc@tieto.com \
--cc=linux-bluetooth@vger.kernel.org \
--cc=lukasz.rymanowski@tieto.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox