Linux bluetooth development
 help / color / mirror / Atom feed
* [PATCH 0/8] shared/hfp: Add support for HFP HF - part 2
@ 2014-10-09 23:50 Lukasz Rymanowski
  2014-10-09 23:50 ` [PATCH 1/8] shared/hfp: Rename hfp_gw_result to hfp_context Lukasz Rymanowski
                   ` (9 more replies)
  0 siblings, 10 replies; 13+ messages in thread
From: Lukasz Rymanowski @ 2014-10-09 23:50 UTC (permalink / raw)
  To: linux-bluetooth; +Cc: Lukasz Rymanowski

Following patches applies on:
[PATCH v4 00/11] shared/hfp: Add support for HFP HF

This is last part of patches for HFP HF in shared code. Next ones
will be done in android part.

This set mostly affects functions which help to parse hfp response.
This has been unified so it can be used by hfp gw and hf.

Also handling of +CME ERROR has been added and couple of unit tests.

Sending it now as I want to get early comments on approach. Future work
depends on it very much so I want to avoid too much rebasing.

Lukasz Rymanowski (8):
  shared/hfp: Rename hfp_gw_result to hfp_context
  shared/hfp: Rename hfp_hf_result to common hfp_context
  shared/hfp: Rename functions operating on context
  shared/hfp: Add handling +CME ERROR to parser
  shared/hfp: Minor fix in container close function
  shared/hfp: Add hfp_context_get_range function
  unit/hfp: Add unit tests for parsing hfp_context
  unit/hfp: Add test for +CME ERROR: response

 android/handsfree.c | 184 +++++++++++++++++++++++-----------------------
 src/shared/hfp.c    | 207 ++++++++++++++++++++++++++++++++--------------------
 src/shared/hfp.h    |  28 ++++---
 unit/test-hfp.c     | 111 +++++++++++++++++++++++++---
 4 files changed, 334 insertions(+), 196 deletions(-)

-- 
1.8.4


^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2014-10-31 19:32 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2014-10-09 23:50 [PATCH 0/8] shared/hfp: Add support for HFP HF - part 2 Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 1/8] shared/hfp: Rename hfp_gw_result to hfp_context Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 2/8] shared/hfp: Rename hfp_hf_result to common hfp_context Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 3/8] shared/hfp: Rename functions operating on context Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 4/8] shared/hfp: Add handling +CME ERROR to parser Lukasz Rymanowski
2014-10-30  9:43   ` Marcin Kraglak
2014-10-30 15:53     ` Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 5/8] shared/hfp: Minor fix in container close function Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 6/8] shared/hfp: Add hfp_context_get_range function Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 7/8] unit/hfp: Add unit tests for parsing hfp_context Lukasz Rymanowski
2014-10-09 23:50 ` [PATCH 8/8] unit/hfp: Add test for +CME ERROR: response Lukasz Rymanowski
2014-10-29 23:34 ` [PATCH 0/8] shared/hfp: Add support for HFP HF - part 2 Lukasz Rymanowski
2014-10-31 19:32 ` Szymon Janc

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox