From: Szymon Janc <szymon.janc@tieto.com>
To: Lukasz Rymanowski <lukasz.rymanowski@tieto.com>
Cc: linux-bluetooth@vger.kernel.org
Subject: Re: [PATCH v2 00/10] shared\hfp: Add support for HFP-HF
Date: Wed, 05 Nov 2014 08:54:21 +0100 [thread overview]
Message-ID: <2683632.9sIy0RRORA@uw000953> (raw)
In-Reply-To: <1415007361-4177-1-git-send-email-lukasz.rymanowski@tieto.com>
Hi Łukasz,
On Monday 03 of November 2014 10:35:51 Lukasz Rymanowski wrote:
> This set is continuation of adding support for HFP-HF.
> Most of the patches is refactor of handling hfp result.
> No it is commong hfp_context which can be parsed by GW and HF
> with API funtions hfp_context_*
>
> There is also CME ERROR handling added and couple of unit test.
>
> v2
> * rebase
> * Handled Marcin comment.
> * Added two more patches for skipping field in hfp_context
>
> Lukasz Rymanowski (10):
> shared/hfp: Rename hfp_gw_result to hfp_context
> shared/hfp: Rename hfp_hf_result to common hfp_context
> shared/hfp: Rename functions operating on context
> shared/hfp: Add handling +CME ERROR to parser
> shared/hfp: Minor fix in container close function
> shared/hfp: Add hfp_context_get_range function
> unit/hfp: Add unit tests for parsing hfp_context
> unit/hfp: Add test for +CME ERROR: response
> shared/hfp: Add function to skip field in hfp_context
> unit/test-hfp: Test for skip hfp_context field
>
> android/handsfree.c | 184 ++++++++++++++++++++--------------------
> src/shared/hfp.c | 237 +++++++++++++++++++++++++++++++++-------------------
> src/shared/hfp.h | 35 ++++----
> unit/test-hfp.c | 136 +++++++++++++++++++++++++++---
> 4 files changed, 389 insertions(+), 203 deletions(-)
>
All patches applied, thanks.
--
Best regards,
Szymon Janc
prev parent reply other threads:[~2014-11-05 7:54 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-03 9:35 [PATCH v2 00/10] shared\hfp: Add support for HFP-HF Lukasz Rymanowski
2014-11-03 9:35 ` [PATCH v2 01/10] shared/hfp: Rename hfp_gw_result to hfp_context Lukasz Rymanowski
2014-11-03 9:35 ` [PATCH v2 02/10] shared/hfp: Rename hfp_hf_result to common hfp_context Lukasz Rymanowski
2014-11-03 9:35 ` [PATCH v2 03/10] shared/hfp: Rename functions operating on context Lukasz Rymanowski
2014-11-03 9:35 ` [PATCH v2 04/10] shared/hfp: Add handling +CME ERROR to parser Lukasz Rymanowski
2014-11-03 9:35 ` [PATCH v2 05/10] shared/hfp: Minor fix in container close function Lukasz Rymanowski
2014-11-03 9:35 ` [PATCH v2 06/10] shared/hfp: Add hfp_context_get_range function Lukasz Rymanowski
2014-11-03 9:35 ` [PATCH v2 07/10] unit/hfp: Add unit tests for parsing hfp_context Lukasz Rymanowski
2014-11-03 9:35 ` [PATCH v2 08/10] unit/hfp: Add test for +CME ERROR: response Lukasz Rymanowski
2014-11-03 9:36 ` [PATCH v2 09/10] shared/hfp: Add function to skip field in hfp_context Lukasz Rymanowski
2014-11-03 9:36 ` [PATCH v2 10/10] unit/test-hfp: Test for skip hfp_context field Lukasz Rymanowski
2014-11-05 7:54 ` Szymon Janc [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2683632.9sIy0RRORA@uw000953 \
--to=szymon.janc@tieto.com \
--cc=linux-bluetooth@vger.kernel.org \
--cc=lukasz.rymanowski@tieto.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox