Linux bluetooth development
 help / color / mirror / Atom feed
* [PATCH v2 00/10] shared\hfp: Add support for HFP-HF
@ 2014-11-03  9:35 Lukasz Rymanowski
  2014-11-03  9:35 ` [PATCH v2 01/10] shared/hfp: Rename hfp_gw_result to hfp_context Lukasz Rymanowski
                   ` (10 more replies)
  0 siblings, 11 replies; 12+ messages in thread
From: Lukasz Rymanowski @ 2014-11-03  9:35 UTC (permalink / raw)
  To: linux-bluetooth; +Cc: Lukasz Rymanowski

This set is continuation of adding support for HFP-HF.
Most of the patches is refactor of handling hfp result.
No it is commong hfp_context which can be parsed by GW and HF
with API funtions hfp_context_*

There is also CME ERROR handling added and couple of unit test.

v2
* rebase
* Handled Marcin comment.
* Added two more patches for skipping field in hfp_context 

Lukasz Rymanowski (10):
  shared/hfp: Rename hfp_gw_result to hfp_context
  shared/hfp: Rename hfp_hf_result to common hfp_context
  shared/hfp: Rename functions operating on context
  shared/hfp: Add handling +CME ERROR to parser
  shared/hfp: Minor fix in container close function
  shared/hfp: Add hfp_context_get_range function
  unit/hfp: Add unit tests for parsing hfp_context
  unit/hfp: Add test for +CME ERROR: response
  shared/hfp: Add function to skip field in hfp_context
  unit/test-hfp: Test for skip hfp_context field

 android/handsfree.c | 184 ++++++++++++++++++++--------------------
 src/shared/hfp.c    | 237 +++++++++++++++++++++++++++++++++-------------------
 src/shared/hfp.h    |  35 ++++----
 unit/test-hfp.c     | 136 +++++++++++++++++++++++++++---
 4 files changed, 389 insertions(+), 203 deletions(-)

-- 
1.8.4


^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2014-11-05  7:54 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2014-11-03  9:35 [PATCH v2 00/10] shared\hfp: Add support for HFP-HF Lukasz Rymanowski
2014-11-03  9:35 ` [PATCH v2 01/10] shared/hfp: Rename hfp_gw_result to hfp_context Lukasz Rymanowski
2014-11-03  9:35 ` [PATCH v2 02/10] shared/hfp: Rename hfp_hf_result to common hfp_context Lukasz Rymanowski
2014-11-03  9:35 ` [PATCH v2 03/10] shared/hfp: Rename functions operating on context Lukasz Rymanowski
2014-11-03  9:35 ` [PATCH v2 04/10] shared/hfp: Add handling +CME ERROR to parser Lukasz Rymanowski
2014-11-03  9:35 ` [PATCH v2 05/10] shared/hfp: Minor fix in container close function Lukasz Rymanowski
2014-11-03  9:35 ` [PATCH v2 06/10] shared/hfp: Add hfp_context_get_range function Lukasz Rymanowski
2014-11-03  9:35 ` [PATCH v2 07/10] unit/hfp: Add unit tests for parsing hfp_context Lukasz Rymanowski
2014-11-03  9:35 ` [PATCH v2 08/10] unit/hfp: Add test for +CME ERROR: response Lukasz Rymanowski
2014-11-03  9:36 ` [PATCH v2 09/10] shared/hfp: Add function to skip field in hfp_context Lukasz Rymanowski
2014-11-03  9:36 ` [PATCH v2 10/10] unit/test-hfp: Test for skip hfp_context field Lukasz Rymanowski
2014-11-05  7:54 ` [PATCH v2 00/10] shared\hfp: Add support for HFP-HF Szymon Janc

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox