Linux Btrfs filesystem development
 help / color / mirror / Atom feed
* [PATCH v6 0/4] btrfs: simplify the stripe buffer handling
@ 2026-07-05 11:54 Qu Wenruo
  2026-07-05 11:54 ` [PATCH v6 1/4] btrfs: remove SCRUB_MAX_SECTORS_PER_BLOCK Qu Wenruo
                   ` (3 more replies)
  0 siblings, 4 replies; 8+ messages in thread
From: Qu Wenruo @ 2026-07-05 11:54 UTC (permalink / raw)
  To: linux-btrfs

[CHANGELOG]
v6:
- Remove an ASSERT() that is no longer required
  Since there is no code that even bothers the underlying page layout
  anymore, the ASSERT() for the alignment of kvmalloc() returned address
  can be safely removed now.

v5:
- Use a simpler and faster way to implement calc_sector_number()
  Commit 81cea6cd7041 ("btrfs: remove btrfs_bio::fs_info by extracting
  it from btrfs_bio::inode") uses logical bytenr as the file_offset for
  scrub bbios, so we have a very reliable way to determine the bytenr,
  without the need to iterate through all the blocks.

  This removes the only the caller that iterates through the scrub block
  addresses, and should also completely shut sashiko up on the impossible
  unaligned address returned by kvmalloc(64K).

v4:
- Add a patch to extract the common handling of scrub read endios
  This is to reduce duplication and allow a single
  invalidate_kernel_vmap_range() call to be added with proper comments.

- Add a comment on why we need to call invalidate_kernel_vmap_range()
  for vmallocated memory
  It's mostly copied from dma-api doc.

v3:
- Add a patch to remove a unused macro

- Add new ASSERT()s to make sure the kvmallocated memory is page aligned
  The size is 64K, which is page aligned and power of 2, thus the
  resulted memory should at least be page aligned.

  Furthermore, we have several call sites using (BTRFS_STRIPE_LEN /
  PAGE_SIZE) or (BTRFS_STRIPE_LEN >> PAGE_SHIFT), add an build time
  assert to make sure our PAGE_SIZE is not larger than BTRFS_STRIPE_LEN.

v2:
- Fix a potential double-free during release_scrub_stripe()
  Reported by sashiko.

- Enlarge the scrub bbio to be able to contain the full buffer
  Since the buffer is allocated by kvmalloc(), it's possible that not
  all pages are physically contiguous.

  In that case we have to enlarge the bbio to contain
  (BTRFS_STRIPE_LEN >> PAGE_SHIFT) bvecs.

This is to use kvmalloc() to allocate a buffer for scrub, so that we do
not need to bother page-switching, and simplify the scrub progress.


Qu Wenruo (4):
  btrfs: remove SCRUB_MAX_SECTORS_PER_BLOCK
  btrfs: extract the common scrub read endio into a helper
  btrfs: scrub: implement calc_sector_number() in a faster way
  btrfs: use kvmalloc() for stripe buffer of scrub_stripe

 fs/btrfs/raid56.c |  18 +---
 fs/btrfs/raid56.h |   2 +-
 fs/btrfs/scrub.c  | 235 +++++++++++++++++++---------------------------
 3 files changed, 104 insertions(+), 151 deletions(-)

-- 
2.54.0


^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2026-07-09 10:26 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-05 11:54 [PATCH v6 0/4] btrfs: simplify the stripe buffer handling Qu Wenruo
2026-07-05 11:54 ` [PATCH v6 1/4] btrfs: remove SCRUB_MAX_SECTORS_PER_BLOCK Qu Wenruo
2026-07-09 10:02   ` Johannes Thumshirn
2026-07-05 11:54 ` [PATCH v6 2/4] btrfs: extract the common scrub read endio into a helper Qu Wenruo
2026-07-09 10:06   ` Johannes Thumshirn
2026-07-05 11:54 ` [PATCH v6 3/4] btrfs: scrub: implement calc_sector_number() in a faster way Qu Wenruo
2026-07-09 10:26   ` Johannes Thumshirn
2026-07-05 11:54 ` [PATCH v6 4/4] btrfs: use kvmalloc() for stripe buffer of scrub_stripe Qu Wenruo

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox