Linux cryptographic layer development
 help / color / mirror / Atom feed
* [PATCH 0/6] x86_64 assembler implementation of camellia block cipher
@ 2012-03-05 18:26 Jussi Kivilinna
  2012-03-05 18:26 ` [PATCH 1/6] crypto: testmgr - add more camellia test vectors Jussi Kivilinna
                   ` (6 more replies)
  0 siblings, 7 replies; 8+ messages in thread
From: Jussi Kivilinna @ 2012-03-05 18:26 UTC (permalink / raw)
  To: linux-crypto; +Cc: Herbert Xu, David S. Miller

Patches 1-2 add new tests and test vectors for camellia.
Patches 3-5 rename 'camellia' module to 'camellia_generic'.
Patch 6 adds x86_64 implementation of camellia.

Series depends on patch:
  http://marc.info/?l=linux-crypto-vger&m=133077599602729&w=2

---

Jussi Kivilinna (6):
      crypto: testmgr - add more camellia test vectors
      crypto: tcrypt - add more camellia tests
      crypto: camellia - rename camellia module to camellia_generic
      crypto: camellia - fix checkpatch warnings
      crypto: camellia - rename camellia.c to camellia_generic.c
      crypto: camellia - add assembler implementation for x86_64


 arch/x86/crypto/Makefile                 |    2 
 arch/x86/crypto/camellia-x86_64-asm_64.S |  521 ++++++++
 arch/x86/crypto/camellia_glue.c          | 1953 ++++++++++++++++++++++++++++++
 crypto/Kconfig                           |   18 
 crypto/Makefile                          |    2 
 crypto/camellia.c                        | 1098 -----------------
 crypto/camellia_generic.c                | 1102 +++++++++++++++++
 crypto/tcrypt.c                          |   12 
 crypto/testmgr.c                         |   45 +
 crypto/testmgr.h                         | 1383 +++++++++++++++++++++
 10 files changed, 5033 insertions(+), 1103 deletions(-)
 create mode 100644 arch/x86/crypto/camellia-x86_64-asm_64.S
 create mode 100644 arch/x86/crypto/camellia_glue.c
 delete mode 100644 crypto/camellia.c
 create mode 100644 crypto/camellia_generic.c

-- 

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2012-03-14  9:31 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2012-03-05 18:26 [PATCH 0/6] x86_64 assembler implementation of camellia block cipher Jussi Kivilinna
2012-03-05 18:26 ` [PATCH 1/6] crypto: testmgr - add more camellia test vectors Jussi Kivilinna
2012-03-05 18:26 ` [PATCH 2/6] crypto: tcrypt - add more camellia tests Jussi Kivilinna
2012-03-05 18:26 ` [PATCH 3/6] crypto: camellia - rename camellia module to camellia_generic Jussi Kivilinna
2012-03-05 18:26 ` [PATCH 4/6] crypto: camellia - fix checkpatch warnings Jussi Kivilinna
2012-03-05 18:26 ` [PATCH 5/6] crypto: camellia - rename camellia.c to camellia_generic.c Jussi Kivilinna
2012-03-05 18:26 ` [PATCH 6/6] crypto: camellia - add assembler implementation for x86_64 Jussi Kivilinna
2012-03-14  9:31 ` [PATCH 0/6] x86_64 assembler implementation of camellia block cipher Herbert Xu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox