Linux cryptographic layer development
 help / color / mirror / Atom feed
* [PATCH 0100/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:40 Baole Ni
  0 siblings, 0 replies; only message in thread
From: Baole Ni @ 2016-08-02 10:40 UTC (permalink / raw)
  To: marcel, gustavo, johan.hedberg, gregkh, hpa, x86
  Cc: linux-crypto, linux-kernel, mpm, herbert, jslaby, peter,
	lee.jones, chuansheng.liu, baolex.ni

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/char/hw_random/core.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/char/hw_random/core.c b/drivers/char/hw_random/core.c
index 9203f2d..09dce37 100644
--- a/drivers/char/hw_random/core.c
+++ b/drivers/char/hw_random/core.c
@@ -63,10 +63,10 @@ static u8 *rng_buffer, *rng_fillbuf;
 static unsigned short current_quality;
 static unsigned short default_quality; /* = 0; default to "off" */
 
-module_param(current_quality, ushort, 0644);
+module_param(current_quality, ushort, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(current_quality,
 		 "current hwrng entropy estimation per mill");
-module_param(default_quality, ushort, 0644);
+module_param(default_quality, ushort, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(default_quality,
 		 "default entropy content of hwrng per mill");
 
-- 
2.9.2

^ permalink raw reply related	[flat|nested] only message in thread

only message in thread, other threads:[~2016-08-02 11:19 UTC | newest]

Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2016-08-02 10:40 [PATCH 0100/1285] Replace numeric parameter like 0444 with macro Baole Ni

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox