From: Neeraj Kumar <s.neeraj@samsung.com>
To: Jonathan Cameron <jonathan.cameron@huawei.com>
Cc: linux-cxl@vger.kernel.org, nvdimm@lists.linux.dev,
linux-kernel@vger.kernel.org, gost.dev@samsung.com,
a.manzanares@samsung.com, vishak.g@samsung.com,
neeraj.kernel@gmail.com, cpgs@samsung.com
Subject: Re: [PATCH V3 06/20] nvdimm/region_label: Add region label update support
Date: Mon, 22 Sep 2025 18:42:20 +0530 [thread overview]
Message-ID: <20250922131220.kgkaxyzopprwdi7t@test-PowerEdge-R740xd> (raw)
In-Reply-To: <20250917163623.00004a3c@huawei.com>
[-- Attachment #1: Type: text/plain, Size: 7036 bytes --]
On 17/09/25 04:36PM, Jonathan Cameron wrote:
>On Wed, 17 Sep 2025 19:11:02 +0530
>Neeraj Kumar <s.neeraj@samsung.com> wrote:
>
>> Modified __pmem_label_update() to update region labels into LSA
>>
>I'm struggling to follow the use of the union for the two label types
>in much of this code. To me if feels like that should only be a thing
>at the init_labels() point on the basis I think it's only there that
>we need to handle both in the same storage.
>
>For the rest I'd just pay the small price of duplication that will
>occur if you just split he functions up.
I got your point Jonathan, Let me revisit it again.
>
>> Signed-off-by: Neeraj Kumar <s.neeraj@samsung.com>
>> ---
>> drivers/nvdimm/label.c | 269 ++++++++++++++++++++++++++------
>> drivers/nvdimm/label.h | 15 ++
>> drivers/nvdimm/namespace_devs.c | 12 ++
>> drivers/nvdimm/nd.h | 38 ++++-
>> include/linux/libnvdimm.h | 8 +
>> 5 files changed, 289 insertions(+), 53 deletions(-)
>>
[snip]
>> - nsl_set_position(ndd, nd_label, pos);
>> - nsl_set_isetcookie(ndd, nd_label, cookie);
>> - nsl_set_rawsize(ndd, nd_label, resource_size(res));
>> - nsl_set_lbasize(ndd, nd_label, nspm->lbasize);
>> - nsl_set_dpa(ndd, nd_label, res->start);
>> - nsl_set_slot(ndd, nd_label, slot);
>> - nsl_set_alignment(ndd, nd_label, 0);
>> - nsl_set_type_guid(ndd, nd_label, &nd_set->type_guid);
>> - nsl_set_region_uuid(ndd, nd_label, NULL);
>> - nsl_set_claim_class(ndd, nd_label, ndns->claim_class);
>> - nsl_calculate_checksum(ndd, nd_label);
>> - nd_dbg_dpa(nd_region, ndd, res, "\n");
>> + lsa_label = (union nd_lsa_label *) to_label(ndd, slot);
>
>This cast feels rather dubious.
>
>If the union makes sense in general, then this should be changed
>to return the union.
Sure, I will fix it in next patch-set
>
>> + memset(lsa_label, 0, sizeof_namespace_label(ndd));
>> +
>> + switch (ltype) {
>> + case NS_LABEL_TYPE:
>> + dev = &nspm->nsio.common.dev;
>> + rc = namespace_label_update(nd_region, nd_mapping,
>> + nspm, pos, flags, &lsa_label->ns_label,
>> + nsindex, slot);
>> + if (rc)
>> + return rc;
>> +
>> + break;
>> + case RG_LABEL_TYPE:
>> + dev = &nd_region->dev;
>> + region_label_update(nd_region, &lsa_label->region_label,
>> + nd_mapping, pos, flags, slot);
>> +
>> + break;
>> + }
>>
>> /* update label */
>> - offset = nd_label_offset(ndd, nd_label);
>> - rc = nvdimm_set_config_data(ndd, offset, nd_label,
>> + offset = nd_label_offset(ndd, &lsa_label->ns_label);
>
>This doesn't make sense as the type might be either an ns_label or a region_label.
>If there is a generic header (I'm guessing there is) then define that as part of the
>union with just the shared parts and use that to avoid any implication of what the type
>is in calls like this. Also make nd_label_offset() take the union not the specific bit.
Okay, I will update the signature of nd_label_offset() to use union and not the specific bit
>
>> + rc = nvdimm_set_config_data(ndd, offset, lsa_label,
>> sizeof_namespace_label(ndd));
>> if (rc < 0)
>> return rc;
>> @@ -955,8 +1054,10 @@ static int __pmem_label_update(struct nd_region *nd_region,
>> list_for_each_entry(label_ent, &nd_mapping->labels, list) {
>> if (!label_ent->label)
>> continue;
>> - if (test_and_clear_bit(ND_LABEL_REAP, &label_ent->flags) ||
>> - nsl_uuid_equal(ndd, label_ent->label, nspm->uuid))
>> +
>> + if (is_label_reapable(nd_set, nspm, ndd,
>> + (union nd_lsa_label *) label_ent->label,
>
>If we are going with the union that label_ent->label should be a union that
>we don't need to cast.
Sure, I will fix this in next patch-set
>
>> + ltype, &label_ent->flags))
>> reap_victim(nd_mapping, label_ent);
>> }
>>
>> @@ -966,19 +1067,20 @@ static int __pmem_label_update(struct nd_region *nd_region,
>> if (rc)
>> return rc;
>>
>> - list_for_each_entry(label_ent, &nd_mapping->labels, list)
>> - if (!label_ent->label) {
>> - label_ent->label = nd_label;
>> - nd_label = NULL;
>> - break;
>> - }
>> - dev_WARN_ONCE(&nspm->nsio.common.dev, nd_label,
>> - "failed to track label: %d\n",
>> - to_slot(ndd, nd_label));
>> - if (nd_label)
>> - rc = -ENXIO;
>> + list_for_each_entry(label_ent, &nd_mapping->labels, list) {
>> + if (label_ent->label)
>> + continue;
>
>This flow change is unrelated to the rest here. I'd push it back
>to the simpler patch that change the locking. Make sure to call it out there
>though. Or just don't do it and keep this patch a little more readable!
Yes, I will fix this in previous patch.
>> @@ -1091,12 +1209,19 @@ int nd_pmem_namespace_label_update(struct nd_region *nd_region,
>> count++;
>> WARN_ON_ONCE(!count);
>>
>> - rc = init_labels(nd_mapping, count);
>> + region_label_cnt = find_region_label_count(ndd, nd_mapping);
>> + /*
>> + * init_labels() scan labels and allocate new label based
>> + * on its second parameter (num_labels). Therefore to
>> + * allocate new namespace label also include previously
>> + * added region label
>> + */
>> + rc = init_labels(nd_mapping, count + region_label_cnt);
>> if (rc < 0)
>> return rc;
>>
>> rc = __pmem_label_update(nd_region, nd_mapping, nspm, i,
>> - NSLABEL_FLAG_UPDATING);
>> + NSLABEL_FLAG_UPDATING, NS_LABEL_TYPE);
>
>The amount of shared code in __pmem_label_update() across the two types in
>the union isn't that high. I'd be tempted to just split it for simplicity.
Sure, I will split it out in next patch-set.
>
>> if (rc)
>> return rc;
>> }
>>
[snip]
>> +int nd_region_label_update(struct nd_region *nd_region)
>> +{
>> + int rc;
>> +
>> + nvdimm_bus_lock(&nd_region->dev);
>> + rc = nd_pmem_region_label_update(nd_region);
>> + nvdimm_bus_unlock(&nd_region->dev);
>Looks like it would be worth introducing a
>DEFINE_GUARD() for this lock.
>
>Not necessarily in this series however.
Yes, Fixing it here will add some extra change.
>> +
>> + return rc;
>> +}
>> +EXPORT_SYMBOL_GPL(nd_region_label_update);
>> +
>> static int nd_namespace_label_update(struct nd_region *nd_region,
>> struct device *dev)
>> {
>> diff --git a/drivers/nvdimm/nd.h b/drivers/nvdimm/nd.h
>> index e362611d82cc..f04c042dcfa9 100644
>> --- a/drivers/nvdimm/nd.h
>> +++ b/drivers/nvdimm/nd.h
>
>> bool nsl_validate_type_guid(struct nvdimm_drvdata *ndd,
>> struct nd_namespace_label *nd_label, guid_t *guid);
>> enum nvdimm_claim_class nsl_get_claim_class(struct nvdimm_drvdata *ndd,
>> @@ -399,7 +432,10 @@ enum nd_label_flags {
>> struct nd_label_ent {
>> struct list_head list;
>> unsigned long flags;
>> - struct nd_namespace_label *label;
>> + union {
>> + struct nd_namespace_label *label;
>> + struct cxl_region_label *region_label;
>
>It is a bit odd to have a union above of the two types in
>here but then union the pointers here.
Yes Jonathan, I will replace this unnamed union with "union nd_lsa_label". I will
also help in avoid extra typecasting in is_region_label() and is_label_reapable()
Regards,
Neeraj
[-- Attachment #2: Type: text/plain, Size: 0 bytes --]
next prev parent reply other threads:[~2025-09-22 13:12 UTC|newest]
Thread overview: 89+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <CGME20250917134126epcas5p3e20c773759b91f70a1caa32b9f6f27ff@epcas5p3.samsung.com>
2025-09-17 13:40 ` [PATCH V3 00/20] Add CXL LSA 2.1 format support in nvdimm and cxl pmem Neeraj Kumar
2025-09-17 13:40 ` [PATCH V3 01/20] nvdimm/label: Introduce NDD_REGION_LABELING flag to set region label Neeraj Kumar
2025-09-19 23:10 ` Dave Jiang
2025-09-22 12:41 ` Neeraj Kumar
2025-09-17 13:40 ` [PATCH V3 02/20] nvdimm/label: CXL labels skip the need for 'interleave-set cookie' Neeraj Kumar
2025-09-19 23:31 ` Dave Jiang
2025-09-17 13:40 ` [PATCH V3 03/20] nvdimm/label: Modify nd_label_base() signature Neeraj Kumar
2025-09-19 21:42 ` Ira Weiny
2025-09-19 23:34 ` Dave Jiang
2025-09-22 12:44 ` Neeraj Kumar
2025-09-24 21:02 ` Alison Schofield
2025-09-29 14:07 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 04/20] nvdimm/label: Update mutex_lock() with guard(mutex)() Neeraj Kumar
2025-09-19 21:55 ` Ira Weiny
2025-09-22 12:56 ` Neeraj Kumar
2025-09-19 23:50 ` Dave Jiang
2025-09-20 17:44 ` Ira Weiny
2025-09-22 13:01 ` Neeraj Kumar
2025-09-24 21:42 ` Alison Schofield
2025-09-29 14:19 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 05/20] nvdimm/namespace_label: Add namespace label changes as per CXL LSA v2.1 Neeraj Kumar
2025-09-17 14:54 ` Jonathan Cameron
2025-09-19 22:00 ` Ira Weiny
2025-09-22 13:05 ` Neeraj Kumar
2025-09-19 23:59 ` Dave Jiang
2025-09-22 13:03 ` Neeraj Kumar
2025-09-23 21:48 ` Dave Jiang
2025-09-29 13:28 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 06/20] nvdimm/region_label: Add region label update support Neeraj Kumar
2025-09-17 15:36 ` Jonathan Cameron
2025-09-22 13:12 ` Neeraj Kumar [this message]
2025-10-06 16:56 ` Dave Jiang
2025-09-22 23:11 ` Dave Jiang
2025-09-29 13:24 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 07/20] nvdimm/region_label: Add region label delete support Neeraj Kumar
2025-09-22 21:37 ` Dave Jiang
2025-09-29 13:13 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 08/20] nvdimm/label: Include region label in slot validation Neeraj Kumar
2025-09-22 22:17 ` Dave Jiang
2025-09-29 13:17 ` Neeraj Kumar
2025-09-24 21:30 ` Alison Schofield
2025-09-29 14:10 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 09/20] nvdimm/namespace_label: Skip region label during ns label DPA reservation Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 10/20] nvdimm/namespace_label: Skip region label during namespace creation Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 11/20] nvdimm/region_label: Preserve cxl region information from region label Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 12/20] nvdimm/region_label: Export routine to fetch region information Neeraj Kumar
2025-09-23 20:23 ` Dave Jiang
2025-09-29 13:26 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 13/20] cxl/mem: Refactor cxl pmem region auto-assembling Neeraj Kumar
2025-09-23 22:37 ` Dave Jiang
2025-09-29 13:30 ` Neeraj Kumar
2025-10-06 15:55 ` Dave Jiang
2025-11-07 12:39 ` Neeraj Kumar
2025-11-12 15:55 ` Dave Jiang
2025-11-13 7:27 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 14/20] cxl/region: Add devm_cxl_pmem_add_region() for pmem region creation Neeraj Kumar
2025-09-23 23:50 ` Dave Jiang
2025-09-29 13:37 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 15/20] cxl: Add a routine to find cxl root decoder on cxl bus using cxl port Neeraj Kumar
2025-09-24 18:11 ` Dave Jiang
2025-09-29 13:40 ` Neeraj Kumar
2025-10-06 16:02 ` Dave Jiang
2025-09-17 13:41 ` [PATCH V3 16/20] cxl/mem: Preserve cxl root decoder during mem probe Neeraj Kumar
2025-09-24 18:23 ` Dave Jiang
2025-09-29 13:52 ` Neeraj Kumar
2025-09-24 21:38 ` Alison Schofield
2025-09-29 14:13 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 17/20] cxl/pmem: Preserve region information into nd_set Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 18/20] cxl/pmem_region: Prep patch to accommodate pmem_region attributes Neeraj Kumar
2025-09-24 18:53 ` Dave Jiang
2025-09-29 13:57 ` Neeraj Kumar
2025-10-06 16:06 ` Dave Jiang
2025-11-07 12:49 ` Neeraj Kumar
2025-11-12 15:40 ` Dave Jiang
2025-11-13 7:29 ` Neeraj Kumar
2025-10-06 16:09 ` Dave Jiang
2025-09-17 13:41 ` [PATCH V3 19/20] cxl/pmem_region: Add sysfs attribute cxl region label updation/deletion Neeraj Kumar
2025-09-24 20:25 ` Dave Jiang
2025-09-29 14:00 ` Neeraj Kumar
2025-09-17 13:41 ` [PATCH V3 20/20] cxl/pmem: Add CXL LSA 2.1 support in cxl pmem Neeraj Kumar
2025-09-24 20:47 ` Dave Jiang
2025-09-29 14:02 ` Neeraj Kumar
2025-10-06 16:13 ` Dave Jiang
2025-09-17 14:50 ` [PATCH V3 00/20] Add CXL LSA 2.1 format support in nvdimm and " Jonathan Cameron
2025-09-17 15:38 ` Dave Jiang
2025-09-22 12:36 ` Neeraj Kumar
2025-09-23 23:04 ` Alison Schofield
2025-09-29 13:33 ` Neeraj Kumar
[not found] <CGME20250917133038epcas5p3b2766b0deb83a3496855cdd334b6ecc2@epcas5p3.samsung.com>
2025-09-17 13:29 ` Neeraj Kumar
2025-09-17 13:29 ` [PATCH V3 06/20] nvdimm/region_label: Add region label update support Neeraj Kumar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250922131220.kgkaxyzopprwdi7t@test-PowerEdge-R740xd \
--to=s.neeraj@samsung.com \
--cc=a.manzanares@samsung.com \
--cc=cpgs@samsung.com \
--cc=gost.dev@samsung.com \
--cc=jonathan.cameron@huawei.com \
--cc=linux-cxl@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=neeraj.kernel@gmail.com \
--cc=nvdimm@lists.linux.dev \
--cc=vishak.g@samsung.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox