Linux CXL
 help / color / mirror / Atom feed
From: Dan Williams <dan.j.williams@intel.com>
To: <alison.schofield@intel.com>, Davidlohr Bueso <dave@stgolabs.net>,
	Jonathan Cameron <jonathan.cameron@huawei.com>,
	Dave Jiang <dave.jiang@intel.com>,
	Vishal Verma <vishal.l.verma@intel.com>,
	Ira Weiny <ira.weiny@intel.com>,
	Dan Williams <dan.j.williams@intel.com>
Cc: <linux-cxl@vger.kernel.org>
Subject: Re: [PATCH v3 0/4] XOR Math Fixups: translation & position
Date: Wed, 26 Jun 2024 18:52:24 -0700	[thread overview]
Message-ID: <667cc5d8c4d89_56392941e@dwillia2-xfh.jf.intel.com.notmuch> (raw)
In-Reply-To: <cover.1719275633.git.alison.schofield@intel.com>

alison.schofield@ wrote:
> From: Alison Schofield <alison.schofield@intel.com>
> 
> Changes in v3:
> - Patch 2: Perform the 'chunk' check on Modulo decodes only
> - Patch 1: Fold cxl_translate() into cxl_dpa_to_hpa()	(Jonathan)
>   Jonathan asked for a rename of cxl_translate to cxl_dpa_to_hpa()
>   but the latter already existed and the work of cxl_translate() was
>   minimal. They are now one.
> - Remove the mention of XOR's purpose in Patch 2 commit log (Dan)
> - Reword hamming weight wrt XORALLBITS code comment (Jonathan)
> - Post a unit test upstream[1]  (Dan, Jonathan)
> - Remove Reviewed-by Tags on Patch 1 & 2 due to rework
> - Add Diego's Tested-by tag to Patch 2,3
> 
> Link to v2:
> https://lore.kernel.org/cover.1714159486.git.alison.schofield@intel.com/
> 
> [1] https://lore.kernel.org/20240624210644.495563-1-alison.schofield@intel.com/
> 
> 
> Begin cover letter:
> 
> Rather than repeat the individual patch commit message content,
> let me describe the flow of this set:

For a future cover letter, a lead in like this does not capture
potential new reviewers compared to a boilerplate flow of:

"Kernel fails at X... this is bad because... here is the flow of the
patches to get the kernel back on track..."

> 
> Patch 1: Rename an existing fn - cxl_trace_hpa()-> cxl_dpa_to_hpa()
> A tiny, yet essential cleanup to take first.
> 
> Patch 2: cxl: Restore XOR'd position bits during address translation
> The problem fixed in this patch, bad HPA translations with XOR math,
> came to my attention recently. 
> 
> Patch 3 & Patch 4 are paired. Patch 3 presents the new method for
> verifying a target position in the list and Patch 4 removes the
> old method. These could be squashed.
> 
> FYI - the reason I don't present the code removal first is because
> I think it is easier to read the diff if I leave in the old root
> decoder call back setup for calc_hb, insert the new call back along
> the same path, and then rip out the defunct calc_hb. That's the
> way I created the patchset and it may be an easier way for reviewers
> to follow along with the root decoder callback setup.

If I did not say it before, I appreciate notes like this, and agree this
makes the patches easier to read.

      parent reply	other threads:[~2024-06-27  1:52 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-06-25  0:55 [PATCH v3 0/4] XOR Math Fixups: translation & position alison.schofield
2024-06-25  0:55 ` [PATCH v3 1/4] cxl/core: Rename cxl_trace_hpa() to cxl_dpa_to_hpa() alison.schofield
2024-06-27  1:45   ` Dan Williams
2024-06-25  0:55 ` [PATCH v3 2/4] cxl: Restore XOR'd position bits during address translation alison.schofield
2024-06-27  2:04   ` Dan Williams
2024-07-01  9:28   ` Fabio M. De Francesco
2024-07-01  9:42     ` Fabio M. De Francesco
2024-07-01 22:48     ` Alison Schofield
2024-06-25  0:55 ` [PATCH v3 3/4] cxl/region: Verify target positions using the ordered target list alison.schofield
2024-06-25  0:55 ` [PATCH v3 4/4] cxl: Remove defunct code calculating host bridge target positions alison.schofield
2024-06-27  1:52 ` Dan Williams [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=667cc5d8c4d89_56392941e@dwillia2-xfh.jf.intel.com.notmuch \
    --to=dan.j.williams@intel.com \
    --cc=alison.schofield@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=dave@stgolabs.net \
    --cc=ira.weiny@intel.com \
    --cc=jonathan.cameron@huawei.com \
    --cc=linux-cxl@vger.kernel.org \
    --cc=vishal.l.verma@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox