Devicetree
 help / color / mirror / Atom feed
From: Anton Vorontsov <cbouatmailru-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>
To: Grant Likely <grant.likely-s3s/WqlpOiPyB63q8FvJNQ@public.gmane.org>
Cc: sfr-3FnU+UHB4dNDw9hX6IcOSA@public.gmane.org,
	microblaze-uclinux-rVRm/Wmeqae7NGdpmJTKYQ@public.gmane.org,
	devicetree-discuss-uLR06cmDAlY/bJ5BZ2RsiQ@public.gmane.org,
	jeremy.kerr-Z7WLFzj8eWMS+FvcfC7Uqw@public.gmane.org,
	linuxppc-dev-uLR06cmDAlY/bJ5BZ2RsiQ@public.gmane.org
Subject: Re: [PATCH 6/6] of/device: populate platform_device (of_device) resource table on allocation
Date: Thu, 10 Jun 2010 21:10:29 +0400	[thread overview]
Message-ID: <20100610171029.GA18824@oksana.dev.rtsoft.ru> (raw)
In-Reply-To: <AANLkTimjIyclTWZZW1A26zOcWroK-bwOkmEqsLm4DINk-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>

On Thu, Jun 10, 2010 at 10:30:26AM -0600, Grant Likely wrote:
[...]
> C)
> struct of_device *alloc_function(int num_res)
> {
> 	struct device *ofdev;
> 	struct resource *res;
> 	ofdev = kzalloc(sizeof(*ofdev), GFP_KERNEL)
> 	if (!ofdev)
> 		return NULL;
> 	res = kzalloc((sizeof(*res) * num_res), GFP_KERNEL);
> 	if (!res) {
> 		kfree(ofdev);  /* or goto an error unwind label */
> 		return NULL;
> 	}
> 	res = (struct resource *)&ofdev[1];

You mean ofdev->resource = res; ?

> That being said, I'm looking at refactoring to use
> platform_device_alloc() instead, which is effectively option C. (which
> I'd normally avoid, but it removes otherwise duplicate code from
> drivers/of).

Sounds great!

Thanks,

-- 
Anton Vorontsov
email: cbouatmailru-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org
irc://irc.freenode.net/bd2

  parent reply	other threads:[~2010-06-10 17:10 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-06-08 14:26 [PATCH 0/6] OF device code merges and improvements Grant Likely
2010-06-08 14:26 ` [PATCH 1/6] of: Use full node name in resource structures Grant Likely
2010-06-08 14:26 ` [PATCH 2/6] of/device: merge of_device_uevent Grant Likely
2010-06-08 14:26 ` [PATCH 3/6] of: Modify of_device_get_modalias to be passed struct device Grant Likely
2010-06-08 14:26 ` [PATCH 4/6] of/device: Merge of_platform_bus_probe() Grant Likely
2010-06-08 14:26 ` [PATCH 5/6] of: Merge of_device_alloc Grant Likely
2010-06-08 14:26 ` [PATCH 6/6] of/device: populate platform_device (of_device) resource table on allocation Grant Likely
2010-06-08 15:57   ` Anton Vorontsov
     [not found]     ` <20100608155702.GA5419-wnGakbxT3iijyJ0x5qLZdcN33GVbZNy3@public.gmane.org>
2010-06-08 16:02       ` Grant Likely
     [not found]         ` <AANLkTinZT4z93SWxjce5oRZzmaQHtVnO96zsXO9OX2UZ-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
2010-06-08 16:46           ` Anton Vorontsov
2010-06-08 18:41             ` Grant Likely
2010-06-08 19:48               ` Anton Vorontsov
     [not found]                 ` <20100608194809.GA32732-wnGakbxT3iijyJ0x5qLZdcN33GVbZNy3@public.gmane.org>
2010-06-10  6:17                   ` Benjamin Herrenschmidt
2010-06-10 14:18                     ` Grant Likely
     [not found]                       ` <AANLkTilpUi1cazljWSFbzliY78RKyHUlvBshUD3NPHPv-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
2010-06-10 15:13                         ` M. Warner Losh
2010-06-10 15:47                           ` Anton Vorontsov
     [not found]                           ` <20100610.091357.513168276793712624.imp-uzTCJ5RojNnQT0dZR+AlfA@public.gmane.org>
2010-06-10 15:47                             ` Anton Vorontsov
2010-06-10 15:47                           ` Anton Vorontsov
     [not found]                           ` <20100610154741.GA7484@oksana.dev.rtsoft.ru>
     [not found]                             ` <20100610154741.GA7484-wnGakbxT3iijyJ0x5qLZdcN33GVbZNy3@public.gmane.org>
2010-06-10 16:01                               ` M. Warner Losh
2010-06-10 16:52                                 ` Anton Vorontsov
     [not found]                                   ` <20100610165243.GA18043-wnGakbxT3iijyJ0x5qLZdcN33GVbZNy3@public.gmane.org>
2010-06-10 17:09                                     ` Mitch Bradley
     [not found]                                       ` <4C111C34.1010708-D5eQfiDGL7eakBO8gow8eQ@public.gmane.org>
2010-06-10 17:20                                         ` Grant Likely
2010-06-10 17:09                                     ` M. Warner Losh
2010-06-11  1:14                                 ` Benjamin Herrenschmidt
2010-06-10 16:30                               ` Grant Likely
     [not found]                                 ` <AANLkTimjIyclTWZZW1A26zOcWroK-bwOkmEqsLm4DINk-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
2010-06-10 17:10                                   ` Anton Vorontsov [this message]
2010-06-10 17:21                                     ` Grant Likely

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100610171029.GA18824@oksana.dev.rtsoft.ru \
    --to=cbouatmailru-re5jqeeqqe8avxtiumwx3w@public.gmane.org \
    --cc=devicetree-discuss-uLR06cmDAlY/bJ5BZ2RsiQ@public.gmane.org \
    --cc=grant.likely-s3s/WqlpOiPyB63q8FvJNQ@public.gmane.org \
    --cc=jeremy.kerr-Z7WLFzj8eWMS+FvcfC7Uqw@public.gmane.org \
    --cc=linuxppc-dev-uLR06cmDAlY/bJ5BZ2RsiQ@public.gmane.org \
    --cc=microblaze-uclinux-rVRm/Wmeqae7NGdpmJTKYQ@public.gmane.org \
    --cc=sfr-3FnU+UHB4dNDw9hX6IcOSA@public.gmane.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox