Devicetree
 help / color / mirror / Atom feed
* [PATCH v1] riscv: dts: starfive: Unify regulator naming scheme
@ 2025-02-05 17:16 Shengyu Qu
  2025-02-07 12:46 ` Emil Renner Berthing
  2025-02-10 19:01 ` Conor Dooley
  0 siblings, 2 replies; 3+ messages in thread
From: Shengyu Qu @ 2025-02-05 17:16 UTC (permalink / raw)
  To: conor, kernel, robh, krzk+dt, paul.walmsley, palmer, aou,
	linux-riscv, devicetree, linux-kernel
  Cc: Shengyu Qu

Currently, there are 3 regulators defined in JH7110's common device tree,
but regulator names are mixed with "-" and "_". So unify them to "_",
which is more often to be seen in other dts files.

Signed-off-by: Shengyu Qu <wiagn233@outlook.com>
---
 arch/riscv/boot/dts/starfive/jh7110-common.dtsi | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/riscv/boot/dts/starfive/jh7110-common.dtsi b/arch/riscv/boot/dts/starfive/jh7110-common.dtsi
index 48fb5091b8176..dd2eefc295e5c 100644
--- a/arch/riscv/boot/dts/starfive/jh7110-common.dtsi
+++ b/arch/riscv/boot/dts/starfive/jh7110-common.dtsi
@@ -233,7 +233,7 @@ vdd_cpu: dcdc2 {
 				regulator-always-on;
 				regulator-min-microvolt = <500000>;
 				regulator-max-microvolt = <1540000>;
-				regulator-name = "vdd-cpu";
+				regulator-name = "vdd_cpu";
 			};
 
 			emmc_vdd: aldo4 {
-- 
2.48.1


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH v1] riscv: dts: starfive: Unify regulator naming scheme
  2025-02-05 17:16 [PATCH v1] riscv: dts: starfive: Unify regulator naming scheme Shengyu Qu
@ 2025-02-07 12:46 ` Emil Renner Berthing
  2025-02-10 19:01 ` Conor Dooley
  1 sibling, 0 replies; 3+ messages in thread
From: Emil Renner Berthing @ 2025-02-07 12:46 UTC (permalink / raw)
  To: Shengyu Qu, conor, kernel, robh, krzk+dt, paul.walmsley, palmer,
	aou, linux-riscv, devicetree, linux-kernel

Shengyu Qu wrote:
> Currently, there are 3 regulators defined in JH7110's common device tree,
> but regulator names are mixed with "-" and "_". So unify them to "_",
> which is more often to be seen in other dts files.
>
> Signed-off-by: Shengyu Qu <wiagn233@outlook.com>

Thanks!

Acked-by: Emil Renner Berthing <emil.renner.berthing@canonical.com>

> ---
>  arch/riscv/boot/dts/starfive/jh7110-common.dtsi | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/riscv/boot/dts/starfive/jh7110-common.dtsi b/arch/riscv/boot/dts/starfive/jh7110-common.dtsi
> index 48fb5091b8176..dd2eefc295e5c 100644
> --- a/arch/riscv/boot/dts/starfive/jh7110-common.dtsi
> +++ b/arch/riscv/boot/dts/starfive/jh7110-common.dtsi
> @@ -233,7 +233,7 @@ vdd_cpu: dcdc2 {
>  				regulator-always-on;
>  				regulator-min-microvolt = <500000>;
>  				regulator-max-microvolt = <1540000>;
> -				regulator-name = "vdd-cpu";
> +				regulator-name = "vdd_cpu";
>  			};
>
>  			emmc_vdd: aldo4 {
> --
> 2.48.1
>

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v1] riscv: dts: starfive: Unify regulator naming scheme
  2025-02-05 17:16 [PATCH v1] riscv: dts: starfive: Unify regulator naming scheme Shengyu Qu
  2025-02-07 12:46 ` Emil Renner Berthing
@ 2025-02-10 19:01 ` Conor Dooley
  1 sibling, 0 replies; 3+ messages in thread
From: Conor Dooley @ 2025-02-10 19:01 UTC (permalink / raw)
  To: conor, kernel, robh, krzk+dt, paul.walmsley, palmer, aou,
	linux-riscv, devicetree, linux-kernel, Shengyu Qu
  Cc: Conor Dooley

From: Conor Dooley <conor.dooley@microchip.com>

On Thu, 06 Feb 2025 01:16:35 +0800, Shengyu Qu wrote:
> Currently, there are 3 regulators defined in JH7110's common device tree,
> but regulator names are mixed with "-" and "_". So unify them to "_",
> which is more often to be seen in other dts files.
> 
> 

Applied to riscv-dt-for-next, thanks!

[1/1] riscv: dts: starfive: Unify regulator naming scheme
      https://git.kernel.org/conor/c/6b47db27468c

Thanks,
Conor.

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2025-02-10 19:02 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-02-05 17:16 [PATCH v1] riscv: dts: starfive: Unify regulator naming scheme Shengyu Qu
2025-02-07 12:46 ` Emil Renner Berthing
2025-02-10 19:01 ` Conor Dooley

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox