* [PATCH] dt-bindings: pinctrl: realtek,rtd1625: Fix input voltage property name
@ 2026-06-01 7:52 Yu-Chun Lin
2026-06-02 17:01 ` Conor Dooley
2026-06-08 22:47 ` Linus Walleij
0 siblings, 2 replies; 3+ messages in thread
From: Yu-Chun Lin @ 2026-06-01 7:52 UTC (permalink / raw)
To: linusw, robh, krzk+dt, conor+dt
Cc: tychang, eleanor.lin, linux-gpio, devicetree, linux-kernel,
cy.huang, stanley_chang, james.tai
The property 'input-voltage-microvolt' is a typo. Rename it to
'input-threshold-voltage-microvolt' to align with the standard pin
configuration defined in pincfg-node.yaml and parsed by pinconf-generic.c.
Fixes: f6ea7004e926 ("dt-bindings: pinctrl: realtek: Add RTD1625 pinctrl binding")
Signed-off-by: Yu-Chun Lin <eleanor.lin@realtek.com>
---
.../devicetree/bindings/pinctrl/realtek,rtd1625-pinctrl.yaml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Documentation/devicetree/bindings/pinctrl/realtek,rtd1625-pinctrl.yaml b/Documentation/devicetree/bindings/pinctrl/realtek,rtd1625-pinctrl.yaml
index 9562a043707e..adc5955a2047 100644
--- a/Documentation/devicetree/bindings/pinctrl/realtek,rtd1625-pinctrl.yaml
+++ b/Documentation/devicetree/bindings/pinctrl/realtek,rtd1625-pinctrl.yaml
@@ -110,7 +110,7 @@ patternProperties:
input-schmitt-disable: true
- input-voltage-microvolt:
+ input-threshold-voltage-microvolt:
description: |
Select the input receiver voltage domain for the pin.
Valid arguments are:
--
2.43.0
^ permalink raw reply related [flat|nested] 3+ messages in thread* Re: [PATCH] dt-bindings: pinctrl: realtek,rtd1625: Fix input voltage property name
2026-06-01 7:52 [PATCH] dt-bindings: pinctrl: realtek,rtd1625: Fix input voltage property name Yu-Chun Lin
@ 2026-06-02 17:01 ` Conor Dooley
2026-06-08 22:47 ` Linus Walleij
1 sibling, 0 replies; 3+ messages in thread
From: Conor Dooley @ 2026-06-02 17:01 UTC (permalink / raw)
To: Yu-Chun Lin
Cc: linusw, robh, krzk+dt, conor+dt, tychang, linux-gpio, devicetree,
linux-kernel, cy.huang, stanley_chang, james.tai
[-- Attachment #1: Type: text/plain, Size: 76 bytes --]
Acked-by: Conor Dooley <conor.dooley@microchip.com>
pw-bot: not-applicable
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] dt-bindings: pinctrl: realtek,rtd1625: Fix input voltage property name
2026-06-01 7:52 [PATCH] dt-bindings: pinctrl: realtek,rtd1625: Fix input voltage property name Yu-Chun Lin
2026-06-02 17:01 ` Conor Dooley
@ 2026-06-08 22:47 ` Linus Walleij
1 sibling, 0 replies; 3+ messages in thread
From: Linus Walleij @ 2026-06-08 22:47 UTC (permalink / raw)
To: Yu-Chun Lin
Cc: robh, krzk+dt, conor+dt, tychang, linux-gpio, devicetree,
linux-kernel, cy.huang, stanley_chang, james.tai
On Mon, Jun 1, 2026 at 9:52 AM Yu-Chun Lin <eleanor.lin@realtek.com> wrote:
> The property 'input-voltage-microvolt' is a typo. Rename it to
> 'input-threshold-voltage-microvolt' to align with the standard pin
> configuration defined in pincfg-node.yaml and parsed by pinconf-generic.c.
>
> Fixes: f6ea7004e926 ("dt-bindings: pinctrl: realtek: Add RTD1625 pinctrl binding")
> Signed-off-by: Yu-Chun Lin <eleanor.lin@realtek.com>
Patch applied!
Yours,
Linus Walleij
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2026-06-08 22:47 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-06-01 7:52 [PATCH] dt-bindings: pinctrl: realtek,rtd1625: Fix input voltage property name Yu-Chun Lin
2026-06-02 17:01 ` Conor Dooley
2026-06-08 22:47 ` Linus Walleij
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox