Devicetree
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Sebastian Reichel" <sebastian.reichel@collabora.com>
Cc: robh@kernel.org, vkoul@kernel.org, neil.armstrong@linaro.org,
	linux-phy@lists.infradead.org, devicetree@vger.kernel.org,
	conor+dt@kernel.org, olteanv@gmail.com
Subject: Re: [PATCH v12 18/36] phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit
Date: Fri, 10 Jul 2026 21:10:32 +0000	[thread overview]
Message-ID: <20260710211033.07D621F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260710-rockchip-usbdp-cleanup-v12-18-8b41a9a9bef0@collabora.com>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:

Pre-existing issues:
- [High] Hardware hang due to unclocked memory-mapped register access.
--

--- Patch [18]: [PATCH v12 18/36] phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit ---
commit 879ba283150f41ae77236ca40a0536af8b8e8236
Author: Sebastian Reichel <sebastian.reichel@collabora.com>

phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit

This patch renames the mode_change property to phy_needs_reinit to better
reflect that the PHY requires re-initialization not just on mode changes, but
also on cable orientation switches. This prepares the driver to handle DP
re-init properly on orientation changes.

> diff --git a/drivers/phy/rockchip/phy-rockchip-usbdp.c b/drivers/phy/rockchip/phy-rockchip-usbdp.c
> index 24108816e3b95..e44d19c9d1193 100644
> --- a/drivers/phy/rockchip/phy-rockchip-usbdp.c
> +++ b/drivers/phy/rockchip/phy-rockchip-usbdp.c
[ ... ]
> @@ -951,15 +951,15 @@ static int rk_udphy_power_on(struct rk_udphy *udphy, u8 mode)

[Severity: High]
This is a pre-existing issue, but can this lead to a system hang when the PHY
is unsupported?

Looking at rk_udphy_power_on(), if the requested mode is unsupported,
it returns 0 early without enabling the clocks:

drivers/phy/rockchip/phy-rockchip-usbdp.c:rk_udphy_power_on() {
	if (!(udphy->mode & mode)) {
		dev_info(udphy->dev, "mode 0x%02x is not support\n", mode);
		return 0;
	}
...
}

Because this returns 0 instead of an error code, rk_udphy_dp_phy_power_on()
assumes the PHY is clocked and proceeds to call rk_udphy_dp_lane_enable():

drivers/phy/rockchip/phy-rockchip-usbdp.c:rk_udphy_dp_phy_power_on() {
...
	ret = rk_udphy_power_on(udphy, UDPHY_MODE_DP);
	if (ret)
		goto unlock;

	rk_udphy_dp_lane_enable(udphy, udphy->dp_lanes);
...
}

This results in accessing memory-mapped PHY registers via pma_regmap when the
corresponding PHY clocks are gated. Could this trigger a synchronous external
abort and a kernel panic?

Additionally, this same sequence appears in rk_udphy_dp_phy_power_off()
which calls rk_udphy_dp_lane_enable(udphy, 0) unconditionally without checking
if the PHY was successfully powered on:

drivers/phy/rockchip/phy-rockchip-usbdp.c:rk_udphy_dp_phy_power_off() {
	mutex_lock(&udphy->mutex);
	rk_udphy_dp_lane_enable(udphy, 0);
	rk_udphy_power_off(udphy, UDPHY_MODE_DP);
...
}

Should rk_udphy_power_on() return an error like -EINVAL when the mode is not
supported, and should rk_udphy_dp_phy_power_off() avoid calling
rk_udphy_dp_lane_enable() if the PHY is not powered on?

>  
>  		if (udphy->mode & UDPHY_MODE_USB)
>  			rk_udphy_u3_port_disable(udphy, false);
> -		udphy->mode_change = false;
> -	} else if (udphy->mode_change) {
> +		udphy->phy_needs_reinit = false;
> +	} else if (udphy->phy_needs_reinit) {
>  		if (udphy->mode == UDPHY_MODE_DP)
>  			rk_udphy_u3_port_disable(udphy, true);
>  
>  		ret = rk_udphy_init(udphy);
>  		if (ret)
>  			return ret;
> -		udphy->mode_change = false;
> +		udphy->phy_needs_reinit = false;
>  	}
>  
>  	udphy->status |= mode;

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260710-rockchip-usbdp-cleanup-v12-0-8b41a9a9bef0@collabora.com?part=18

  reply	other threads:[~2026-07-10 21:10 UTC|newest]

Thread overview: 57+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-10 16:44 [PATCH v12 00/36] phy: rockchip: usbdp: Clean up the mess Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 01/36] dt-bindings: phy: rockchip-usbdp: add improved ports scheme Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 02/36] phy: rockchip: usbdp: Update mode_change after error handling Sebastian Reichel
2026-07-10 21:15   ` sashiko-bot
2026-07-10 16:44 ` [PATCH v12 03/36] phy: rockchip: usbdp: Do not lose USB3 PHY status Sebastian Reichel
2026-07-10 21:07   ` sashiko-bot
2026-07-10 16:44 ` [PATCH v12 04/36] phy: rockchip: usbdp: Fix devm_clk_bulk_get_all check Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 05/36] phy: rockchip: usbdp: Handle missing clock-names DT property gracefully Sebastian Reichel
2026-07-10 21:07   ` sashiko-bot
2026-07-10 16:44 ` [PATCH v12 06/36] phy: rockchip: usbdp: Drop seamless DP takeover Sebastian Reichel
2026-07-10 21:08   ` sashiko-bot
2026-07-10 16:44 ` [PATCH v12 07/36] phy: rockchip: usbdp: Keep clocks running on PHY re-init Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 08/36] phy: rockchip: usbdp: Amend SSC modulation deviation Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 09/36] phy: rockchip: usbdp: Fix LFPS detect threshold control Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 10/36] phy: rockchip: usbdp: Add missing mode_change update Sebastian Reichel
2026-07-10 21:13   ` sashiko-bot
2026-07-10 16:44 ` [PATCH v12 11/36] phy: rockchip: usbdp: Support single-lane DP Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 12/36] phy: rockchip: usbdp: Limit DP lane count to muxed lanes Sebastian Reichel
2026-07-10 21:08   ` sashiko-bot
2026-07-10 16:44 ` [PATCH v12 13/36] phy: rockchip: usbdp: Rename DP lane functions Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 14/36] phy: rockchip: usbdp: Use FIELD_PREP_WM16_CONST Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 15/36] phy: rockchip: usbdp: Cleanup DP lane selection function Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 16/36] phy: rockchip: usbdp: Register DP aux bridge Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 17/36] phy: rockchip: usbdp: Drop DP HPD handling Sebastian Reichel
2026-07-10 16:44 ` [PATCH v12 18/36] phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit Sebastian Reichel
2026-07-10 21:10   ` sashiko-bot [this message]
2026-07-10 16:44 ` [PATCH v12 19/36] phy: rockchip: usbdp: Re-init the PHY on orientation change Sebastian Reichel
2026-07-10 21:15   ` sashiko-bot
2026-07-10 16:44 ` [PATCH v12 20/36] phy: rockchip: usbdp: Factor out lane_mux_sel setup Sebastian Reichel
2026-07-10 21:16   ` sashiko-bot
2026-07-10 16:44 ` [PATCH v12 21/36] phy: rockchip: usbdp: Properly handle TYPEC_STATE_SAFE and TYPEC_STATE_USB Sebastian Reichel
2026-07-10 21:18   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 22/36] phy: rockchip: usbdp: Use guard functions for mutex Sebastian Reichel
2026-07-10 21:18   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 23/36] phy: rockchip: usbdp: Clear USB status on PHY exit Sebastian Reichel
2026-07-10 21:17   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 24/36] phy: rockchip: usbdp: Hold mutex in DP PHY configure Sebastian Reichel
2026-07-10 16:45 ` [PATCH v12 25/36] phy: rockchip: usbdp: Add some extra debug messages Sebastian Reichel
2026-07-10 16:45 ` [PATCH v12 26/36] phy: rockchip: usbdp: Avoid xHCI SErrors Sebastian Reichel
2026-07-10 21:20   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 27/36] phy: rockchip: usbdp: Handle rk_udphy_reset_deassert errors Sebastian Reichel
2026-07-10 21:17   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 28/36] phy: rockchip: usbdp: Only enable USB3 when not in high-speed mode Sebastian Reichel
2026-07-10 21:26   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 29/36] phy: core: add notifier infrastructure Sebastian Reichel
2026-07-10 16:45 ` [PATCH v12 30/36] usb: dwc3: core: support PHY reset notifications Sebastian Reichel
2026-07-10 21:20   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 31/36] phy: rockchip: usbdp: Add phy reset notification support Sebastian Reichel
2026-07-10 21:26   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 32/36] phy: rockchip: usbdp: Drop -EPROBE_DEFER hack Sebastian Reichel
2026-07-10 21:28   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 33/36] phy: rockchip: usbdp: Rename mode to hw_mode Sebastian Reichel
2026-07-10 21:23   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 34/36] phy: rockchip: usbdp: Fix power state handling Sebastian Reichel
2026-07-10 16:45 ` [PATCH v12 35/36] phy: rockchip: usbdp: Re-init PHY on mux change Sebastian Reichel
2026-07-10 21:27   ` sashiko-bot
2026-07-10 16:45 ` [PATCH v12 36/36] phy: rockchip: usbdp: Add USB-C state without DP enabled Sebastian Reichel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260710211033.07D621F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-phy@lists.infradead.org \
    --cc=neil.armstrong@linaro.org \
    --cc=olteanv@gmail.com \
    --cc=robh@kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    --cc=sebastian.reichel@collabora.com \
    --cc=vkoul@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox