Devicetree
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "David Heidelberg" <david@ixit.cz>
Cc: conor+dt@kernel.org, robh@kernel.org, media-ci@linuxtv.org,
	devicetree@vger.kernel.org
Subject: Re: [PATCH 2/2] arm64: dts: qcom: sdm845-shift-axolotl: Add actuator for main rear camera
Date: Wed, 29 Jul 2026 22:08:56 +0000	[thread overview]
Message-ID: <20260729220856.EEA4E1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260729-dw9714v-v1-2-3c479b3cf8c0@ixit.cz>

Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] Deprecated node name for the fixed regulator 'cam-bus-2p8-regulator'.
--

--- Patch [2]: [PATCH 2/2] arm64: dts: qcom: sdm845-shift-axolotl: Add actuator for main rear camera ---
commit 4edbb2eb79bd8137a526316cca12432942ca08b4
Author: David Heidelberg <david@ixit.cz>

arm64: dts: qcom: sdm845-shift-axolotl: Add actuator for main rear camera

This commit adds a fixed regulator and actuator node for the Dongwoon
DW9714V main rear camera actuator.

> diff --git a/arch/arm64/boot/dts/qcom/sdm845-shift-axolotl.dts b/arch/arm64/boot/dts/qcom/sdm845-shift-axolotl.dts
> index e31c784eff3de..6d0254e205850 100644
> --- a/arch/arm64/boot/dts/qcom/sdm845-shift-axolotl.dts
> +++ b/arch/arm64/boot/dts/qcom/sdm845-shift-axolotl.dts
> @@ -86,6 +86,32 @@ battery: battery {
>  		voltage-max-design-microvolt = <4400000>;
>  	};
>  
> +	/* SGM2036-2.8YUDH4G/TR */
> +	cam_bus_2p8: cam-bus-2p8-regulator {
> +		compatible = "regulator-fixed";

[Severity: Low]
Does this node name trigger a dtbs_check warning during validation?

The fixed-regulator schema typically expects node names to use a regulator- 
prefix to match its regex pattern. Naming this node regulator-cam-bus-2p8 
instead of cam-bus-2p8-regulator would match the preferred schema and avoid 
triggering a deprecated pattern warning during static analysis.

[ ... ]

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260729-dw9714v-v1-0-3c479b3cf8c0@ixit.cz?part=2

      reply	other threads:[~2026-07-29 22:08 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-29 21:53 [PATCH 0/2] Enable DW9714V camera focus coil on SHIFT 6MQ David Heidelberg via B4 Relay
2026-07-29 21:53 ` [PATCH 1/2] dt-bindings: media: i2c: dongwoon,dw9714: Document DW9714A and V variant David Heidelberg via B4 Relay
2026-07-29 22:03   ` sashiko-bot
2026-07-29 21:53 ` [PATCH 2/2] arm64: dts: qcom: sdm845-shift-axolotl: Add actuator for main rear camera David Heidelberg via B4 Relay
2026-07-29 22:08   ` sashiko-bot [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260729220856.EEA4E1F000E9@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=david@ixit.cz \
    --cc=devicetree@vger.kernel.org \
    --cc=media-ci@linuxtv.org \
    --cc=robh@kernel.org \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox