From: sashiko-bot@kernel.org
To: "James Hilliard" <james.hilliard1@gmail.com>
Cc: robh@kernel.org, lee@kernel.org, devicetree@vger.kernel.org,
mfd@lists.linux.dev, conor+dt@kernel.org
Subject: Re: [PATCH net-next v3 2/4] mfd: add X-Powers AC200 support
Date: Fri, 07 Aug 2026 01:25:50 +0000 [thread overview]
Message-ID: <20260807012551.3B9CC1F00A3D@smtp.kernel.org> (raw)
In-Reply-To: <20260805-submit-acx00-of-dynamic-v1-v3-2-32c3210a6f25@gmail.com>
Thank you for your contribution! Sashiko AI review found 3 potential issue(s) to consider:
- [Low] The commit message prefix does not follow the required MFD subsystem format.
- [Low] The private data structure instance uses the device name instead of 'ddata'.
- [Low] The `i2c_device_id` array does not use named initializers.
--
--- Patch [2]: [PATCH net-next v3 2/4] mfd: add X-Powers AC200 support ---
commit f27704a7e16fcc27a2ce774a23d85d9a4464373b
Author: James Hilliard <james.hilliard1@gmail.com>
mfd: add X-Powers AC200 support
This commit adds core MFD support for the X-Powers AC200 mixed-signal companion
IC. It enables package supplies and input clock, initializes the paged regmap,
and sets up basic chip reset and teardown handling.
> mfd: add X-Powers AC200 support
[Severity: Low]
This isn't a bug, but does the commit message prefix follow the MFD subsystem
formatting guidelines? The expected format requires a driver name and a
capitalized description, such as mfd: ac200: Add X-Powers AC200 support.
> diff --git a/drivers/mfd/ac200.c b/drivers/mfd/ac200.c
> index 0000000000000..e8346a3faad5e
> --- /dev/null
> +++ b/drivers/mfd/ac200.c
[ ... ]
> +static int ac200_probe(struct i2c_client *client)
> +{
> + struct device *dev = &client->dev;
> + struct ac200 *ac200;
[Severity: Low]
This isn't a bug, but should the private data structure instance be named
ddata instead of ac200? The MFD subsystem guidelines prefer the use of ddata
for variable instances to avoid hard-coding implementation details.
[ ... ]
> +static void ac200_shutdown(struct i2c_client *client)
> +{
> + struct ac200 *ac200 = i2c_get_clientdata(client);
[Severity: Low]
This isn't a bug, but similar to ac200_probe(), should this use the ddata
naming convention for the variable instance?
[ ... ]
> +static const struct i2c_device_id ac200_i2c_ids[] = {
> + { "ac200" },
> + { }
> +};
[Severity: Low]
This isn't a bug, but should this array use named initializers to comply with
I2C subsystem initialization rules? For example, using { .name = "ac200" }.
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260805-submit-acx00-of-dynamic-v1-v3-0-32c3210a6f25@gmail.com?part=2
next prev parent reply other threads:[~2026-08-07 1:25 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-06 1:24 [PATCH net-next v3 0/4] net: phy: add X-Powers AC200/AC300 EPHY support James Hilliard
2026-08-06 1:24 ` [PATCH net-next v3 1/4] dt-bindings: mfd: x-powers: add AC200 James Hilliard
2026-08-06 9:34 ` Jagielski, Jedrzej
2026-08-07 1:24 ` sashiko-bot
2026-08-06 1:24 ` [PATCH net-next v3 2/4] mfd: add X-Powers AC200 support James Hilliard
2026-08-07 1:25 ` sashiko-bot [this message]
2026-08-06 1:24 ` [PATCH net-next v3 3/4] dt-bindings: net: x-powers: add AC200/AC300 EPHY packages James Hilliard
2026-08-07 1:25 ` sashiko-bot
2026-08-06 1:24 ` [PATCH net-next v3 4/4] net: phy: add X-Powers AC200/AC300 EPHY driver James Hilliard
2026-08-07 1:25 ` sashiko-bot
2026-08-06 9:18 ` [PATCH net-next v3 0/4] net: phy: add X-Powers AC200/AC300 EPHY support Jagielski, Jedrzej
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260807012551.3B9CC1F00A3D@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=james.hilliard1@gmail.com \
--cc=lee@kernel.org \
--cc=mfd@lists.linux.dev \
--cc=robh@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox