* [PATCH 1/2] drm: fix spelling mistakes in comments and documentation
@ 2026-05-31 4:59 Gustavo Kenji Mendonça Kaneko
2026-05-31 4:59 ` [PATCH 2/2] drm/amd/display: rename timeout_occured to timeout_occurred Gustavo Kenji Mendonça Kaneko
0 siblings, 1 reply; 2+ messages in thread
From: Gustavo Kenji Mendonça Kaneko @ 2026-05-31 4:59 UTC (permalink / raw)
To: dri-devel
Cc: airlied, simona, alexander.deucher, christian.koenig,
harry.wentland, corbet, amd-gfx, linux-doc, linux-kernel,
Gustavo Kenji Mendonça Kaneko
Fix multiple spelling mistakes across the DRM subsystem:
- 'occured' -> 'occurred' in:
- drm_debugfs_crc.h
- amdgpu_ctx.c
- amdgpu_ids.c (x2)
- amdgpu_job.h
- radeon_fence.c (x2)
- 'fucntions' -> 'functions' in Documentation/gpu/todo.rst
- 'doesn't exists' -> 'doesn't exist' in amdgpu_gmc.h
Signed-off-by: Gustavo Kenji Mendonça Kaneko <kaneko.dev@pm.me>
---
Documentation/gpu/todo.rst | 2 +-
drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c | 2 +-
drivers/gpu/drm/amd/amdgpu/amdgpu_gmc.h | 2 +-
drivers/gpu/drm/amd/amdgpu/amdgpu_ids.c | 4 ++--
drivers/gpu/drm/amd/amdgpu/amdgpu_job.h | 2 +-
drivers/gpu/drm/radeon/radeon_fence.c | 4 ++--
include/drm/drm_debugfs_crc.h | 2 +-
7 files changed, 9 insertions(+), 9 deletions(-)
diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
index bc9f14c8a2ec..841e4e986c48 100644
--- a/Documentation/gpu/todo.rst
+++ b/Documentation/gpu/todo.rst
@@ -55,7 +55,7 @@ There are still drivers that use drm_simple_display_pipe. The task here is to
convert them to use regular atomic helpers. Search for a driver that calls
drm_simple_display_pipe_init() and inline all helpers from drm_simple_kms_helper.c
into the driver, such that no simple-KMS interfaces are required. Please also
-rename all inlined fucntions according to driver conventions.
+rename all inlined functions according to driver conventions.
Contact: Thomas Zimmermann, respective driver maintainer
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c
index 7af86a32c0c5..e5884bb4d63a 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_ctx.c
@@ -564,7 +564,7 @@ static int amdgpu_ctx_query(struct amdgpu_device *adev,
out->state.flags = 0x0;
out->state.hangs = 0x0;
- /* determine if a GPU reset has occured since the last call */
+ /* determine if a GPU reset has occurred since the last call */
reset_counter = atomic_read(&adev->gpu_reset_counter);
/* TODO: this should ideally return NO, GUILTY, or INNOCENT. */
if (ctx->reset_counter_query == reset_counter)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_gmc.h b/drivers/gpu/drm/amd/amdgpu/amdgpu_gmc.h
index 6ab4c1e297fc..85a0d9bcba16 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_gmc.h
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_gmc.h
@@ -39,7 +39,7 @@
0xff00000000000000ULL : 0xffff800000000000ULL)
/*
- * Hardware is programmed as if the hole doesn't exists with start and end
+ * Hardware is programmed as if the hole doesn't exist with start and end
* address values.
*
* This mask is used to remove the upper 16bits of the VA and so come up with
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_ids.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_ids.c
index 124fb38eb465..095ab609623f 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_ids.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_ids.c
@@ -161,12 +161,12 @@ void amdgpu_pasid_free_delayed(struct dma_resv *resv,
*/
/**
- * amdgpu_vmid_had_gpu_reset - check if reset occured since last use
+ * amdgpu_vmid_had_gpu_reset - check if reset occurred since last use
*
* @adev: amdgpu_device pointer
* @id: VMID structure
*
- * Check if GPU reset occured since last use of the VMID.
+ * Check if GPU reset occurred since last use of the VMID.
*/
bool amdgpu_vmid_had_gpu_reset(struct amdgpu_device *adev,
struct amdgpu_vmid *id)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_job.h b/drivers/gpu/drm/amd/amdgpu/amdgpu_job.h
index 56a88e14a044..bc011b4639f2 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_job.h
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_job.h
@@ -31,7 +31,7 @@
#define AMDGPU_PREAMBLE_IB_PRESENT (1 << 0)
/* bit set means preamble IB is first presented in belonging context */
#define AMDGPU_PREAMBLE_IB_PRESENT_FIRST (1 << 1)
-/* bit set means context switch occured */
+/* bit set means context switch occurred */
#define AMDGPU_HAVE_CTX_SWITCH (1 << 2)
/* bit set means IB is preempted */
#define AMDGPU_IB_PREEMPTED (1 << 3)
diff --git a/drivers/gpu/drm/radeon/radeon_fence.c b/drivers/gpu/drm/radeon/radeon_fence.c
index 02a40e4750c7..943861b62ee9 100644
--- a/drivers/gpu/drm/radeon/radeon_fence.c
+++ b/drivers/gpu/drm/radeon/radeon_fence.c
@@ -191,7 +191,7 @@ static int radeon_fence_check_signaled(wait_queue_entry_t *wait,
* @ring: ring index the fence is associated with
*
* Checks the current fence value and calculates the last
- * signalled fence value. Returns true if activity occured
+ * signalled fence value. Returns true if activity occurred
* on the ring, and the fence_queue should be waken up.
*/
static bool radeon_fence_activity(struct radeon_device *rdev, int ring)
@@ -262,7 +262,7 @@ static bool radeon_fence_activity(struct radeon_device *rdev, int ring)
* @work: delayed work item
*
* Checks for fence activity and if there is none probe
- * the hardware if a lockup occured.
+ * the hardware if a lockup occurred.
*/
static void radeon_fence_check_lockup(struct work_struct *work)
{
diff --git a/include/drm/drm_debugfs_crc.h b/include/drm/drm_debugfs_crc.h
index 1b4c98c2f838..d7da666b50ca 100644
--- a/include/drm/drm_debugfs_crc.h
+++ b/include/drm/drm_debugfs_crc.h
@@ -49,7 +49,7 @@ struct drm_crtc_crc_entry {
* @lock: protects the fields in this struct
* @source: name of the currently configured source of CRCs
* @opened: whether userspace has opened the data file for reading
- * @overflow: whether an overflow occured.
+ * @overflow: whether an overflow occurred.
* @entries: array of entries, with size of %DRM_CRC_ENTRIES_NR
* @head: head of circular queue
* @tail: tail of circular queue
--
2.54.0
^ permalink raw reply related [flat|nested] 2+ messages in thread* [PATCH 2/2] drm/amd/display: rename timeout_occured to timeout_occurred
2026-05-31 4:59 [PATCH 1/2] drm: fix spelling mistakes in comments and documentation Gustavo Kenji Mendonça Kaneko
@ 2026-05-31 4:59 ` Gustavo Kenji Mendonça Kaneko
0 siblings, 0 replies; 2+ messages in thread
From: Gustavo Kenji Mendonça Kaneko @ 2026-05-31 4:59 UTC (permalink / raw)
To: dri-devel
Cc: airlied, simona, alexander.deucher, christian.koenig,
harry.wentland, corbet, amd-gfx, linux-doc, linux-kernel,
Gustavo Kenji Mendonça Kaneko
Fix spelling mistake in struct dmub_timeout_info field name.
Rename 'timeout_occured' to 'timeout_occurred' and update
all references in dc_dmub_srv.c accordingly.
Signed-off-by: Gustavo Kenji Mendonça Kaneko <kaneko.dev@pm.me>
---
drivers/gpu/drm/amd/display/dc/dc_dmub_srv.c | 4 ++--
drivers/gpu/drm/amd/display/dmub/dmub_srv.h | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/gpu/drm/amd/display/dc/dc_dmub_srv.c b/drivers/gpu/drm/amd/display/dc/dc_dmub_srv.c
index 79c8b4cab053..4b47172a71c0 100644
--- a/drivers/gpu/drm/amd/display/dc/dc_dmub_srv.c
+++ b/drivers/gpu/drm/amd/display/dc/dc_dmub_srv.c
@@ -285,8 +285,8 @@ bool dc_dmub_srv_wait_for_idle(struct dc_dmub_srv *dc_dmub_srv,
if (status != DMUB_STATUS_OK) {
DC_LOG_DEBUG("No reply for DMUB command: status=%d\n", status);
- if (!dmub->debug.timeout_info.timeout_occured) {
- dmub->debug.timeout_info.timeout_occured = true;
+ if (!dmub->debug.timeout_info.timeout_occurred) {
+ dmub->debug.timeout_info.timeout_occurred = true;
if (cmd_list)
dmub->debug.timeout_info.timeout_cmd = *cmd_list;
dmub->debug.timeout_info.timestamp = dm_get_timestamp(dc_dmub_srv->ctx);
diff --git a/drivers/gpu/drm/amd/display/dmub/dmub_srv.h b/drivers/gpu/drm/amd/display/dmub/dmub_srv.h
index c18ff8f00bb8..33fcda687a86 100644
--- a/drivers/gpu/drm/amd/display/dmub/dmub_srv.h
+++ b/drivers/gpu/drm/amd/display/dmub/dmub_srv.h
@@ -355,11 +355,11 @@ struct dmub_srv_hw_params {
/**
* struct dmub_srv_debug - Debug info for dmub_srv
- * @timeout_occured: Indicates a timeout occured on any message from driver to dmub
+ * @timeout_occurred: Indicates a timeout occurred on any message from driver to dmub
* @timeout_cmd: first cmd sent from driver that timed out - subsequent timeouts are not stored
*/
struct dmub_timeout_info {
- bool timeout_occured;
+ bool timeout_occurred;
union dmub_rb_cmd timeout_cmd;
unsigned long long timestamp;
};
--
2.54.0
^ permalink raw reply related [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-05-31 4:59 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-05-31 4:59 [PATCH 1/2] drm: fix spelling mistakes in comments and documentation Gustavo Kenji Mendonça Kaneko
2026-05-31 4:59 ` [PATCH 2/2] drm/amd/display: rename timeout_occured to timeout_occurred Gustavo Kenji Mendonça Kaneko
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox