* [PATCH] docs/mm: ksm: Use the renamed ksm structure names
@ 2026-09-05 8:40 Karl Mehltretter
2026-09-05 19:49 ` Randy Dunlap
0 siblings, 1 reply; 2+ messages in thread
From: Karl Mehltretter @ 2026-09-05 8:40 UTC (permalink / raw)
To: Andrew Morton, David Hildenbrand
Cc: Karl Mehltretter, Xu Xin, Chengming Zhou, linux-mm,
Jonathan Corbet, linux-doc, Shuah Khan, Randy Dunlap, Qi Zheng
The Reference section of ksm.rst asks mm/ksm.c for mm_slot, stable_node
and rmap_item. Commit 21fbd59136e0 ("ksm: add the ksm prefix to the
names of the ksm private structures") renamed them to ksm_mm_slot,
ksm_stable_node and ksm_rmap_item. Since then only ksm_scan is rendered
and the three structures are missing from the generated documentation.
Use the current names.
Fixes: 21fbd59136e0 ("ksm: add the ksm prefix to the names of the ksm private structures")
Assisted-by: LLM
Signed-off-by: Karl Mehltretter <kmehltretter@gmail.com>
---
Documentation/mm/ksm.rst | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Documentation/mm/ksm.rst b/Documentation/mm/ksm.rst
index 2b4f72f1f953..5a80573162de 100644
--- a/Documentation/mm/ksm.rst
+++ b/Documentation/mm/ksm.rst
@@ -78,7 +78,7 @@ The frequency of such scans is defined by
Reference
---------
.. kernel-doc:: mm/ksm.c
- :functions: mm_slot ksm_scan stable_node rmap_item
+ :functions: ksm_mm_slot ksm_scan ksm_stable_node ksm_rmap_item
--
Izik Eidus,
--
2.53.0
^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [PATCH] docs/mm: ksm: Use the renamed ksm structure names
2026-09-05 8:40 [PATCH] docs/mm: ksm: Use the renamed ksm structure names Karl Mehltretter
@ 2026-09-05 19:49 ` Randy Dunlap
0 siblings, 0 replies; 2+ messages in thread
From: Randy Dunlap @ 2026-09-05 19:49 UTC (permalink / raw)
To: Karl Mehltretter, Andrew Morton, David Hildenbrand
Cc: Xu Xin, Chengming Zhou, linux-mm, Jonathan Corbet, linux-doc,
Shuah Khan, Qi Zheng
On 9/5/26 1:40 AM, Karl Mehltretter wrote:
> The Reference section of ksm.rst asks mm/ksm.c for mm_slot, stable_node
> and rmap_item. Commit 21fbd59136e0 ("ksm: add the ksm prefix to the
> names of the ksm private structures") renamed them to ksm_mm_slot,
> ksm_stable_node and ksm_rmap_item. Since then only ksm_scan is rendered
> and the three structures are missing from the generated documentation.
>
> Use the current names.
>
> Fixes: 21fbd59136e0 ("ksm: add the ksm prefix to the names of the ksm private structures")
> Assisted-by: LLM
> Signed-off-by: Karl Mehltretter <kmehltretter@gmail.com>
Reviewed-by: Randy Dunlap <rdunlap@infradead.org>
Thanks.
> ---
> Documentation/mm/ksm.rst | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/Documentation/mm/ksm.rst b/Documentation/mm/ksm.rst
> index 2b4f72f1f953..5a80573162de 100644
> --- a/Documentation/mm/ksm.rst
> +++ b/Documentation/mm/ksm.rst
> @@ -78,7 +78,7 @@ The frequency of such scans is defined by
> Reference
> ---------
> .. kernel-doc:: mm/ksm.c
> - :functions: mm_slot ksm_scan stable_node rmap_item
> + :functions: ksm_mm_slot ksm_scan ksm_stable_node ksm_rmap_item
>
> --
> Izik Eidus,
eh?
--
~Randy
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-09-05 19:49 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-09-05 8:40 [PATCH] docs/mm: ksm: Use the renamed ksm structure names Karl Mehltretter
2026-09-05 19:49 ` Randy Dunlap
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox