linux-fsdevel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 0/5] fuse: {io-uring} Allow to reduce the number of queues and request distribution
@ 2025-07-22 21:57 Bernd Schubert
  2025-07-22 21:57 ` [PATCH 1/5] fuse: {io-uring} Add queue length counters Bernd Schubert
                   ` (4 more replies)
  0 siblings, 5 replies; 14+ messages in thread
From: Bernd Schubert @ 2025-07-22 21:57 UTC (permalink / raw)
  To: Miklos Szeredi; +Cc: Joanne Koong, linux-fsdevel, Bernd Schubert

This adds bitmaps that track which queues are registered and which queues
do not have queued requests.
These bitmaps are then used to map from request core to queue
and also allow load distribution. NUMA affinity is handled and
fuse client/server protocol does not need changes, all is handled
in fuse client internally.

Signed-off-by: Bernd Schubert <bschubert@ddn.com>
---
Bernd Schubert (5):
      fuse: {io-uring} Add queue length counters
      fuse: {io-uring} Rename ring->nr_queues to max_nr_queues
      fuse: {io-uring} Use bitmaps to track queue availability
      fuse: {io-uring} Distribute load among queues
      fuse: {io-uring} Allow reduced number of ring queues

 fs/fuse/dev_uring.c   | 308 ++++++++++++++++++++++++++++++++++++++++++--------
 fs/fuse/dev_uring_i.h |  26 ++++-
 2 files changed, 286 insertions(+), 48 deletions(-)
---
base-commit: 6832a9317eee280117cd695fa885b2b7a7a38daf
change-id: 20250722-reduced-nr-ring-queues_3-6acb79dad978

Best regards,
-- 
Bernd Schubert <bschubert@ddn.com>


^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2025-09-15 22:52 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-07-22 21:57 [PATCH 0/5] fuse: {io-uring} Allow to reduce the number of queues and request distribution Bernd Schubert
2025-07-22 21:57 ` [PATCH 1/5] fuse: {io-uring} Add queue length counters Bernd Schubert
2025-07-24 21:07   ` Joanne Koong
2025-07-22 21:57 ` [PATCH 2/5] fuse: {io-uring} Rename ring->nr_queues to max_nr_queues Bernd Schubert
2025-07-22 21:58 ` [PATCH 3/5] fuse: {io-uring} Use bitmaps to track queue availability Bernd Schubert
2025-07-24 23:56   ` Joanne Koong
2025-07-22 21:58 ` [PATCH 4/5] fuse: {io-uring} Distribute load among queues Bernd Schubert
2025-07-22 21:58 ` [PATCH 5/5] fuse: {io-uring} Allow reduced number of ring queues Bernd Schubert
2025-07-25  0:43   ` Joanne Koong
2025-08-04 10:17     ` Bernd Schubert
2025-09-15 22:18       ` Bernd Schubert
2025-09-15  4:37   ` yangerkun
2025-09-15  8:39     ` Bernd Schubert
2025-09-15  9:07       ` yangerkun

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).