Linux filesystem development
 help / color / mirror / Atom feed
From: John Garry <john.g.garry@oracle.com>
To: "Darrick J. Wong" <djwong@kernel.org>
Cc: brauner@kernel.org, cem@kernel.org, dchinner@redhat.com,
	hch@lst.de, linux-xfs@vger.kernel.org,
	linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org,
	ojaswin@linux.ibm.com, ritesh.list@gmail.com,
	martin.petersen@oracle.com, tytso@mit.edu,
	linux-ext4@vger.kernel.org
Subject: Re: [PATCH v2 06/11] xfs: Reflink CoW-based atomic write support
Date: Tue, 25 Feb 2025 10:58:56 +0000	[thread overview]
Message-ID: <e1aa10da-046b-48a8-bb49-f494a5a2b383@oracle.com> (raw)
In-Reply-To: <20250224203228.GI21808@frogsfrogsfrogs>

On 24/02/2025 20:32, Darrick J. Wong wrote:
> On Thu, Feb 13, 2025 at 01:56:14PM +0000, John Garry wrote:
>> For CoW-based atomic write support, always allocate a cow hole in
>> xfs_reflink_allocate_cow() to write the new data.
>>
>> The semantics is that if @atomic is set, we will be passed a CoW fork
>> extent mapping for no error returned.
>>
>> Signed-off-by: John Garry <john.g.garry@oracle.com>
>> ---
>>   fs/xfs/xfs_iomap.c   |  2 +-
>>   fs/xfs/xfs_reflink.c | 12 +++++++-----
>>   fs/xfs/xfs_reflink.h |  2 +-
>>   3 files changed, 9 insertions(+), 7 deletions(-)
>>
>> diff --git a/fs/xfs/xfs_iomap.c b/fs/xfs/xfs_iomap.c
>> index d61460309a78..ab79f0080288 100644
>> --- a/fs/xfs/xfs_iomap.c
>> +++ b/fs/xfs/xfs_iomap.c
>> @@ -865,7 +865,7 @@ xfs_direct_write_iomap_begin(
>>   		/* may drop and re-acquire the ilock */
>>   		error = xfs_reflink_allocate_cow(ip, &imap, &cmap, &shared,
>>   				&lockmode,
>> -				(flags & IOMAP_DIRECT) || IS_DAX(inode));
>> +				(flags & IOMAP_DIRECT) || IS_DAX(inode), false);
> 
> Now I'm /really/ think it's time for some reflink allocation flags,
> because the function signature now involves two booleans...

ok, but the @convert_now arg is passed to other functions from 
xfs_reflink_allocate_cow() - so would you prefer to create a bool 
@convert_now inside xfs_reflink_allocate_cow() and pass that bool as 
before? Or pass the flags all the way down to end users of @convert_now?

> 
>>   		if (error)
>>   			goto out_unlock;
>>   		if (shared)
>> diff --git a/fs/xfs/xfs_reflink.c b/fs/xfs/xfs_reflink.c
>> index 8428f7b26ee6..3dab3ba900a3 100644
>> --- a/fs/xfs/xfs_reflink.c
>> +++ b/fs/xfs/xfs_reflink.c
>> @@ -435,7 +435,8 @@ xfs_reflink_fill_cow_hole(
>>   	struct xfs_bmbt_irec	*cmap,
>>   	bool			*shared,
>>   	uint			*lockmode,
>> -	bool			convert_now)
>> +	bool			convert_now,
>> +	bool			atomic)
> 
> ...but this can come later. 

Do you mean that this would just be a new flag to set?

 > Also, is atomic==true only for the> ATOMIC_SW operation?

Right, so I think that the variable (or new flag) can be renamed for that.

> I think so, but that's the unfortunate thing about
> booleans.
> 
>>   {
>>   	struct xfs_mount	*mp = ip->i_mount;
>>   	struct xfs_trans	*tp;
>> @@ -466,7 +467,7 @@ xfs_reflink_fill_cow_hole(
>>   	*lockmode = XFS_ILOCK_EXCL;
>>   
>>   	error = xfs_find_trim_cow_extent(ip, imap, cmap, shared, &found);
>> -	if (error || !*shared)
>> +	if (error || (!*shared && !atomic))
>>   		goto out_trans_cancel;
>>   
>>   	if (found) {
>> @@ -566,7 +567,8 @@ xfs_reflink_allocate_cow(
>>   	struct xfs_bmbt_irec	*cmap,
>>   	bool			*shared,
>>   	uint			*lockmode,
>> -	bool			convert_now)
>> +	bool			convert_now,
>> +	bool 			atomic)
> 
> Nit:        ^ space before tab.

ok

> 
> If the answer to the question above is 'yes' then with that nit fixed,
> Reviewed-by: "Darrick J. Wong" <djwong@kernel.org>

Thanks, but I will wait for your feedback to decide whether to pick that up.

John

  reply	other threads:[~2025-02-25 10:59 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-13 13:56 [PATCH v2 00/11] large atomic writes for xfs with CoW John Garry
2025-02-13 13:56 ` [PATCH v2 01/11] iomap: Rename IOMAP_ATOMIC -> IOMAP_ATOMIC_HW John Garry
2025-02-24 20:23   ` Darrick J. Wong
2025-02-13 13:56 ` [PATCH v2 02/11] xfs: Switch atomic write size check in xfs_file_write_iter() John Garry
2025-02-24 20:24   ` Darrick J. Wong
2025-02-13 13:56 ` [PATCH v2 03/11] xfs: Refactor xfs_reflink_end_cow_extent() John Garry
2025-02-24 20:26   ` Darrick J. Wong
2025-02-25 10:01     ` John Garry
2025-02-25 17:29       ` Darrick J. Wong
2025-02-13 13:56 ` [PATCH v2 04/11] iomap: Support CoW-based atomic writes John Garry
2025-02-24 19:59   ` Darrick J. Wong
2025-02-25 10:19     ` John Garry
2025-02-25 17:33       ` Darrick J. Wong
2025-02-13 13:56 ` [PATCH v2 05/11] iomap: Lift blocksize restriction on " John Garry
2025-02-13 13:56 ` [PATCH v2 06/11] xfs: Reflink CoW-based atomic write support John Garry
2025-02-24 20:32   ` Darrick J. Wong
2025-02-25 10:58     ` John Garry [this message]
2025-02-25 17:37       ` Darrick J. Wong
2025-02-25 18:02         ` John Garry
2025-02-13 13:56 ` [PATCH v2 07/11] xfs: iomap " John Garry
2025-02-24 20:13   ` Darrick J. Wong
2025-02-25 11:06     ` John Garry
2025-02-25 17:47       ` Darrick J. Wong
2025-02-25 18:07         ` John Garry
2025-02-13 13:56 ` [PATCH v2 08/11] xfs: Add xfs_file_dio_write_atomic() John Garry
2025-02-24 20:32   ` Darrick J. Wong
2025-02-13 13:56 ` [PATCH v2 09/11] xfs: Commit CoW-based atomic writes atomically John Garry
2025-02-24 20:20   ` Darrick J. Wong
2025-02-25 11:11     ` John Garry
2025-02-25 17:50       ` Darrick J. Wong
2025-02-25 18:07         ` John Garry
2025-02-13 13:56 ` [PATCH v2 10/11] xfs: Update atomic write max size John Garry
2025-02-24 20:34   ` Darrick J. Wong
2025-02-25 11:13     ` John Garry
2025-02-13 13:56 ` [PATCH v2 11/11] xfs: Allow block allocator to take an alignment hint John Garry
2025-02-24 20:37   ` Darrick J. Wong
2025-02-25 11:17     ` John Garry
2025-02-20  7:48 ` [PATCH v2 00/11] large atomic writes for xfs with CoW John Garry

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e1aa10da-046b-48a8-bb49-f494a5a2b383@oracle.com \
    --to=john.g.garry@oracle.com \
    --cc=brauner@kernel.org \
    --cc=cem@kernel.org \
    --cc=dchinner@redhat.com \
    --cc=djwong@kernel.org \
    --cc=hch@lst.de \
    --cc=linux-ext4@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=ojaswin@linux.ibm.com \
    --cc=ritesh.list@gmail.com \
    --cc=tytso@mit.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox