Linux ATA/IDE development
 help / color / mirror / Atom feed
From: Damien Le Moal <dlemoal@kernel.org>
To: Niklas Cassel <cassel@kernel.org>, Rosen Penev <rosenp@gmail.com>
Cc: linux-ide@vger.kernel.org, open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] ata: sata_dwc_460ex: use platform_get_irq()
Date: Tue, 30 Jun 2026 17:21:58 +0900	[thread overview]
Message-ID: <9327f32a-5037-477c-80dc-f99b97ed9740@kernel.org> (raw)
In-Reply-To: <akNzEGgiYC5V3rtc@ryzen>

On 6/30/26 16:41, Niklas Cassel wrote:
> On Sun, Jun 28, 2026 at 04:03:10PM -0700, Rosen Penev wrote:
>> Replace irq_of_parse_and_map() with platform_get_irq() in both
>> sata_dwc_dma_init_old() and sata_dwc_probe(). This is the preferred
>> way to obtain IRQs for platform devices and provides better error
>> reporting.  Remove the now-unnecessary #include <linux/of_irq.h>.
>>
>> irq_of_parse_and_map() requires irq_dispose_mapping(), which is missing.
>>
>> Assisted-by: opencode:big-pickle
>> Signed-off-by: Rosen Penev <rosenp@gmail.com>
>> ---
>>  drivers/ata/sata_dwc_460ex.c | 18 ++++++------------
>>  1 file changed, 6 insertions(+), 12 deletions(-)
>>
>> diff --git a/drivers/ata/sata_dwc_460ex.c b/drivers/ata/sata_dwc_460ex.c
>> index 4fc22ce4bd9a..35aa7f9acdf7 100644
>> --- a/drivers/ata/sata_dwc_460ex.c
>> +++ b/drivers/ata/sata_dwc_460ex.c
>> @@ -19,7 +19,6 @@
>>  #include <linux/device.h>
>>  #include <linux/dmaengine.h>
>>  #include <linux/of.h>
>> -#include <linux/of_irq.h>
>>  #include <linux/platform_device.h>
>>  #include <linux/phy/phy.h>
>>  #include <linux/libata.h>
>> @@ -226,7 +225,6 @@ static int sata_dwc_dma_init_old(struct platform_device *pdev,
>>  				 struct sata_dwc_device *hsdev)
>>  {
>>  	struct device *dev = &pdev->dev;
>> -	struct device_node *np = dev->of_node;
> 
> While this patch drops 'struct device_node *np = dev->of_node;' from
> sata_dwc_dma_init_old() ...
> 
>>  
>>  	hsdev->dma = devm_kzalloc(dev, sizeof(*hsdev->dma), GFP_KERNEL);
>>  	if (!hsdev->dma)
>> @@ -236,11 +234,9 @@ static int sata_dwc_dma_init_old(struct platform_device *pdev,
>>  	hsdev->dma->id = pdev->id;
>>  
>>  	/* Get SATA DMA interrupt number */
>> -	hsdev->dma->irq = irq_of_parse_and_map(np, 1);
>> -	if (!hsdev->dma->irq) {
>> -		dev_err(dev, "no SATA DMA irq\n");
>> -		return -ENODEV;
>> -	}
>> +	hsdev->dma->irq = platform_get_irq(pdev, 1);
>> +	if (hsdev->dma->irq < 0)
>> +		return hsdev->dma->irq;
>>  
>>  	/* Get physical SATA DMA register base address */
>>  	hsdev->dma->regs = devm_platform_ioremap_resource(pdev, 1);
>> @@ -1173,11 +1169,9 @@ static int sata_dwc_probe(struct platform_device *ofdev)
> 
> it seems like you forgot to do the same for sata_dwc_probe().
> 
> Which results in a new warning:
> https://lore.kernel.org/oe-kbuild-all/202606301243.9MrXM4WY-lkp@intel.com/T/#u
> 
> Damien, perhaps drop this patch and wait for a v2,
> or fixup the patch to remove 'struct device_node *np = dev->of_node;'
> also from sata_dwc_probe().
> 
> 
>>  	sata_dwc_enable_interrupts(hsdev);
>>  
>>  	/* Get SATA interrupt number */
>> -	irq = irq_of_parse_and_map(np, 0);
>> -	if (!irq) {
>> -		dev_err(dev, "no SATA DMA irq\n");
>> -		return -ENODEV;
>> -	}
>> +	irq = platform_get_irq(ofdev, 0);
>> +	if (irq < 0)
>> +		return irq;
>>  
>>  #ifdef CONFIG_SATA_DWC_OLD_DMA
>>  	if (!of_property_present(np, "dmas")) {

Hmmm... np is used here though...

I will drop the patch for now and wait for a v2.

>> -- 
>> 2.54.0
>>


-- 
Damien Le Moal
Western Digital Research

  reply	other threads:[~2026-06-30  8:22 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-28 23:03 [PATCH] ata: sata_dwc_460ex: use platform_get_irq() Rosen Penev
2026-06-28 23:12 ` sashiko-bot
2026-06-29  8:21 ` Niklas Cassel
2026-06-29 23:58 ` Damien Le Moal
2026-06-30  7:41 ` Niklas Cassel
2026-06-30  8:21   ` Damien Le Moal [this message]
2026-06-30  8:30     ` Niklas Cassel
2026-06-30  8:33       ` Rosen Penev
2026-06-30  8:52         ` Rosen Penev
2026-06-30  9:00           ` Damien Le Moal
2026-06-30  9:06             ` Niklas Cassel
2026-06-30  9:22               ` Damien Le Moal
2026-06-30  9:55                 ` Niklas Cassel
2026-06-30 10:06                   ` Damien Le Moal
2026-06-30 11:16                     ` Niklas Cassel
2026-06-30 20:11                       ` Rosen Penev

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=9327f32a-5037-477c-80dc-f99b97ed9740@kernel.org \
    --to=dlemoal@kernel.org \
    --cc=cassel@kernel.org \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rosenp@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox