* [PATCH v1 1/1] iio: imu: inv_mpu6050: Use upper_16_bits()/lower_16_bits() helpers
@ 2024-09-04 18:45 Andy Shevchenko
2024-09-05 9:16 ` Jean-Baptiste Maneyrol
0 siblings, 1 reply; 3+ messages in thread
From: Andy Shevchenko @ 2024-09-04 18:45 UTC (permalink / raw)
To: Andy Shevchenko, linux-iio, linux-kernel
Cc: Jonathan Cameron, Lars-Peter Clausen
Use upper_16_bits()/lower_16_bits() helpers instead of open-coding them.
This is easier to scan quickly compared to bitwise manipulation, and
it is pleasingly symmetric.
Signed-off-by: Andy Shevchenko <andy.shevchenko@gmail.com>
---
drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c b/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c
index f7bce428d9eb..b15d8c94cc11 100644
--- a/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c
+++ b/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c
@@ -10,6 +10,8 @@
#include <linux/i2c.h>
#include <linux/dmi.h>
#include <linux/acpi.h>
+#include <linux/wordpart.h>
+
#include "inv_mpu_iio.h"
enum inv_mpu_product_name {
@@ -118,8 +120,8 @@ static int inv_mpu_process_acpi_config(struct i2c_client *client,
return ret;
acpi_dev_free_resource_list(&resources);
- *primary_addr = i2c_addr & 0x0000ffff;
- *secondary_addr = (i2c_addr & 0xffff0000) >> 16;
+ *primary_addr = lower_16_bits(i2c_addr);
+ *secondary_addr = upper_16_bits(i2c_addr);
return 0;
}
--
2.46.0
^ permalink raw reply related [flat|nested] 3+ messages in thread* Re: [PATCH v1 1/1] iio: imu: inv_mpu6050: Use upper_16_bits()/lower_16_bits() helpers
2024-09-04 18:45 [PATCH v1 1/1] iio: imu: inv_mpu6050: Use upper_16_bits()/lower_16_bits() helpers Andy Shevchenko
@ 2024-09-05 9:16 ` Jean-Baptiste Maneyrol
2024-09-07 17:18 ` Jonathan Cameron
0 siblings, 1 reply; 3+ messages in thread
From: Jean-Baptiste Maneyrol @ 2024-09-05 9:16 UTC (permalink / raw)
To: Andy Shevchenko, linux-iio@vger.kernel.org,
linux-kernel@vger.kernel.org
Cc: Jonathan Cameron, Lars-Peter Clausen
Hello,
looks good for me, nice reading improvement indeed.
Acked-by: Jean-Baptiste Maneyrol <jean-baptiste.maneyrol@tdk.com>
Thanks for the patch,
JB
________________________________________
From: Andy Shevchenko <andy.shevchenko@gmail.com>
Sent: Wednesday, September 4, 2024 20:45
To: Andy Shevchenko <andy.shevchenko@gmail.com>; linux-iio@vger.kernel.org <linux-iio@vger.kernel.org>; linux-kernel@vger.kernel.org <linux-kernel@vger.kernel.org>
Cc: Jonathan Cameron <jic23@kernel.org>; Lars-Peter Clausen <lars@metafoo.de>
Subject: [PATCH v1 1/1] iio: imu: inv_mpu6050: Use upper_16_bits()/lower_16_bits() helpers
This Message Is From an External Sender
This message came from outside your organization.
Use upper_16_bits()/lower_16_bits() helpers instead of open-coding them.
This is easier to scan quickly compared to bitwise manipulation, and
it is pleasingly symmetric.
Signed-off-by: Andy Shevchenko <andy.shevchenko@gmail.com>
---
drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c b/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c
index f7bce428d9eb..b15d8c94cc11 100644
--- a/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c
+++ b/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c
@@ -10,6 +10,8 @@
#include <linux/i2c.h>
#include <linux/dmi.h>
#include <linux/acpi.h>
+#include <linux/wordpart.h>
+
#include "inv_mpu_iio.h"
enum inv_mpu_product_name {
@@ -118,8 +120,8 @@ static int inv_mpu_process_acpi_config(struct i2c_client *client,
return ret;
acpi_dev_free_resource_list(&resources);
- *primary_addr = i2c_addr & 0x0000ffff;
- *secondary_addr = (i2c_addr & 0xffff0000) >> 16;
+ *primary_addr = lower_16_bits(i2c_addr);
+ *secondary_addr = upper_16_bits(i2c_addr);
return 0;
}
--
2.46.0
^ permalink raw reply related [flat|nested] 3+ messages in thread* Re: [PATCH v1 1/1] iio: imu: inv_mpu6050: Use upper_16_bits()/lower_16_bits() helpers
2024-09-05 9:16 ` Jean-Baptiste Maneyrol
@ 2024-09-07 17:18 ` Jonathan Cameron
0 siblings, 0 replies; 3+ messages in thread
From: Jonathan Cameron @ 2024-09-07 17:18 UTC (permalink / raw)
To: Jean-Baptiste Maneyrol
Cc: Andy Shevchenko, linux-iio@vger.kernel.org,
linux-kernel@vger.kernel.org, Lars-Peter Clausen
On Thu, 5 Sep 2024 09:16:22 +0000
Jean-Baptiste Maneyrol <Jean-Baptiste.Maneyrol@tdk.com> wrote:
> Hello,
>
> looks good for me, nice reading improvement indeed.
>
> Acked-by: Jean-Baptiste Maneyrol <jean-baptiste.maneyrol@tdk.com>
Applied.
>
> Thanks for the patch,
> JB
>
> ________________________________________
> From: Andy Shevchenko <andy.shevchenko@gmail.com>
> Sent: Wednesday, September 4, 2024 20:45
> To: Andy Shevchenko <andy.shevchenko@gmail.com>; linux-iio@vger.kernel.org <linux-iio@vger.kernel.org>; linux-kernel@vger.kernel.org <linux-kernel@vger.kernel.org>
> Cc: Jonathan Cameron <jic23@kernel.org>; Lars-Peter Clausen <lars@metafoo.de>
> Subject: [PATCH v1 1/1] iio: imu: inv_mpu6050: Use upper_16_bits()/lower_16_bits() helpers
>
> This Message Is From an External Sender
> This message came from outside your organization.
>
> Use upper_16_bits()/lower_16_bits() helpers instead of open-coding them.
> This is easier to scan quickly compared to bitwise manipulation, and
> it is pleasingly symmetric.
>
> Signed-off-by: Andy Shevchenko <andy.shevchenko@gmail.com>
> ---
> drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c b/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c
> index f7bce428d9eb..b15d8c94cc11 100644
> --- a/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c
> +++ b/drivers/iio/imu/inv_mpu6050/inv_mpu_acpi.c
> @@ -10,6 +10,8 @@
> #include <linux/i2c.h>
> #include <linux/dmi.h>
> #include <linux/acpi.h>
> +#include <linux/wordpart.h>
> +
> #include "inv_mpu_iio.h"
>
> enum inv_mpu_product_name {
> @@ -118,8 +120,8 @@ static int inv_mpu_process_acpi_config(struct i2c_client *client,
> return ret;
>
> acpi_dev_free_resource_list(&resources);
> - *primary_addr = i2c_addr & 0x0000ffff;
> - *secondary_addr = (i2c_addr & 0xffff0000) >> 16;
> + *primary_addr = lower_16_bits(i2c_addr);
> + *secondary_addr = upper_16_bits(i2c_addr);
>
> return 0;
> }
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2024-09-07 17:19 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2024-09-04 18:45 [PATCH v1 1/1] iio: imu: inv_mpu6050: Use upper_16_bits()/lower_16_bits() helpers Andy Shevchenko
2024-09-05 9:16 ` Jean-Baptiste Maneyrol
2024-09-07 17:18 ` Jonathan Cameron
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox