From: Baolu Lu <baolu.lu@linux.intel.com>
To: Yi Liu <yi.l.liu@intel.com>,
joro@8bytes.org, jgg@nvidia.com, kevin.tian@intel.com
Cc: baolu.lu@linux.intel.com, alex.williamson@redhat.com,
robin.murphy@arm.com, eric.auger@redhat.com, nicolinc@nvidia.com,
kvm@vger.kernel.org, chao.p.peng@linux.intel.com,
iommu@lists.linux.dev, zhenzhong.duan@intel.com,
jacob.jun.pan@intel.com
Subject: Re: [PATCH v2 01/12] iommu: Pass old domain to set_dev_pasid op
Date: Mon, 15 Apr 2024 13:32:03 +0800 [thread overview]
Message-ID: <3cfb2bb1-3d66-450d-b561-f8f0939645ba@linux.intel.com> (raw)
In-Reply-To: <20240412081516.31168-2-yi.l.liu@intel.com>
On 4/12/24 4:15 PM, Yi Liu wrote:
> diff --git a/include/linux/iommu.h b/include/linux/iommu.h
> index 40dd439307e8..1e5e9249c93f 100644
> --- a/include/linux/iommu.h
> +++ b/include/linux/iommu.h
> @@ -631,7 +631,7 @@ struct iommu_ops {
> struct iommu_domain_ops {
> int (*attach_dev)(struct iommu_domain *domain, struct device *dev);
> int (*set_dev_pasid)(struct iommu_domain *domain, struct device *dev,
> - ioasid_t pasid);
> + ioasid_t pasid, struct iommu_domain *old);
Is it possible to add another op to replace a domain for pasid? For
example,
int (*replace_dev_pasid)(domain, dev, pasid, old_domain)
Best regards,
baolu
next prev parent reply other threads:[~2024-04-15 5:33 UTC|newest]
Thread overview: 50+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-04-12 8:15 [PATCH v2 00/12] iommufd support pasid attach/replace Yi Liu
2024-04-12 8:15 ` [PATCH v2 01/12] iommu: Pass old domain to set_dev_pasid op Yi Liu
2024-04-15 5:32 ` Baolu Lu [this message]
2024-04-15 11:54 ` Jason Gunthorpe
2024-04-16 2:07 ` Baolu Lu
2024-04-16 17:47 ` Jason Gunthorpe
2024-04-12 8:15 ` [PATCH v2 02/12] iommu: Introduce a replace API for device pasid Yi Liu
2024-04-16 3:01 ` Duan, Zhenzhong
2024-04-16 9:18 ` Yi Liu
2024-04-17 8:44 ` Tian, Kevin
2024-04-17 12:17 ` Jason Gunthorpe
2024-04-18 0:08 ` Tian, Kevin
2024-04-29 13:55 ` Jason Gunthorpe
2024-04-30 5:00 ` Yi Liu
2024-04-30 12:26 ` Jason Gunthorpe
2024-04-12 8:15 ` [PATCH v2 03/12] iommufd: replace attach_fn with a structure Yi Liu
2024-04-12 8:15 ` [PATCH v2 04/12] iommufd: Support attach/replace hwpt per pasid Yi Liu
2024-04-29 13:56 ` Jason Gunthorpe
2024-04-12 8:15 ` [PATCH v2 05/12] iommu: Allow iommu driver to populate the max_pasids Yi Liu
2024-04-15 5:41 ` Baolu Lu
2024-04-17 8:49 ` Tian, Kevin
2024-04-20 5:45 ` Yi Liu
2024-04-22 11:52 ` Jason Gunthorpe
2024-04-12 8:15 ` [PATCH v2 06/12] iommufd/selftest: Add set_dev_pasid and remove_dev_pasid in mock iommu Yi Liu
2024-04-12 8:15 ` [PATCH v2 07/12] iommufd/selftest: Add a helper to get test device Yi Liu
2024-04-12 8:15 ` [PATCH v2 08/12] iommufd/selftest: Add test ops to test pasid attach/detach Yi Liu
2024-04-12 8:15 ` [PATCH v2 09/12] iommufd/selftest: Add coverage for iommufd " Yi Liu
2024-04-12 8:15 ` [PATCH v2 10/12] iommu/vt-d: Return if no dev_pasid is found in domain Yi Liu
2024-04-15 6:04 ` Baolu Lu
2024-04-16 9:21 ` Yi Liu
2024-04-17 2:30 ` Baolu Lu
2024-04-17 3:48 ` Yi Liu
2024-04-17 9:03 ` Tian, Kevin
2024-04-17 9:36 ` Yi Liu
2024-04-12 8:15 ` [PATCH v2 11/12] iommu/vt-d: Make intel_iommu_set_dev_pasid() to handle domain replacement Yi Liu
2024-04-17 9:19 ` Tian, Kevin
2024-04-17 9:35 ` Yi Liu
2024-04-17 12:19 ` Jason Gunthorpe
2024-04-12 8:15 ` [PATCH v2 12/12] iommu/vt-d: Add set_dev_pasid callback for nested domain Yi Liu
2024-04-17 9:25 ` Tian, Kevin
2024-04-30 9:19 ` Yi Liu
2024-05-06 7:42 ` Baolu Lu
2024-05-06 13:36 ` Jason Gunthorpe
2024-05-07 2:28 ` Yi Liu
2024-05-07 15:18 ` Jason Gunthorpe
2024-05-08 6:10 ` Yi Liu
2024-05-08 12:25 ` Jason Gunthorpe
2024-05-08 13:26 ` Yi Liu
2024-05-08 14:11 ` Jason Gunthorpe
2024-05-09 14:22 ` Liu, Yi L
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=3cfb2bb1-3d66-450d-b561-f8f0939645ba@linux.intel.com \
--to=baolu.lu@linux.intel.com \
--cc=alex.williamson@redhat.com \
--cc=chao.p.peng@linux.intel.com \
--cc=eric.auger@redhat.com \
--cc=iommu@lists.linux.dev \
--cc=jacob.jun.pan@intel.com \
--cc=jgg@nvidia.com \
--cc=joro@8bytes.org \
--cc=kevin.tian@intel.com \
--cc=kvm@vger.kernel.org \
--cc=nicolinc@nvidia.com \
--cc=robin.murphy@arm.com \
--cc=yi.l.liu@intel.com \
--cc=zhenzhong.duan@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox