Linux IOMMU Development
 help / color / mirror / Atom feed
From: Baolu Lu <baolu.lu@linux.intel.com>
To: Yi Liu <yi.l.liu@intel.com>,
	joro@8bytes.org, jgg@nvidia.com, kevin.tian@intel.com
Cc: baolu.lu@linux.intel.com, alex.williamson@redhat.com,
	robin.murphy@arm.com, eric.auger@redhat.com, nicolinc@nvidia.com,
	kvm@vger.kernel.org, chao.p.peng@linux.intel.com,
	iommu@lists.linux.dev, zhenzhong.duan@intel.com,
	jacob.jun.pan@intel.com
Subject: Re: [PATCH v2 10/12] iommu/vt-d: Return if no dev_pasid is found in domain
Date: Wed, 17 Apr 2024 10:30:35 +0800	[thread overview]
Message-ID: <a0543205-18a8-4878-8b24-3d87bee24645@linux.intel.com> (raw)
In-Reply-To: <373e52b4-e663-4b2d-9a6b-feaf3a93892b@intel.com>

On 4/16/24 5:21 PM, Yi Liu wrote:
> 
> n 2024/4/15 14:04, Baolu Lu wrote:
>> On 4/12/24 4:15 PM, Yi Liu wrote:
>>> If no dev_pasid is found, it should be a problem of caller. So a WARN_ON
>>> is fine, but no need to go further as nothing to be cleanup and also it
>>> may hit unknown issue.
>>
>> If "... it should be a problem of caller ...", then the check and WARN()
>> should be added in the caller instead of individual drivers.
>>
>>>
>>> Signed-off-by: Yi Liu <yi.l.liu@intel.com>
>>> ---
>>>   drivers/iommu/intel/iommu.c | 3 ++-
>>>   1 file changed, 2 insertions(+), 1 deletion(-)
>>>
>>> diff --git a/drivers/iommu/intel/iommu.c b/drivers/iommu/intel/iommu.c
>>> index df49aed3df5e..fff7dea012a7 100644
>>> --- a/drivers/iommu/intel/iommu.c
>>> +++ b/drivers/iommu/intel/iommu.c
>>> @@ -4614,8 +4614,9 @@ static void intel_iommu_remove_dev_pasid(struct 
>>> device *dev, ioasid_t pasid,
>>>               break;
>>>           }
>>>       }
>>> -    WARN_ON_ONCE(!dev_pasid);
>>>       spin_unlock_irqrestore(&dmar_domain->lock, flags);
>>> +    if (WARN_ON_ONCE(!dev_pasid))
>>> +        return;
>>
>> The iommu core calls remove_dev_pasid op to tear down the translation on
>> a pasid and park it in a BLOCKED state. Since this is a must-be-
>> successful callback, it makes no sense to return before tearing down the
>> pasid table entry.
> 
> but if no dev_pasid is found, does it mean there is no pasid table entry
> to be destroyed? That's why I think it deserves a warn, but no need to
> continue.

The pasid table is allocated in the iommu probe path, hence the entry is
*always* there. Teardown a pasid translation just means zeroing out all
fields of the entry.

> 
>>
>>  From the Intel iommu driver's perspective, the pasid devices have
>> already been tracked in the core, hence the dev_pasid is a duplicate and
>> will be removed later, so don't use it for other purposes.
> 
> 
> good to know it. But for the current code, if we continue, it would hit
> call trace in the end in the intel_iommu_debugfs_remove_dev_pasid().

The debugfs interface should be designed to be self-contained. That
means, even if one passes a NULL pointer to
intel_iommu_debugfs_remove_dev_pasid(), it should handle it gracefully.

Best regards,
baolu

  reply	other threads:[~2024-04-17  2:31 UTC|newest]

Thread overview: 50+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-04-12  8:15 [PATCH v2 00/12] iommufd support pasid attach/replace Yi Liu
2024-04-12  8:15 ` [PATCH v2 01/12] iommu: Pass old domain to set_dev_pasid op Yi Liu
2024-04-15  5:32   ` Baolu Lu
2024-04-15 11:54     ` Jason Gunthorpe
2024-04-16  2:07       ` Baolu Lu
2024-04-16 17:47         ` Jason Gunthorpe
2024-04-12  8:15 ` [PATCH v2 02/12] iommu: Introduce a replace API for device pasid Yi Liu
2024-04-16  3:01   ` Duan, Zhenzhong
2024-04-16  9:18     ` Yi Liu
2024-04-17  8:44   ` Tian, Kevin
2024-04-17 12:17     ` Jason Gunthorpe
2024-04-18  0:08       ` Tian, Kevin
2024-04-29 13:55   ` Jason Gunthorpe
2024-04-30  5:00     ` Yi Liu
2024-04-30 12:26       ` Jason Gunthorpe
2024-04-12  8:15 ` [PATCH v2 03/12] iommufd: replace attach_fn with a structure Yi Liu
2024-04-12  8:15 ` [PATCH v2 04/12] iommufd: Support attach/replace hwpt per pasid Yi Liu
2024-04-29 13:56   ` Jason Gunthorpe
2024-04-12  8:15 ` [PATCH v2 05/12] iommu: Allow iommu driver to populate the max_pasids Yi Liu
2024-04-15  5:41   ` Baolu Lu
2024-04-17  8:49     ` Tian, Kevin
2024-04-20  5:45       ` Yi Liu
2024-04-22 11:52         ` Jason Gunthorpe
2024-04-12  8:15 ` [PATCH v2 06/12] iommufd/selftest: Add set_dev_pasid and remove_dev_pasid in mock iommu Yi Liu
2024-04-12  8:15 ` [PATCH v2 07/12] iommufd/selftest: Add a helper to get test device Yi Liu
2024-04-12  8:15 ` [PATCH v2 08/12] iommufd/selftest: Add test ops to test pasid attach/detach Yi Liu
2024-04-12  8:15 ` [PATCH v2 09/12] iommufd/selftest: Add coverage for iommufd " Yi Liu
2024-04-12  8:15 ` [PATCH v2 10/12] iommu/vt-d: Return if no dev_pasid is found in domain Yi Liu
2024-04-15  6:04   ` Baolu Lu
2024-04-16  9:21     ` Yi Liu
2024-04-17  2:30       ` Baolu Lu [this message]
2024-04-17  3:48         ` Yi Liu
2024-04-17  9:03   ` Tian, Kevin
2024-04-17  9:36     ` Yi Liu
2024-04-12  8:15 ` [PATCH v2 11/12] iommu/vt-d: Make intel_iommu_set_dev_pasid() to handle domain replacement Yi Liu
2024-04-17  9:19   ` Tian, Kevin
2024-04-17  9:35     ` Yi Liu
2024-04-17 12:19       ` Jason Gunthorpe
2024-04-12  8:15 ` [PATCH v2 12/12] iommu/vt-d: Add set_dev_pasid callback for nested domain Yi Liu
2024-04-17  9:25   ` Tian, Kevin
2024-04-30  9:19     ` Yi Liu
2024-05-06  7:42       ` Baolu Lu
2024-05-06 13:36         ` Jason Gunthorpe
2024-05-07  2:28           ` Yi Liu
2024-05-07 15:18             ` Jason Gunthorpe
2024-05-08  6:10               ` Yi Liu
2024-05-08 12:25                 ` Jason Gunthorpe
2024-05-08 13:26                   ` Yi Liu
2024-05-08 14:11                     ` Jason Gunthorpe
2024-05-09 14:22                       ` Liu, Yi L

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a0543205-18a8-4878-8b24-3d87bee24645@linux.intel.com \
    --to=baolu.lu@linux.intel.com \
    --cc=alex.williamson@redhat.com \
    --cc=chao.p.peng@linux.intel.com \
    --cc=eric.auger@redhat.com \
    --cc=iommu@lists.linux.dev \
    --cc=jacob.jun.pan@intel.com \
    --cc=jgg@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=nicolinc@nvidia.com \
    --cc=robin.murphy@arm.com \
    --cc=yi.l.liu@intel.com \
    --cc=zhenzhong.duan@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox