Linux IOMMU Development
 help / color / mirror / Atom feed
From: Yi Liu <yi.l.liu@intel.com>
To: <kevin.tian@intel.com>, <jgg@nvidia.com>
Cc: <joro@8bytes.org>, <baolu.lu@linux.intel.com>,
	<iommu@lists.linux.dev>, <nicolinc@nvidia.com>
Subject: Re: [PATCH v9 12/21] iommufd/device: Add pasid_attach array to track per-PASID attach
Date: Mon, 17 Mar 2025 15:07:01 +0800	[thread overview]
Message-ID: <c804a37a-61a1-486b-bfc6-d82a19ab9754@intel.com> (raw)
In-Reply-To: <20250313123532.103522-13-yi.l.liu@intel.com>

On 2025/3/13 20:35, Yi Liu wrote:
> PASIDs of PASID-capable device can be attached to hwpt separately, hence
> a pasid array to track per-PASID attachment is necessary. The index
> IOMMU_NO_PASID is used by the RID path. Hence drop the igroup->handle.
> 
> Signed-off-by: Yi Liu <yi.l.liu@intel.com>
> ---
>   drivers/iommu/iommufd/device.c          | 78 +++++++++++++++++--------
>   drivers/iommu/iommufd/iommufd_private.h |  4 +-
>   2 files changed, 54 insertions(+), 28 deletions(-)
> 
> diff --git a/drivers/iommu/iommufd/device.c b/drivers/iommu/iommufd/device.c
> index 7d52f304b9bb..63b189a5b8ac 100644
> --- a/drivers/iommu/iommufd/device.c
> +++ b/drivers/iommu/iommufd/device.c
> @@ -23,7 +23,7 @@ static void iommufd_group_release(struct kref *kref)
>   	struct iommufd_group *igroup =
>   		container_of(kref, struct iommufd_group, ref);
>   
> -	WARN_ON(igroup->handle);
> +	WARN_ON(!xa_empty(&igroup->pasid_attach));
>   
>   	xa_cmpxchg(&igroup->ictx->groups, iommu_group_id(igroup->group), igroup,
>   		   NULL, GFP_KERNEL);
> @@ -90,6 +90,7 @@ static struct iommufd_group *iommufd_get_group(struct iommufd_ctx *ictx,
>   
>   	kref_init(&new_igroup->ref);
>   	mutex_init(&new_igroup->lock);
> +	xa_init(&new_igroup->pasid_attach);
>   	new_igroup->sw_msi_start = PHYS_ADDR_MAX;
>   	/* group reference moves into new_igroup */
>   	new_igroup->group = group;
> @@ -293,16 +294,19 @@ u32 iommufd_device_to_id(struct iommufd_device *idev)
>   }
>   EXPORT_SYMBOL_NS_GPL(iommufd_device_to_id, "IOMMUFD");
>   
> -static int iommufd_group_device_num(struct iommufd_group *igroup)
> +static int iommufd_group_device_num(struct iommufd_group *igroup,
> +				    ioasid_t pasid)
>   {
> +	struct iommufd_attach_handle *handle;
>   	struct iommufd_device *idev;
>   	unsigned long index;
>   	int count = 0;
>   
>   	lockdep_assert_held(&igroup->lock);
>   
> -	if (igroup->handle)
> -		xa_for_each(&igroup->handle->device_array, index, idev)
> +	handle = xa_load(&igroup->pasid_attach, pasid);
> +	if (handle)
> +		xa_for_each(&handle->device_array, index, idev)
>   			count++;
>   	return count;
>   }
> @@ -472,7 +476,7 @@ iommufd_device_attach_reserved_iova(struct iommufd_device *idev,
>   	if (rc)
>   		return rc;
>   
> -	if (!igroup->handle) {
> +	if (!xa_load(&igroup->pasid_attach, IOMMU_NO_PASID)) {
>   		rc = iommufd_group_setup_msi(igroup, hwpt_paging);
>   		if (rc) {
>   			iopt_remove_reserved_iova(&hwpt_paging->ioas->iopt,
> @@ -485,10 +489,14 @@ iommufd_device_attach_reserved_iova(struct iommufd_device *idev,
>   
>   /* The device attach/detach/replace helpers for attach_handle */
>   
> -static bool iommufd_device_is_attached(struct iommufd_device *idev)
> +static bool iommufd_device_is_attached(struct iommufd_device *idev,
> +				       ioasid_t pasid)
>   {
> -	WARN_ON(!idev->igroup->handle);
> -	return xa_load(&idev->igroup->handle->device_array, idev->obj.id);
> +	struct iommufd_attach_handle *handle;
> +
> +	handle = xa_load(&idev->igroup->pasid_attach, pasid);
> +	WARN_ON(!handle);
> +	return xa_load(&handle->device_array, idev->obj.id);
>   }
>   
>   static int iommufd_hwpt_attach_device(struct iommufd_hw_pagetable *hwpt,
> @@ -574,19 +582,25 @@ int iommufd_hw_pagetable_attach(struct iommufd_hw_pagetable *hwpt,
>   {
>   	struct iommufd_hwpt_paging *hwpt_paging = find_hwpt_paging(hwpt);
>   	bool attach_resv = hwpt_paging && pasid == IOMMU_NO_PASID;
> +	struct iommufd_hw_pagetable *old_hwpt = NULL;
>   	struct iommufd_group *igroup = idev->igroup;
> -	struct iommufd_hw_pagetable *old_hwpt;
>   	struct iommufd_attach_handle *handle;
>   	int rc;
>   
>   	mutex_lock(&igroup->lock);
>   
> -	handle = igroup->handle;
> +	handle = xa_cmpxchg(&igroup->pasid_attach, pasid, NULL,
> +			    XA_ZERO_ENTRY, GFP_KERNEL);
> +	if (xa_is_err(handle)) {
> +		rc = PTR_ERR(handle);

An issue was reported by Dan. This should be rc = xa_err(handle); Feel free
to let me know if a v10 is necessary to fix this.

https://lore.kernel.org/all/202503161104.CANtg5Ng-lkp@intel.com/

Regards,
Yi Liu

  reply	other threads:[~2025-03-17  7:02 UTC|newest]

Thread overview: 48+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-13 12:35 [PATCH v9 00/21] iommufd support pasid attach/replace Yi Liu
2025-03-13 12:35 ` [PATCH v9 01/21] iommu: Clear handle->domain in detach Yi Liu
2025-03-18 11:46   ` Jason Gunthorpe
2025-03-18 13:30     ` Yi Liu
2025-03-13 12:35 ` [PATCH v9 02/21] iommu: Wrap pasid_array entry creation and setting Yi Liu
2025-03-18 12:04   ` Jason Gunthorpe
2025-03-18 14:40     ` Yi Liu
2025-03-13 12:35 ` [PATCH v9 03/21] iommu: Introduce a replace API for device pasid Yi Liu
2025-03-18 12:19   ` Jason Gunthorpe
2025-03-18 13:50     ` Baolu Lu
2025-03-18 13:57       ` Jason Gunthorpe
2025-03-13 12:35 ` [PATCH v9 04/21] iommufd: Pass @pasid through the device attach/replace path Yi Liu
2025-03-13 12:35 ` [PATCH v9 05/21] iommufd/device: Only add reserved_iova in non-pasid path Yi Liu
2025-03-18 19:22   ` Nicolin Chen
2025-03-13 12:35 ` [PATCH v9 06/21] iommufd/device: Replace idev->igroup with local variable Yi Liu
2025-03-18 12:25   ` Jason Gunthorpe
2025-03-18 19:24   ` Nicolin Chen
2025-03-13 12:35 ` [PATCH v9 07/21] iommufd/device: Check !igroup->hwpt in iommufd_device_attach_reserved_iova() Yi Liu
2025-03-18 12:27   ` Jason Gunthorpe
2025-03-13 12:35 ` [PATCH v9 08/21] iommufd/device: Lift iommufd_attach_handle handling to upper level helpers Yi Liu
2025-03-18 12:30   ` Jason Gunthorpe
2025-03-13 12:35 ` [PATCH v9 09/21] iommufd/device: Use iommufd_attach_handle track attachment Yi Liu
2025-03-13 12:35 ` [PATCH v9 10/21] iommufd/device: Replace device_list with device_array Yi Liu
2025-03-13 12:35 ` [PATCH v9 11/21] iommufd/device: Move attached device tracking to handle Yi Liu
2025-03-18 12:34   ` Jason Gunthorpe
2025-03-18 13:25     ` Yi Liu
2025-03-18 13:26       ` Jason Gunthorpe
2025-03-18 13:50         ` Yi Liu
2025-03-18 13:56           ` Jason Gunthorpe
2025-03-18 14:13             ` Yi Liu
2025-03-18 14:32               ` Jason Gunthorpe
2025-03-13 12:35 ` [PATCH v9 12/21] iommufd/device: Add pasid_attach array to track per-PASID attach Yi Liu
2025-03-17  7:07   ` Yi Liu [this message]
2025-03-13 12:35 ` [PATCH v9 13/21] iommufd: Enforce PASID-compatible domain in PASID path Yi Liu
2025-03-13 12:35 ` [PATCH v9 14/21] iommufd: Support pasid attach/replace Yi Liu
2025-03-18 12:35   ` Jason Gunthorpe
2025-03-13 12:35 ` [PATCH v9 15/21] iommufd: Enforce PASID-compatible domain for RID Yi Liu
2025-03-18 12:38   ` Jason Gunthorpe
2025-03-18 14:09     ` Yi Liu
2025-03-13 12:35 ` [PATCH v9 16/21] iommu/vt-d: Add IOMMU_HWPT_ALLOC_PASID support Yi Liu
2025-03-13 12:35 ` [PATCH v9 17/21] iommufd: Allow allocating PASID-compatible domain Yi Liu
2025-03-18 12:39   ` Jason Gunthorpe
2025-03-13 12:35 ` [PATCH v9 18/21] iommufd/selftest: Add set_dev_pasid in mock iommu Yi Liu
2025-03-13 12:35 ` [PATCH v9 19/21] iommufd/selftest: Add a helper to get test device Yi Liu
2025-03-13 12:35 ` [PATCH v9 20/21] iommufd/selftest: Add test ops to test pasid attach/detach Yi Liu
2025-03-13 12:35 ` [PATCH v9 21/21] iommufd/selftest: Add coverage for iommufd " Yi Liu
2025-03-18 12:41 ` [PATCH v9 00/21] iommufd support pasid attach/replace Jason Gunthorpe
2025-03-18 14:37   ` Yi Liu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c804a37a-61a1-486b-bfc6-d82a19ab9754@intel.com \
    --to=yi.l.liu@intel.com \
    --cc=baolu.lu@linux.intel.com \
    --cc=iommu@lists.linux.dev \
    --cc=jgg@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=nicolinc@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox