* Re: [PATCH] KVM: selftests: hyperv_tlb_flush: use swap() to swap PTEs
2026-05-28 13:13 ` Sean Christopherson
@ 2026-05-28 14:07 ` Piotr Zarycki
2026-05-28 14:10 ` [PATCH v2] " Piotr Zarycki
2026-05-28 15:35 ` Piotr Zarycki
2 siblings, 0 replies; 7+ messages in thread
From: Piotr Zarycki @ 2026-05-28 14:07 UTC (permalink / raw)
To: Sean Christopherson
Cc: pbonzini, shuah, dmatlack, vkuznets, kvm, linux-kselftest,
linux-kernel
On Thu, May 28, 2026 at 06:13:16AM -0700, Sean Christopherson wrote:
> On Thu, May 28, 2026, Piotr Zarycki wrote:
> > Replace the open-coded swap with the swap() macro.
> >
> > Signed-off-by: Piotr Zarycki <piotr.zarycki@gmail.com>
> > ---
> > tools/testing/selftests/kvm/include/test_util.h | 2 ++
> > tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c | 6 +-----
> > 2 files changed, 3 insertions(+), 5 deletions(-)
> >
> > diff --git a/tools/testing/selftests/kvm/include/test_util.h b/tools/testing/selftests/kvm/include/test_util.h
> > index d9b433b834f1..a66bc9ccba65 100644
> > --- a/tools/testing/selftests/kvm/include/test_util.h
> > +++ b/tools/testing/selftests/kvm/include/test_util.h
> > @@ -26,6 +26,8 @@
> >
> > #define msecs_to_usecs(msec) ((msec) * 1000ULL)
> >
> > +#define swap(a, b) do { typeof(a) __tmp = (a); (a) = (b); (b) = __tmp; } while (0)
>
> This belongs in a common tools/ header, not in KVM's test_util.h. I don't see
> an obvious place, maybe tools/include/linux/kernel.h?
Good point, v2 below.
^ permalink raw reply [flat|nested] 7+ messages in thread* [PATCH v2] KVM: selftests: hyperv_tlb_flush: use swap() to swap PTEs
2026-05-28 13:13 ` Sean Christopherson
2026-05-28 14:07 ` Piotr Zarycki
@ 2026-05-28 14:10 ` Piotr Zarycki
2026-05-28 15:35 ` Piotr Zarycki
2 siblings, 0 replies; 7+ messages in thread
From: Piotr Zarycki @ 2026-05-28 14:10 UTC (permalink / raw)
To: seanjc, pbonzini
Cc: shuah, dmatlack, vkuznets, kvm, linux-kselftest, linux-kernel,
Piotr Zarycki
Replace the open-coded swap with the swap() macro.
Signed-off-by: Piotr Zarycki <piotr.zarycki@gmail.com>
---
tools/include/linux/kernel.h | 4 ++++
tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c | 6 +-----
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/tools/include/linux/kernel.h b/tools/include/linux/kernel.h
index c8c18d3908a9..381e457960dc 100644
--- a/tools/include/linux/kernel.h
+++ b/tools/include/linux/kernel.h
@@ -46,6 +46,10 @@
#define min_t(type, x, y) min((type)x, (type)y)
#define clamp(val, lo, hi) min((typeof(val))max(val, lo), hi)
+#ifndef swap
+#define swap(a, b) do { typeof(a) __tmp = (a); (a) = (b); (b) = __tmp; } while (0)
+#endif
+
#ifndef BUG_ON
#ifdef NDEBUG
#define BUG_ON(cond) do { if (cond) {} } while (0)
diff --git a/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c b/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c
index 15ee8b7bfc11..514d41f00714 100644
--- a/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c
+++ b/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c
@@ -131,14 +131,10 @@ static void set_expected_val(void *addr, u64 val, int vcpu_id)
/*
* Update PTEs swapping two test pages.
- * TODO: use swap()/xchg() when these are provided.
*/
static void swap_two_test_pages(gpa_t pte_gva1, gpa_t pte_gva2)
{
- u64 tmp = *(u64 *)pte_gva1;
-
- *(u64 *)pte_gva1 = *(u64 *)pte_gva2;
- *(u64 *)pte_gva2 = tmp;
+ swap(*(u64 *)pte_gva1, *(u64 *)pte_gva2);
}
/*
--
2.54.0
^ permalink raw reply related [flat|nested] 7+ messages in thread* [PATCH v2] KVM: selftests: hyperv_tlb_flush: use swap() to swap PTEs
2026-05-28 13:13 ` Sean Christopherson
2026-05-28 14:07 ` Piotr Zarycki
2026-05-28 14:10 ` [PATCH v2] " Piotr Zarycki
@ 2026-05-28 15:35 ` Piotr Zarycki
2026-06-25 7:09 ` [PATCH v3] selftests: add swap() macro to kselftest.h Piotr Zarycki
2 siblings, 1 reply; 7+ messages in thread
From: Piotr Zarycki @ 2026-05-28 15:35 UTC (permalink / raw)
To: seanjc, pbonzini
Cc: shuah, dmatlack, vkuznets, kvm, linux-kselftest, linux-kernel,
Piotr Zarycki
Replace the open-coded swap with the swap() macro.
Signed-off-by: Piotr Zarycki <piotr.zarycki@gmail.com>
---
tools/include/linux/kernel.h breaks perf — swap is used there as a
function pointer call. Using tools/testing/selftests/kselftest.h instead.
tools/testing/selftests/kselftest.h | 4 ++++
tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c | 6 +-----
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/tools/testing/selftests/kselftest.h b/tools/testing/selftests/kselftest.h
index 60838b61a2da..7f53751523d8 100644
--- a/tools/testing/selftests/kselftest.h
+++ b/tools/testing/selftests/kselftest.h
@@ -64,6 +64,10 @@
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
#endif
+#ifndef swap
+#define swap(a, b) do { typeof(a) __tmp = (a); (a) = (b); (b) = __tmp; } while (0)
+#endif
+
#if defined(__i386__) || defined(__x86_64__) /* arch */
/*
* gcc cpuid.h provides __cpuid_count() since v4.4.
diff --git a/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c b/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c
index 15ee8b7bfc11..514d41f00714 100644
--- a/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c
+++ b/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c
@@ -131,14 +131,10 @@ static void set_expected_val(void *addr, u64 val, int vcpu_id)
/*
* Update PTEs swapping two test pages.
- * TODO: use swap()/xchg() when these are provided.
*/
static void swap_two_test_pages(gpa_t pte_gva1, gpa_t pte_gva2)
{
- u64 tmp = *(u64 *)pte_gva1;
-
- *(u64 *)pte_gva1 = *(u64 *)pte_gva2;
- *(u64 *)pte_gva2 = tmp;
+ swap(*(u64 *)pte_gva1, *(u64 *)pte_gva2);
}
/*
--
2.54.0
^ permalink raw reply related [flat|nested] 7+ messages in thread* [PATCH v3] selftests: add swap() macro to kselftest.h
2026-05-28 15:35 ` Piotr Zarycki
@ 2026-06-25 7:09 ` Piotr Zarycki
2026-07-09 14:55 ` Sean Christopherson
0 siblings, 1 reply; 7+ messages in thread
From: Piotr Zarycki @ 2026-06-25 7:09 UTC (permalink / raw)
To: kvm, linux-kselftest; +Cc: seanjc, vkuznets, shuah, linux-kernel, Piotr Zarycki
Add swap() to tools/testing/selftests/kselftest.h with an #ifndef guard.
Guard the local swap() definition in mm/uffd-stress.c with #ifndef to
prevent a redefinition warning.
Use swap() in hyperv_tlb_flush.c to replace the open-coded PTE swap and
remove the TODO comment.
Signed-off-by: Piotr Zarycki <piotr.zarycki@gmail.com>
---
Changes in v3:
- Add #ifndef guard to mm/uffd-stress.c to fix a redefinition warning;
uffd-stress.c defines its own swap() without a guard, which conflicts
when kselftest.h is included first via uffd-common.h.
Changes in v2:
- Move swap() from tools/include/linux/kernel.h to kselftest.h; kernel.h
breaks perf (swap is used there as a function pointer call).
tools/testing/selftests/kselftest.h | 4 ++++
tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c | 6 +-----
tools/testing/selftests/mm/uffd-stress.c | 2 ++
3 files changed, 7 insertions(+), 5 deletions(-)
diff --git a/tools/testing/selftests/kselftest.h b/tools/testing/selftests/kselftest.h
index 60838b61a2da..7f53751523d8 100644
--- a/tools/testing/selftests/kselftest.h
+++ b/tools/testing/selftests/kselftest.h
@@ -64,6 +64,10 @@
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
#endif
+#ifndef swap
+#define swap(a, b) do { typeof(a) __tmp = (a); (a) = (b); (b) = __tmp; } while (0)
+#endif
+
#if defined(__i386__) || defined(__x86_64__) /* arch */
/*
* gcc cpuid.h provides __cpuid_count() since v4.4.
diff --git a/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c b/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c
index 15ee8b7bfc11..514d41f00714 100644
--- a/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c
+++ b/tools/testing/selftests/kvm/x86/hyperv_tlb_flush.c
@@ -131,14 +131,10 @@ static void set_expected_val(void *addr, u64 val, int vcpu_id)
/*
* Update PTEs swapping two test pages.
- * TODO: use swap()/xchg() when these are provided.
*/
static void swap_two_test_pages(gpa_t pte_gva1, gpa_t pte_gva2)
{
- u64 tmp = *(u64 *)pte_gva1;
-
- *(u64 *)pte_gva1 = *(u64 *)pte_gva2;
- *(u64 *)pte_gva2 = tmp;
+ swap(*(u64 *)pte_gva1, *(u64 *)pte_gva2);
}
/*
diff --git a/tools/testing/selftests/mm/uffd-stress.c b/tools/testing/selftests/mm/uffd-stress.c
index 700fbaa18d44..802046e905dd 100644
--- a/tools/testing/selftests/mm/uffd-stress.c
+++ b/tools/testing/selftests/mm/uffd-stress.c
@@ -56,8 +56,10 @@ static uffd_global_test_opts_t *gopts;
static char *zeropage;
pthread_attr_t attr;
+#ifndef swap
#define swap(a, b) \
do { __auto_type __tmp = (a); (a) = (b); (b) = __tmp; } while (0)
+#endif
const char *examples =
"# Run anonymous memory test on 100MiB region with 99999 bounces:\n"
--
2.54.0
^ permalink raw reply related [flat|nested] 7+ messages in thread* Re: [PATCH v3] selftests: add swap() macro to kselftest.h
2026-06-25 7:09 ` [PATCH v3] selftests: add swap() macro to kselftest.h Piotr Zarycki
@ 2026-07-09 14:55 ` Sean Christopherson
0 siblings, 0 replies; 7+ messages in thread
From: Sean Christopherson @ 2026-07-09 14:55 UTC (permalink / raw)
To: Piotr Zarycki; +Cc: kvm, linux-kselftest, vkuznets, shuah, linux-kernel
On Thu, Jun 25, 2026, Piotr Zarycki wrote:
> Add swap() to tools/testing/selftests/kselftest.h with an #ifndef guard.
>
> Guard the local swap() definition in mm/uffd-stress.c with #ifndef to
> prevent a redefinition warning.
>
> Use swap() in hyperv_tlb_flush.c to replace the open-coded PTE swap and
> remove the TODO comment.
>
> Signed-off-by: Piotr Zarycki <piotr.zarycki@gmail.com>
> ---
> Changes in v3:
> - Add #ifndef guard to mm/uffd-stress.c to fix a redefinition warning;
> uffd-stress.c defines its own swap() without a guard, which conflicts
> when kselftest.h is included first via uffd-common.h.
Why not explicitly include kselftest.h in mm/uffd-stress.c and drop uffd-stress.c's
version of swap()?
^ permalink raw reply [flat|nested] 7+ messages in thread