Linux LED subsystem development
 help / color / mirror / Atom feed
From: sashiko-bot@kernel.org
To: "Liang Haowen" <nbg2974@gmail.com>
Cc: linux-scsi@vger.kernel.org, lee@kernel.org, linux-leds@vger.kernel.org
Subject: Re: [PATCH RFC v5 1/1] leds: asus-aura-scsi: Add ASUS Aura RGB LED driver for ROG NVMe enclosures
Date: Wed, 16 Sep 2026 12:27:40 +0000	[thread overview]
Message-ID: <20260916122740.921E51F000FF@smtp.kernel.org> (raw)
In-Reply-To: <202609162015.RFCv5-1.lhw@gmail.com>

Thank you for your contribution! Sashiko AI review found 3 potential issue(s) to consider:
- [Low] block: build failure due to missing request_queue argument in blk_rq_map_kern()
- [Low] leds: build failure due to undefined macro kzalloc_obj()
- [Low] leds: UAPI naming convention violation for LED class device
--

commit fe7900b55dc69157a3ef071f13e8783fac33da59
Author: Liang Haowen <nbg2974@gmail.com>

leds: asus-aura-scsi: Add ASUS Aura RGB LED driver for ROG NVMe enclosures

This commit adds a new SCSI driver for ASUS Aura RGB LEDs found on ROG
NVMe enclosures. It exposes each LED as a multicolor LED class device by
routing vendor SCSI commands. Updates are batched and scheduled via a
workqueue to prevent concurrent writes.

> diff --git a/drivers/leds/leds-asus-aura-scsi.c b/drivers/leds/leds-asus-aura-scsi.c
> new file mode 100644
> index 0000000000000..a1e31dc3f0101
> --- /dev/null
> +++ b/drivers/leds/leds-asus-aura-scsi.c
[ ... ]
> +	if (arg_count) {
> +		ret = blk_rq_map_kern(rq, (void *)data, arg_count, GFP_NOIO);

[Severity: Low]
Does this build against the current block layer?

The blk_rq_map_kern() function requires five arguments, including a
struct request_queue pointer. Only four arguments are provided here.

> +		if (ret)
> +			goto out;
> +	}
[ ... ]
> +	/*
> +	 * Include the sdev's H:C:T:L: every enclosure gets its own SCSI
> +	 * host, so the names stay unique when more than one is connected.
> +	 * With a static name the LED core would register the second
> +	 * enclosure's LEDs under renamed nodes (asus-arion:led0_1), which
> +	 * is the wrong device identity. The names are per-attachment, like
> +	 * sd X letters, and userspace is expected to enumerate.
> +	 *
> +	 * dev_name() renders the sdev as H:C:T:L; the extra colons would
> +	 * break the devicename:color:function scheme userspace parses LED
> +	 * class names with, so they are flattened to dashes and the name
> +	 * keeps exactly one separator.
> +	 */
> +	strscpy(hctl, dev_name(&zone->sdev->sdev_gendev), sizeof(hctl));
> +	strreplace(hctl, ':', '-');
> +	cdev->name = kasprintf(GFP_KERNEL, "asus-arion-%s:led%d", hctl, index);

[Severity: Low]
Does this naming scheme violate the UAPI LED naming convention?

The standard format requires two colons (devicename:color:function), as
documented in Documentation/leds/leds-class.rst. The comment above states
this follows the devicename:color:function convention, but the generated
name (e.g., asus-arion-xxxx:led0) only contains a single colon.

> +	if (!cdev->name)
> +		return -ENOMEM;
[ ... ]
> +	if (strncmp(sdev->vendor, ARION_INQ_VENDOR, strlen(ARION_INQ_VENDOR)) ||
> +	    strncmp(sdev->model, ARION_INQ_MODEL, strlen(ARION_INQ_MODEL)))
> +		return SCSI_DH_DEV_UNSUPP;
> +
> +	zone = kzalloc_obj(*zone, GFP_KERNEL);

[Severity: Low]
Is kzalloc_obj() a valid macro in the kernel API?

It appears to be undefined, which will cause a build failure.
Should this just be kzalloc(sizeof(*zone), GFP_KERNEL)?

> +	if (!zone)
> +		return SCSI_DH_NOMEM;

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/202609162015.RFCv5-1.lhw@gmail.com?part=1

  reply	other threads:[~2026-09-16 12:27 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-01 14:26 [PATCH RFC 0/1] leds: add ASUS Aura SCSI driver for ROG NVMe enclosures Liang Haowen
2026-09-01 14:34 ` [PATCH RFC 1/1] " Liang Haowen
2026-09-01 14:52   ` sashiko-bot
2026-09-03 12:00 ` [PATCH RFC v2 1/1] leds: asus-aura-scsi: Add ASUS Aura RGB LED " Liang Haowen
2026-09-03 12:24   ` sashiko-bot
2026-09-03 16:13     ` Lee Jones
2026-09-04 12:30       ` [PATCH RFC v3 0/1] " Liang Haowen
2026-09-04 12:30         ` [PATCH RFC v3 1/1] " Liang Haowen
2026-09-04 13:15           ` sashiko-bot
2026-09-10  9:32             ` Lee Jones
2026-09-15 12:48               ` [PATCH RFC v4 0/1] " Liang Haowen
2026-09-15 12:49                 ` [PATCH RFC v4 1/1] " Liang Haowen
2026-09-15 13:00                   ` sashiko-bot
2026-09-16 10:43                     ` Lee Jones
2026-09-16 12:15                       ` [PATCH RFC v5 0/1] " Liang Haowen
2026-09-16 12:15                         ` [PATCH RFC v5 1/1] " Liang Haowen
2026-09-16 12:27                           ` sashiko-bot [this message]
2026-09-16 13:06                             ` Lee Jones
2026-09-16 14:22                               ` [PATCH RFC v6 0/1] " Liang Haowen
2026-09-16 14:22                                 ` [PATCH RFC v6 1/1] " Liang Haowen
2026-09-16 14:38                                   ` sashiko-bot
2026-09-17 11:28                                     ` Lee Jones
2026-09-17 11:49                                       ` Liang Haowen
2026-09-23  9:45                                   ` Lee Jones
2026-09-23 10:18                                     ` Liang Haowen
     [not found]                                       ` <20260923102812.2353292-1-nbg2974@gmail.com>
2026-09-23 10:12                                   ` Ilpo Järvinen
2026-09-16 14:23                               ` [PATCH RFC v5 " Liang Haowen
2026-09-16 12:15                       ` [PATCH RFC v4 " Liang Haowen
2026-09-15 12:49               ` [PATCH RFC v3 " Liang Haowen
2026-09-04 12:45       ` [PATCH RFC v2 " Liang Haowen
2026-09-03 12:00 ` [PATCH RFC v2 0/1] " Liang Haowen
  -- strict thread matches above, loose matches on Subject: below --
2026-09-23 10:30 [RFC v7 " Liang Haowen
2026-09-23 10:30 ` [RFC v7 1/1] " Liang Haowen
2026-09-23 10:44   ` sashiko-bot
2026-09-23 10:45   ` Lee Jones
2026-09-23 11:19     ` Liang Haowen
2026-09-23 10:41 ` [RFC v7 0/1] " Ilpo Järvinen
2026-09-23 12:35   ` Denis Benato
2026-09-23 12:59     ` Liang Haowen
2026-09-23 15:11       ` Marco Scardovi
2026-09-25 12:22         ` Liang Haowen
2026-09-25 12:41           ` Marco Scardovi
2026-09-25 12:45             ` Liang Haowen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260916122740.921E51F000FF@smtp.kernel.org \
    --to=sashiko-bot@kernel.org \
    --cc=lee@kernel.org \
    --cc=linux-leds@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=nbg2974@gmail.com \
    --cc=sashiko-reviews@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox