Linux LVM users
 help / color / mirror / Atom feed
* [linux-lvm] lv_on_disk_size
@ 2000-08-19 15:27 Jan Niehusmann
  2000-08-21 16:38 ` Jan Niehusmann
  2000-08-22  1:47 ` [linux-lvm] lv_on_disk_size Heinz J. Mauelshagen
  0 siblings, 2 replies; 3+ messages in thread
From: Jan Niehusmann @ 2000-08-19 15:27 UTC (permalink / raw)
  To: linux-lvm; +Cc: linux-lvm-bug, adilger

In the BUGS file, one mentioned bug fix is the following:

> Please change the macro LVM_LV_DISK_OFFSET as below:
> 
> #define LVM_LV_DISK_OFFSET(a, b) ( (a)->lv_on_disk.base + \
>                                    sizeof ( lv_disk_t) * b)
> 

Without really understanding what's going on (all these lv_, pe_, ...
prefixes are really confusing me ;-)) I wonder if the following line
in vg_setup_for_create.c is correct:

(Line 94)
      vg->pv[p]->lv_on_disk.size = ( max_lv + 1) * sizeof ( lv_t);

Or should it be sizeof( lv_disk_t), too?


Jan

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [linux-lvm] lv_on_disk_size
  2000-08-19 15:27 [linux-lvm] lv_on_disk_size Jan Niehusmann
@ 2000-08-21 16:38 ` Jan Niehusmann
  2000-08-22  1:47 ` [linux-lvm] lv_on_disk_size Heinz J. Mauelshagen
  1 sibling, 0 replies; 3+ messages in thread
From: Jan Niehusmann @ 2000-08-21 16:38 UTC (permalink / raw)
  To: linux-lvm

Finally, I'm starting to reply to my own posts. I knew this would happen
one day ;-)

On Sat, Aug 19, 2000 at 05:27:39PM +0200, Jan Niehusmann wrote:
> In the BUGS file, one mentioned bug fix is the following:
> 
> > Please change the macro LVM_LV_DISK_OFFSET as below:
> > 
> > #define LVM_LV_DISK_OFFSET(a, b) ( (a)->lv_on_disk.base + \
> >                                    sizeof ( lv_disk_t) * b)
> > 

Additionally, I found that linux/lvm.h of linux-2.4-testX does contain 
the same line. In fact, linux/lvm.h is nearly identical to tools/lib/lvm.h.
I wonder if this code duplication is needed. Now that lvm is included with
the (development) kernel, linux/lvm.h should contain only things needed for
kernel compilation (IMHO).

Jan

^ permalink raw reply	[flat|nested] 3+ messages in thread

* [linux-lvm] Re: lv_on_disk_size
  2000-08-19 15:27 [linux-lvm] lv_on_disk_size Jan Niehusmann
  2000-08-21 16:38 ` Jan Niehusmann
@ 2000-08-22  1:47 ` Heinz J. Mauelshagen
  1 sibling, 0 replies; 3+ messages in thread
From: Heinz J. Mauelshagen @ 2000-08-22  1:47 UTC (permalink / raw)
  To: jan; +Cc: linux-lvm

On Sat, Aug 19, 2000 at 05:27:39PM +0200, Jan Niehusmann wrote:
> In the BUGS file, one mentioned bug fix is the following:
> 
> > Please change the macro LVM_LV_DISK_OFFSET as below:
> > 
> > #define LVM_LV_DISK_OFFSET(a, b) ( (a)->lv_on_disk.base + \
> >                                    sizeof ( lv_disk_t) * b)
> > 
> 
> Without really understanding what's going on (all these lv_, pe_, ...
> prefixes are really confusing me ;-)) I wonder if the following line
> in vg_setup_for_create.c is correct:
> 
> (Line 94)
>       vg->pv[p]->lv_on_disk.size = ( max_lv + 1) * sizeof ( lv_t);
> 
> Or should it be sizeof( lv_disk_t), too?

Yes, it should.
THX for pinting this out.

Regards,
Heinz      -- The LVM guy --

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Heinz Mauelshagen                                 Sistina Software Inc.
Senior Consultant/Developer                       Bartningstr. 12
                                                  64289 Darmstadt
                                                  Germany
Mauelshagen@Sistina.com                           +49 6151 7103 86
                                                       FAX 7103 96
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2000-08-22  1:47 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2000-08-19 15:27 [linux-lvm] lv_on_disk_size Jan Niehusmann
2000-08-21 16:38 ` Jan Niehusmann
2000-08-22  1:47 ` [linux-lvm] lv_on_disk_size Heinz J. Mauelshagen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox