Linux Media Controller development
 help / color / mirror / Atom feed
From: Oliver Neukum <oneukum@suse.de>
To: Hans Verkuil <hverkuil@xs4all.nl>,
	ben.hutchings@codethink.co.uk, gregkh@linuxfoundation.org,
	mchehab@s-opensource.com, linux-media@vger.kernel.org
Cc: stable@vger.kernel.org
Subject: Re: [PATCH] [Patch v2] usbtv: Fix refcounting mixup
Date: Wed, 16 Sep 2020 15:47:26 +0200	[thread overview]
Message-ID: <1600264046.2424.23.camel@suse.de> (raw)
In-Reply-To: <4550f8e2-38a9-b1f4-0277-25e79fed2e14@xs4all.nl>

[-- Attachment #1: Type: text/plain, Size: 1235 bytes --]

Am Mittwoch, den 16.05.2018, 12:27 +0200 schrieb Hans Verkuil:
> On 05/16/18 11:23, Oliver Neukum wrote:
> > Am Dienstag, den 15.05.2018, 18:01 +0200 schrieb Hans Verkuil:
> > > On 05/15/2018 05:46 PM, Oliver Neukum wrote:
> > > > Am Dienstag, den 15.05.2018, 16:28 +0200 schrieb Hans Verkuil:
> > > > > On 05/15/18 15:07, Oliver Neukum wrote:

> > Eh, but we cannot create a V4L device before the first device
> > is connected and we must certainly create multiple V4L devices if
> > multiple physical devices are connected.
> 
> v4l2_device_register is a terrible name. It does not create devices
> or register with anything, it just initializes a root data structure. I have
> proposed renaming this to v4l2_root_init() in the past, but people didn't
> want a big rename action.
> 
> BTW, with 'global data structure' I meant a data structure in struct usbtv.
> All I meant to say is that v4l2_device_register should be called in probe(),
> not in usbtv_video_init().

Hi,

Sorry for thread necromancy I am cleaning up electronically.
This patch has fallen through the cracks. As far as I can see the issue
is still open. I screwed this up. So do you want me to do a major
redesign? If not, what is to be done?

	Regards
		Oliver



[-- Attachment #2: 0001-Patch-v2-usbtv-Fix-refcounting-mixup.patch --]
[-- Type: text/x-patch, Size: 1182 bytes --]

From c6040618651d670b895198096e3fa442b6cf8a26 Mon Sep 17 00:00:00 2001
From: Oliver Neukum <oneukum@suse.com>
Date: Tue, 15 May 2018 12:16:26 +0200
Subject: [PATCH] [Patch v2] usbtv: Fix refcounting mixup

The premature free in the error path is blocked by V4L
refcounting, not USB refcounting. Thanks to
Ben Hutchings for review.

[v2] corrected attributions

Signed-off-by: Oliver Neukum <oneukum@suse.com>
Fixes: 50e704453553 ("media: usbtv: prevent double free in error case")
CC: stable@vger.kernel.org
Reported-by: Ben Hutchings <ben.hutchings@codethink.co.uk>
---
 drivers/media/usb/usbtv/usbtv-core.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/drivers/media/usb/usbtv/usbtv-core.c b/drivers/media/usb/usbtv/usbtv-core.c
index ee9c656d121f..2308c0b4f5e7 100644
--- a/drivers/media/usb/usbtv/usbtv-core.c
+++ b/drivers/media/usb/usbtv/usbtv-core.c
@@ -113,7 +113,8 @@ static int usbtv_probe(struct usb_interface *intf,
 
 usbtv_audio_fail:
 	/* we must not free at this point */
-	usb_get_dev(usbtv->udev);
+	v4l2_device_get(&usbtv->v4l2_dev);
+	/* this will undo the v4l2_device_get() */
 	usbtv_video_free(usbtv);
 
 usbtv_video_fail:
-- 
2.16.4


  reply	other threads:[~2020-09-16 17:55 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-05-15 13:07 [PATCH] [Patch v2] usbtv: Fix refcounting mixup Oliver Neukum
2018-05-15 14:28 ` Hans Verkuil
2018-05-15 15:46   ` Oliver Neukum
2018-05-15 16:01     ` Hans Verkuil
2018-05-16  9:23       ` Oliver Neukum
2018-05-16 10:27         ` Hans Verkuil
2020-09-16 13:47           ` Oliver Neukum [this message]
2020-09-21  9:10           ` Oliver Neukum

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1600264046.2424.23.camel@suse.de \
    --to=oneukum@suse.de \
    --cc=ben.hutchings@codethink.co.uk \
    --cc=gregkh@linuxfoundation.org \
    --cc=hverkuil@xs4all.nl \
    --cc=linux-media@vger.kernel.org \
    --cc=mchehab@s-opensource.com \
    --cc=stable@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox