Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Dev Jain <dev.jain@arm.com>
To: Barry Song <baohua@kernel.org>
Cc: akpm@linux-foundation.org, david@kernel.org, ljs@kernel.org,
	hughd@google.com, chrisl@kernel.org, kasong@tencent.com,
	riel@surriel.com, liam@infradead.org, vbabka@kernel.org,
	harry@kernel.org, jannh@google.com, lance.yang@linux.dev,
	baolin.wang@linux.alibaba.com, shikemeng@huaweicloud.com,
	nphamcs@gmail.com, baoquan.he@linux.dev, youngjun.park@lge.com,
	linux-mm@kvack.org, linux-kernel@vger.kernel.org,
	rppt@kernel.org, surenb@google.com, mhocko@suse.com,
	pfalcato@suse.de, ryan.roberts@arm.com,
	anshuman.khandual@arm.com
Subject: Re: [PATCH v2 5/8] mm/internal: rename swap offset helpers to softleaf offset
Date: Mon, 7 Sep 2026 11:08:30 +0530	[thread overview]
Message-ID: <12efdc7f-ff82-412b-b79d-bff211d34218@arm.com> (raw)
In-Reply-To: <CAGsJ_4yigbhqkrnufJKC2+rW7StraQvD0gr=4HQkTjKGQ9siGQ@mail.gmail.com>



On 05/09/26 4:12 pm, Barry Song wrote:
> On Tue, Sep 1, 2026 at 1:44 PM Dev Jain <dev.jain@arm.com> wrote:
>>
>> In preparation for adding a helper to set softleaf ptes in one go,
>> generalize the swap entry helpers shifting the swap offset by delta,
>> for softleaves.
>>
>> Note that the soft-dirty bit, exclusive bit and uffd bit preservation
>> will still work for non-swap softleaves, since a softleaf entry is
>> constructed out of a type and offset, and those bits are ahead of
>> the soft-dirty, exclusive and uffd bits.
>>
>> For example, for a migration entry, pte_swp_exclusive() will return
>> false, as the exclusivity is encoded in the type itself
>> (SOFTLEAF_MIGRATION_READ_EXCLUSIVE).
> 
> I don't quite understand why you mention this. Is anyone calling
> `pte_swp_exclusive()` on a migration entry? Shouldn't it only be called
> when `softleaf_is_swap()` is true?

You are right. I just wanted to emphasize the second paragraph - that the
pte_move_swp_offset will also work for softleaf entries. But I think
the third para confuses more, I'll drop it.

> 
>>
>> Signed-off-by: Dev Jain <dev.jain@arm.com>
> 
> Reviewed-by: Barry Song <baohua@kernel.org>

Thanks.


> 
>> ---
>>  mm/internal.h | 29 +++++++++++++++--------------
>>  mm/memory.c   |  4 ++--
>>  2 files changed, 17 insertions(+), 16 deletions(-)
>>
> [...]
>>
>>  /**
>> @@ -523,7 +524,7 @@ static inline pte_t pte_next_swp_offset(pte_t pte)
>>   */
>>  static inline int swap_pte_batch(pte_t *start_ptep, int max_nr, pte_t pte)
>>  {
> 
> We might find a user for this in the future, in which case we might
> want to rename `swap_pte_batch()` to `swap_softleaf_batch()`?

That is what is being done here:
https://lore.kernel.org/all/20260813-migrate-rmap-batch-v2-1-3c5424c555c7@amd.com/

I don't have a strong opinion, I can also generalize this right now.


> 
>> -       pte_t expected_pte = pte_next_swp_offset(pte);
>> +       pte_t expected_pte = pte_next_softleaf_offset(pte);
> 
> Best Regards
> Barry



  parent reply	other threads:[~2026-09-07  5:38 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-01  5:43 [PATCH v2 0/8] Optimize anonymous swapbacked large folio unmapping Dev Jain
2026-09-01  5:43 ` [PATCH v2 1/8] mm/swapfile: add batched version of folio_dup_swap Dev Jain
2026-09-01  5:43 ` [PATCH v2 2/8] mm/swapfile: add batched version of folio_put_swap Dev Jain
2026-09-01  5:43 ` [PATCH v2 3/8] mm: move anon-exclusive batch helper to mm.h Dev Jain
2026-09-01  5:49   ` Barry Song
2026-09-01  6:24     ` Dev Jain
2026-09-02  6:29       ` Barry Song
2026-09-04  3:46   ` Dev Jain
2026-09-01  5:43 ` [PATCH v2 4/8] mm/rmap: Add batched version of folio_try_share_anon_rmap_pte Dev Jain
     [not found]   ` <CAGsJ_4zWPXoJ5kiLoVcq1YHv6WcmjPEssTUs4OT15iNRob3_rQ@mail.gmail.com>
2026-09-09  7:44     ` Dev Jain
2026-09-01  5:43 ` [PATCH v2 5/8] mm/internal: rename swap offset helpers to softleaf offset Dev Jain
2026-09-05 10:42   ` Barry Song
2026-09-05 10:49     ` Barry Song
2026-09-07  5:38     ` Dev Jain [this message]
2026-09-07 21:33       ` Barry Song
2026-09-08  5:38         ` Dev Jain
2026-09-08  8:41           ` Garg, Shivank
2026-09-01  5:43 ` [PATCH v2 6/8] mm/internal: add set_softleaf_ptes Dev Jain
2026-09-05 10:52   ` Barry Song
2026-09-01  5:43 ` [PATCH v2 7/8] mm/memory: use set_softleaf_ptes for uffd-wp markers Dev Jain
2026-09-05 10:53   ` Barry Song
2026-09-01  5:43 ` [PATCH v2 8/8] mm/rmap: batch unmap anonymous swap-backed large folios Dev Jain
2026-09-08 21:48   ` Barry Song

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=12efdc7f-ff82-412b-b79d-bff211d34218@arm.com \
    --to=dev.jain@arm.com \
    --cc=akpm@linux-foundation.org \
    --cc=anshuman.khandual@arm.com \
    --cc=baohua@kernel.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=baoquan.he@linux.dev \
    --cc=chrisl@kernel.org \
    --cc=david@kernel.org \
    --cc=harry@kernel.org \
    --cc=hughd@google.com \
    --cc=jannh@google.com \
    --cc=kasong@tencent.com \
    --cc=lance.yang@linux.dev \
    --cc=liam@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=nphamcs@gmail.com \
    --cc=pfalcato@suse.de \
    --cc=riel@surriel.com \
    --cc=rppt@kernel.org \
    --cc=ryan.roberts@arm.com \
    --cc=shikemeng@huaweicloud.com \
    --cc=surenb@google.com \
    --cc=vbabka@kernel.org \
    --cc=youngjun.park@lge.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox