Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Garg, Shivank" <shivankg@amd.com>
To: "dev.jain@arm.com" <dev.jain@arm.com>,
	"baohua@kernel.org" <baohua@kernel.org>
Cc: "hughd@google.com" <hughd@google.com>,
	"rppt@kernel.org" <rppt@kernel.org>,
	"chrisl@kernel.org" <chrisl@kernel.org>,
	"shikemeng@huaweicloud.com" <shikemeng@huaweicloud.com>,
	"harry@kernel.org" <harry@kernel.org>,
	"vbabka@kernel.org" <vbabka@kernel.org>,
	"riel@surriel.com" <riel@surriel.com>,
	"akpm@linux-foundation.org" <akpm@linux-foundation.org>,
	"david@kernel.org" <david@kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"nphamcs@gmail.com" <nphamcs@gmail.com>,
	"surenb@google.com" <surenb@google.com>,
	"linux-mm@kvack.org" <linux-mm@kvack.org>,
	"youngjun.park@lge.com" <youngjun.park@lge.com>,
	"anshuman.khandual@arm.com" <anshuman.khandual@arm.com>,
	"ryan.roberts@arm.com" <ryan.roberts@arm.com>,
	"kasong@tencent.com" <kasong@tencent.com>,
	"liam@infradead.org" <liam@infradead.org>,
	"jannh@google.com" <jannh@google.com>,
	"baolin.wang@linux.alibaba.com" <baolin.wang@linux.alibaba.com>,
	"ljs@kernel.org" <ljs@kernel.org>,
	"lance.yang@linux.dev" <lance.yang@linux.dev>,
	"mhocko@suse.com" <mhocko@suse.com>,
	"baoquan.he@linux.dev" <baoquan.he@linux.dev>,
	"pfalcato@suse.de" <pfalcato@suse.de>
Subject: Re: [PATCH v2 5/8] mm/internal: rename swap offset helpers to softleaf offset
Date: Tue, 8 Sep 2026 08:41:25 +0000	[thread overview]
Message-ID: <e69e68f58afb8001613b710df6a602d490581292.camel@amd.com> (raw)
In-Reply-To: <8cc0b340-9526-47ac-abd4-3f5724963409@arm.com>

On Tue, 2026-09-08 at 11:08 +0530, Dev Jain wrote:
> 
> On 08/09/26 3:03 am, Barry Song wrote:
> > On Mon, Sep 7, 2026 at 1:38 PM Dev Jain <dev.jain@arm.com> wrote:
> > > 
> > > 
> > > 
> > > On 05/09/26 4:12 pm, Barry Song wrote:
> > > > On Tue, Sep 1, 2026 at 1:44 PM Dev Jain <dev.jain@arm.com> wrote:
> > > > > 
> > > > > In preparation for adding a helper to set softleaf ptes in one go,
> > > > > generalize the swap entry helpers shifting the swap offset by delta,
> > > > > for softleaves.
> > > > > 
> > > > > Note that the soft-dirty bit, exclusive bit and uffd bit preservation
> > > > > will still work for non-swap softleaves, since a softleaf entry is
> > > > > constructed out of a type and offset, and those bits are ahead of
> > > > > the soft-dirty, exclusive and uffd bits.
> > > > > 
> > > > > For example, for a migration entry, pte_swp_exclusive() will return
> > > > > false, as the exclusivity is encoded in the type itself
> > > > > (SOFTLEAF_MIGRATION_READ_EXCLUSIVE).
> > > > 
> > > > I don't quite understand why you mention this. Is anyone calling
> > > > `pte_swp_exclusive()` on a migration entry? Shouldn't it only be called
> > > > when `softleaf_is_swap()` is true?
> > > 
> > > You are right. I just wanted to emphasize the second paragraph - that the
> > > pte_move_swp_offset will also work for softleaf entries. But I think
> > > the third para confuses more, I'll drop it.
> > 
> > I would rather interpret this as meaning that
> > `pte_move_softleaf_offset` will also work for swap softleafs,
> > since `pte_move_softleaf_offset` will call some pure-swap
> > functions?
> 
> Yes, so if you see remove_migration_pte, there pte_swp_uffd and
> pte_swp_soft_dirty are being used. Same with restore_exclusive_pte
> (for device-exclusive stuff).
> 
> Which means that pte_swp_exclusive is the only one being used
> *only* for swap entries.
> 
> 
> > 
> > Would it be possible to use `if (softleaf_is_swap())` for
> > these cases to make the intent clearer? or we can
> > keep both pte_move_softleaf_offset and pte_move_swap_offset?
> 
> So in my patch I can do
> 
> if (softleaf_is_swap(entry) && pte_swp_exclusive(pte))
> 
> That would make the intent clear.
> 
> 
> > 
> > As `pte_move_softleaf_offset()` is getting a bit weird now,
> > a generic softleaf function has a lot of swap-specific code in it:
> > 
> > static inline pte_t pte_move_softleaf_offset(pte_t pte, long delta)
> > {
> >         const softleaf_t entry = softleaf_from_pte(pte);
> >         pte_t new = __swp_entry_to_pte(__swp_entry(swp_type(entry),
> >                                                    (swp_offset(entry)
> > + delta)));
> > 
> >         if (pte_swp_soft_dirty(pte))
> >                 new = pte_swp_mksoft_dirty(new);
> >         if (pte_swp_exclusive(pte))
> >                 new = pte_swp_mkexclusive(new);
> >         if (pte_swp_uffd(pte))
> >                 new = pte_swp_mkuffd(new);
> > 
> >         return new;
> > }
> > 
> > Am I missing something here?
> > 
> > > 
> > > > 
> > > > > 
> > > > > Signed-off-by: Dev Jain <dev.jain@arm.com>
> > > > 
> > > > Reviewed-by: Barry Song <baohua@kernel.org>
> > > 
> > > Thanks.
> > > 
> > > 
> > > > 
> > > > > ---
> > > > >  mm/internal.h | 29 +++++++++++++++--------------
> > > > >  mm/memory.c   |  4 ++--
> > > > >  2 files changed, 17 insertions(+), 16 deletions(-)
> > > > > 
> > > > [...]
> > > > > 
> > > > >  /**
> > > > > @@ -523,7 +524,7 @@ static inline pte_t pte_next_swp_offset(pte_t pte)
> > > > >   */
> > > > >  static inline int swap_pte_batch(pte_t *start_ptep, int max_nr, pte_t pte)
> > > > >  {
> > > > 
> > > > We might find a user for this in the future, in which case we might
> > > > want to rename `swap_pte_batch()` to `swap_softleaf_batch()`?
> > > 
> > > That is what is being done here:
> > > https://lore.kernel.org/all/20260813-migrate-rmap-batch-v2-1-3c5424c555c7@amd.com/
> > > 
> > > I don't have a strong opinion, I can also generalize this right now.
> > 
> > I don't know how you and Shivank are collaborating,
> > since you're both changing the same thing at the same time :-)
> 
> We are not collaborating really : ) he should have ideally waited
> for my patchset to go in first since I was doing big changes in
> rmap.c.
> 

Just to clarify, my series is already based on your V1 series, as noted
in its cover letter and b4 prerequisite-message-id.

The intention was always for your series to go in first. I posted mine
meanwhile to collect review rather than wait for yours to land. 

> > 
> > Hopefully, we can get one of yours into mm-new first,
> > and the other one can find a way to resolve the conflicts.
> 
> Yes.
> 

I agree there is some overlap in rmap.c, and I will rebase my series on your
latest version to avoid conflicts.

Regarding softleaf_pte_batch(), my patch factors the generic logic out of
swap_pte_batch() because the migration path (migration_pte_batch) needs it.
I suggest keeping it in my series, but I can drop that patch if you prefer
to carry this revised patch[1] in yours.

[1] https://lore.kernel.org/all/89d8c2d6f35f7fdc3444ea3a62ccd244945d9644.camel@amd.com

Thanks,
Shivank


  reply	other threads:[~2026-09-08  8:41 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-01  5:43 [PATCH v2 0/8] Optimize anonymous swapbacked large folio unmapping Dev Jain
2026-09-01  5:43 ` [PATCH v2 1/8] mm/swapfile: add batched version of folio_dup_swap Dev Jain
2026-09-01  5:43 ` [PATCH v2 2/8] mm/swapfile: add batched version of folio_put_swap Dev Jain
2026-09-01  5:43 ` [PATCH v2 3/8] mm: move anon-exclusive batch helper to mm.h Dev Jain
2026-09-01  5:49   ` Barry Song
2026-09-01  6:24     ` Dev Jain
2026-09-02  6:29       ` Barry Song
2026-09-04  3:46   ` Dev Jain
2026-09-01  5:43 ` [PATCH v2 4/8] mm/rmap: Add batched version of folio_try_share_anon_rmap_pte Dev Jain
     [not found]   ` <CAGsJ_4zWPXoJ5kiLoVcq1YHv6WcmjPEssTUs4OT15iNRob3_rQ@mail.gmail.com>
2026-09-09  7:44     ` Dev Jain
2026-09-01  5:43 ` [PATCH v2 5/8] mm/internal: rename swap offset helpers to softleaf offset Dev Jain
2026-09-05 10:42   ` Barry Song
2026-09-05 10:49     ` Barry Song
2026-09-07  5:38     ` Dev Jain
2026-09-07 21:33       ` Barry Song
2026-09-08  5:38         ` Dev Jain
2026-09-08  8:41           ` Garg, Shivank [this message]
2026-09-01  5:43 ` [PATCH v2 6/8] mm/internal: add set_softleaf_ptes Dev Jain
2026-09-05 10:52   ` Barry Song
2026-09-01  5:43 ` [PATCH v2 7/8] mm/memory: use set_softleaf_ptes for uffd-wp markers Dev Jain
2026-09-05 10:53   ` Barry Song
2026-09-01  5:43 ` [PATCH v2 8/8] mm/rmap: batch unmap anonymous swap-backed large folios Dev Jain
2026-09-08 21:48   ` Barry Song

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e69e68f58afb8001613b710df6a602d490581292.camel@amd.com \
    --to=shivankg@amd.com \
    --cc=akpm@linux-foundation.org \
    --cc=anshuman.khandual@arm.com \
    --cc=baohua@kernel.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=baoquan.he@linux.dev \
    --cc=chrisl@kernel.org \
    --cc=david@kernel.org \
    --cc=dev.jain@arm.com \
    --cc=harry@kernel.org \
    --cc=hughd@google.com \
    --cc=jannh@google.com \
    --cc=kasong@tencent.com \
    --cc=lance.yang@linux.dev \
    --cc=liam@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=nphamcs@gmail.com \
    --cc=pfalcato@suse.de \
    --cc=riel@surriel.com \
    --cc=rppt@kernel.org \
    --cc=ryan.roberts@arm.com \
    --cc=shikemeng@huaweicloud.com \
    --cc=surenb@google.com \
    --cc=vbabka@kernel.org \
    --cc=youngjun.park@lge.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox