Linux-mm Archive on lore.kernel.org
 help / color / mirror / Atom feed
* Re: [PATCH] mm/damon/ops-common: factor out damon_putback_folio_list()
       [not found] <20260817063458.351063-1-dayou5941@163.com>
@ 2026-08-17 13:42 ` SJ Park
  0 siblings, 0 replies; only message in thread
From: SJ Park @ 2026-08-17 13:42 UTC (permalink / raw)
  To: dayou5941; +Cc: SJ Park, akpm, damon, Li Youhong, linux-mm, linux-kernel

Hello Li,

'get_maintainer.pl --nogit --nogit-fallback' suggests adding below recipients.
I added them.  Please consier using get_maintainer.pl from the next time.

- linux-mm@kvack.org
- linux-kernel@vger.kernel.org

On Mon, 17 Aug 2026 14:34:58 +0800 dayou5941@163.com wrote:

> From: Li Youhong <liyouhong@kylinos.cn>
> 
> The putback loop is duplicated in damon_migrate_folio_list() and on the
> invalid-nid path of damon_migrate_pages().  Factor it into a small helper
> for readability.  No functional change.

Thank you for this patch.

> 
> Signed-off-by: Li Youhong <liyouhong@kylinos.cn>
> 
> ---
> Note:
> As previously pointed out by the AI regarding whether removing the local
> variable struct folio *folio in the damon_migrate_folio_list()function
> would introduce build-time issues: no build failure will actually occur.
> This is because struct folio *folio is only used inside the while-loop.
> link: https://lore.kernel.org/all/20260724060707.CE1F81F000E9@smtp.kernel.org/

But, a build on my setup actually fails like below:

    $ make O=../linux.out mm/damon/
    [...]
      CC      mm/damon/ops-common.o
    mm/damon/ops-common.c: In function ‘damon_migrate_folio_list’:
    mm/damon/ops-common.c:357:17: error: ‘folio’ undeclared (first use in this function)
      357 |                 folio = lru_to_folio(folio_list);
          |                 ^~~~~

> 
> ---
>  mm/damon/ops-common.c | 31 +++++++++++++++----------------
>  1 file changed, 15 insertions(+), 16 deletions(-)
> 
> diff --git a/mm/damon/ops-common.c b/mm/damon/ops-common.c
> index 0bcad6b1e5b9..5c0c941b7f75 100644
> --- a/mm/damon/ops-common.c
> +++ b/mm/damon/ops-common.c
> @@ -329,12 +329,24 @@ static unsigned int __damon_migrate_folio_list(
>  	return nr_succeeded;
>  }
>  
> +static void damon_putback_folio_list(struct list_head *folio_list)
> +{
> +	struct folio *folio;
> +
> +	while (!list_empty(folio_list)) {
> +		folio = lru_to_folio(folio_list);
> +		list_del(&folio->lru);
> +		node_stat_sub_folio(folio, NR_ISOLATED_ANON +
> +				folio_is_file_lru(folio));
> +		folio_putback_lru(folio);
> +	}
> +}
> +
>  static unsigned int damon_migrate_folio_list(struct list_head *folio_list,
>  						struct pglist_data *pgdat,
>  						int target_nid)
>  {
>  	unsigned int nr_migrated = 0;
> -	struct folio *folio;

Above declaration removal is causing the build failure.  Let's keep the
declaration.


Thanks,
SJ

[...]


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2026-08-17 13:42 UTC | newest]

Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
     [not found] <20260817063458.351063-1-dayou5941@163.com>
2026-08-17 13:42 ` [PATCH] mm/damon/ops-common: factor out damon_putback_folio_list() SJ Park

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox