From: "Vlastimil Babka (SUSE)" <vbabka@kernel.org>
To: Ye Liu <ye.liu@linux.dev>, Andrew Morton <akpm@linux-foundation.org>
Cc: Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>,
Brendan Jackman <jackmanb@google.com>,
Johannes Weiner <hannes@cmpxchg.org>, Zi Yan <ziy@nvidia.com>,
linux-mm@kvack.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 6/6] mm/page_owner: drop redundant page_owner prefix from static symbols
Date: Mon, 29 Jun 2026 10:15:46 +0200 [thread overview]
Message-ID: <2293328e-ae86-4568-9353-7f4d2cdfc415@kernel.org> (raw)
In-Reply-To: <20260626024550.25677-7-ye.liu@linux.dev>
On 6/26/26 04:45, Ye Liu wrote:
> All of these symbols are file-scoped (static) in page_owner.c, so the
> page_owner_ prefix is pure noise. Rename them to shorter, still-clear
> names:
>
> page_owner_stack_op -> stack_op
> page_owner_stack_open -> stack_open
> page_owner_stack_fops -> stack_fops
> page_owner_pages_threshold -> pages_threshold
> page_owner_threshold_get -> threshold_get
> page_owner_threshold_set -> threshold_set
> page_owner_threshold_fops -> threshold_fops
>
> No functional change.
>
> Signed-off-by: Ye Liu <ye.liu@linux.dev>
Reviewed-by: Vlastimil Babka (SUSE) <vbabka@kernel.org>
Nit:
> -static int page_owner_threshold_set(void *data, u64 val)
> +static int threshold_set(void *data, u64 val)
> {
> - WRITE_ONCE(page_owner_pages_threshold, val);
> + WRITE_ONCE(pages_threshold, val);
> return 0;
> }
>
> -DEFINE_SIMPLE_ATTRIBUTE(page_owner_threshold_fops, &page_owner_threshold_get,
> - &page_owner_threshold_set, "%llu\n");
> -
> +DEFINE_SIMPLE_ATTRIBUTE(threshold_fops, &threshold_get,
> + &threshold_set, "%llu\n");
We can now do make it a single line? 82 characters are fine unless hch sees
this. checkpatch now warns on 100 chars
>
> static int __init pageowner_init(void)
> {
> @@ -999,17 +998,17 @@ static int __init pageowner_init(void)
> debugfs_create_file("show_stacks", 0400, dir,
> (void *)(STACK_PRINT_FLAG_STACK |
> STACK_PRINT_FLAG_PAGES),
> - &page_owner_stack_fops);
> + &stack_fops);
> debugfs_create_file("show_handles", 0400, dir,
> (void *)(STACK_PRINT_FLAG_HANDLE |
> STACK_PRINT_FLAG_PAGES),
> - &page_owner_stack_fops);
> + &stack_fops);
> debugfs_create_file("show_stacks_handles", 0400, dir,
> (void *)(STACK_PRINT_FLAG_STACK |
> STACK_PRINT_FLAG_HANDLE),
> - &page_owner_stack_fops);
> + &stack_fops);
> debugfs_create_file("count_threshold", 0600, dir, NULL,
> - &page_owner_threshold_fops);
> + &threshold_fops);
> return 0;
> }
> late_initcall(pageowner_init)
prev parent reply other threads:[~2026-06-29 8:15 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-26 2:45 [PATCH v2 0/6] mm/page_owner: misc cleanups Ye Liu
2026-06-26 2:45 ` [PATCH v2 1/6] mm/page_owner: extract skip_buddy_pages() helper to unify buddy page skipping Ye Liu
2026-06-26 18:35 ` Zi Yan
2026-06-29 7:32 ` Vlastimil Babka (SUSE)
2026-06-26 2:45 ` [PATCH v2 2/6] mm/page_owner: use MIGRATE_REASON_NONE instead of -1 for last_migrate_reason Ye Liu
2026-06-26 18:45 ` Zi Yan
2026-06-29 2:20 ` Ye Liu
2026-06-29 8:00 ` Vlastimil Babka (SUSE)
2026-06-26 2:45 ` [PATCH v2 3/6] mm/page_owner: hoist CONFIG_MEMCG to function level for print_page_owner_memcg() Ye Liu
2026-06-26 18:52 ` Zi Yan
2026-06-29 8:09 ` Vlastimil Babka (SUSE)
2026-06-26 2:45 ` [PATCH v2 4/6] mm/page_owner: add missing newline to count_threshold format string Ye Liu
2026-06-26 18:53 ` Zi Yan
2026-06-29 8:11 ` Vlastimil Babka (SUSE)
2026-06-26 2:45 ` [PATCH v2 5/6] mm/page_owner: move free_ts_nsec output to free section in __dump_page_owner() Ye Liu
2026-06-26 18:55 ` Zi Yan
2026-06-29 2:36 ` Ye Liu
2026-06-29 2:59 ` Zi Yan
2026-06-29 8:13 ` Vlastimil Babka (SUSE)
2026-06-26 2:45 ` [PATCH v2 6/6] mm/page_owner: drop redundant page_owner prefix from static symbols Ye Liu
2026-06-26 18:56 ` Zi Yan
2026-06-29 8:15 ` Vlastimil Babka (SUSE) [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2293328e-ae86-4568-9353-7f4d2cdfc415@kernel.org \
--to=vbabka@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=hannes@cmpxchg.org \
--cc=jackmanb@google.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=mhocko@suse.com \
--cc=surenb@google.com \
--cc=ye.liu@linux.dev \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox