From: Muchun Song <muchun.song@linux.dev>
To: Mike Rapoport <rppt@kernel.org>
Cc: Muchun Song <songmuchun@bytedance.com>,
Andrew Morton <akpm@linux-foundation.org>,
Oscar Salvador <osalvador@suse.de>,
David Hildenbrand <david@kernel.org>,
linux-mm@kvack.org, Vlastimil Babka <vbabka@kernel.org>,
Lorenzo Stoakes <ljs@kernel.org>, Michal Hocko <mhocko@suse.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 06/17] mm/sparse-vmemmap: support section-based vmemmap accounting
Date: Wed, 15 Jul 2026 22:44:51 +0800 [thread overview]
Message-ID: <FB36B71D-0972-4EF4-9887-C765CAC33E12@linux.dev> (raw)
In-Reply-To: <178409212283.638342.6610895811767474932.b4-review@b4>
> On Jul 15, 2026, at 13:08, Mike Rapoport <rppt@kernel.org> wrote:
>
>> section_nr_vmemmap_pages() is used to account the vmemmap pages consumed by a
>> memory section, but it currently only understands the ordinary case and the
>> pgmap-provided optimization case. That is not enough for section-based vmemmap
>> optimization, where the compound page order is carried by the memory section
>> itself and tail vmemmap pages may be shared.
>>
>> Make the helper report the actual vmemmap footprint of a section, so it can be
>> used as the common accounting path for both ordinary and optimized sections.
>>
>> Teach section_nr_vmemmap_pages() to use the section order when there is no
>> pgmap, and to account only the vmemmap pages that are actually needed for an
>> optimizable section. This keeps the accounting consistent with section-based
>> vmemmap optimization.
>>
>> Signed-off-by: Muchun Song <songmuchun@bytedance.com>
>>
>> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
>> index 6fa6e7f0abf9..41a1ebbe5e85 100644
>> --- a/include/linux/mmzone.h
>> +++ b/include/linux/mmzone.h
>> @@ -2403,6 +2403,14 @@ static inline unsigned int section_order(const struct mem_section *section)
>> }
>> #endif
>>
>> +static inline bool section_vmemmap_optimizable(const struct mem_section *section)
>> +{
>> + if (!is_power_of_2(sizeof(struct page)))
>> + return false;
>> +
>> + return section_order(section) >= OPTIMIZABLE_FOLIO_MIN_ORDER;
>
> Like with page_vmemmap_optimizable() I think it's not obvious that
> section_order() is enough to gate vmemmap optimization.
page_vmemmap_optimizable() checks the optimizability of an individual page.
section_vmemmap_optimizable() checks whether the optimization can be applied
to a section. Some people may think that section_vmemmap_optimizable() checks
the optimizability of all pages within an entire section. You are referring
to that ambiguity, right?
What do you think about renaming it to section_vmemmap_optimization_eligible()?
Would that clear up the ambiguity? Or should we add a comment to
section_vmemmap_optimizableto explain its purpose?
>
>> +}
>> +
>> /*
>> * Fallback case for when the architecture provides its own pfn_valid() but
>> * not a corresponding for_each_valid_pfn().
>> diff --git a/mm/sparse-vmemmap.c b/mm/sparse-vmemmap.c
>> index 77154e9da08c..99f59394feab 100644
>> --- a/mm/sparse-vmemmap.c
>> +++ b/mm/sparse-vmemmap.c
>> @@ -645,24 +645,29 @@ void offline_mem_sections(unsigned long start_pfn, unsigned long end_pfn)
>> static int __meminit section_nr_vmemmap_pages(unsigned long pfn, unsigned long nr_pages,
>> struct vmem_altmap *altmap, struct dev_pagemap *pgmap)
>> {
>> - const unsigned int order = pgmap ? pgmap->vmemmap_shift : 0;
>> + const struct mem_section *ms = __pfn_to_section(pfn);
>> + const unsigned int order = pgmap ? pgmap->vmemmap_shift : section_order(ms);
>> const unsigned long pages_per_compound = 1UL << order;
>> + unsigned int vmemmap_pages = OPTIMIZED_FOLIO_VMEMMAP_PAGES;
>>
>> VM_WARN_ON_ONCE(!IS_ALIGNED(pfn | nr_pages, PAGES_PER_SUBSECTION));
>> VM_WARN_ON_ONCE(nr_pages > PAGES_PER_SECTION);
>>
>> - if (!vmemmap_can_optimize(altmap, pgmap))
>> + if (vmemmap_can_optimize(altmap, pgmap))
>> + vmemmap_pages = VMEMMAP_RESERVE_NR;
>
> I'd put it below the next if ...
Make sense. Will do.
Thanks for your review.
Muchun
>
>> +
>> + if (!vmemmap_can_optimize(altmap, pgmap) && !section_vmemmap_optimizable(ms))
>> return DIV_ROUND_UP(nr_pages * sizeof(struct page), PAGE_SIZE);
>
> ... and make it
>
> vmmemap_pages = vmemmap_can_optimize() ? VMEMMAP_RESERVE_NR : 1;
>
> --
> Sincerely yours,
> Mike.
>
next prev parent reply other threads:[~2026-07-15 14:45 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20260702093821.2740183-1-songmuchun@bytedance.com>
[not found] ` <20260702093821.2740183-9-songmuchun@bytedance.com>
2026-07-09 10:54 ` [PATCH 08/17] mm/sparse: mark memory sections present earlier Mike Rapoport
2026-07-09 12:35 ` Muchun Song
[not found] ` <20260702093821.2740183-7-songmuchun@bytedance.com>
2026-07-15 5:08 ` [PATCH 06/17] mm/sparse-vmemmap: support section-based vmemmap accounting Mike Rapoport
2026-07-15 14:44 ` Muchun Song [this message]
[not found] ` <20260702093821.2740183-4-songmuchun@bytedance.com>
2026-07-15 5:08 ` [PATCH 03/17] mm/sparse-vmemmap: introduce folio-oriented vmemmap optimization macros Mike Rapoport
[not found] ` <20260702093821.2740183-2-songmuchun@bytedance.com>
2026-07-15 5:08 ` [PATCH 01/17] mm/sparse: drop power-of-2 size requirement for struct mem_section Mike Rapoport
[not found] ` <20260715103445.31b2f727@pumpkin>
2026-07-15 13:15 ` Muchun Song
2026-07-15 15:52 ` David Laight
[not found] ` <20260702093821.2740183-8-songmuchun@bytedance.com>
2026-07-15 5:08 ` [PATCH 07/17] mm/sparse-vmemmap: support section-based vmemmap optimization Mike Rapoport
[not found] ` <20260702093821.2740183-5-songmuchun@bytedance.com>
2026-07-09 10:45 ` [PATCH 04/17] mm/mm_init: skip initializing shared vmemmap tail pages Mike Rapoport
2026-07-09 12:31 ` Muchun Song
2026-07-09 13:05 ` Mike Rapoport
2026-07-09 13:23 ` Muchun Song
2026-07-15 5:08 ` Mike Rapoport
[not found] ` <20260702093821.2740183-3-songmuchun@bytedance.com>
2026-07-15 5:08 ` [PATCH 02/17] mm/sparse-vmemmap: track compound page order in struct mem_section Mike Rapoport
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=FB36B71D-0972-4EF4-9887-C765CAC33E12@linux.dev \
--to=muchun.song@linux.dev \
--cc=akpm@linux-foundation.org \
--cc=david@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=mhocko@suse.com \
--cc=osalvador@suse.de \
--cc=rppt@kernel.org \
--cc=songmuchun@bytedance.com \
--cc=vbabka@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox