* [PATCH] mm: gfp_types: fix __GFP_ACCOUNT, GFP_KERNEL_ACCOUNT documentation
@ 2026-07-01 18:21 Johannes Weiner
2026-07-01 18:27 ` Vlastimil Babka (SUSE)
2026-07-01 18:37 ` Shakeel Butt
0 siblings, 2 replies; 3+ messages in thread
From: Johannes Weiner @ 2026-07-01 18:21 UTC (permalink / raw)
To: Andrew Morton
Cc: Gregory Price, Michal Hocko, Roman Gushchin, Shakeel Butt,
Muchun Song, David Hildenbrand, Lorenzo Stoakes, Liam R. Howlett,
Vlastimil Babka, Mike Rapoport, Suren Baghdasaryan, cgroups,
linux-mm, linux-kernel
Gregory points out that these descriptions are cursed and confusing,
considering what these flags actually do. This is mostly due to
historic implementation choices and cgroup1 baggage. Improve the
description of their actual effects.
Reported-by: Gregory Price <gourry@gourry.net>
Signed-off-by: Johannes Weiner <hannes@cmpxchg.org>
---
include/linux/gfp_types.h | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/include/linux/gfp_types.h b/include/linux/gfp_types.h
index 54ca0c88bab6..463b551d12d9 100644
--- a/include/linux/gfp_types.h
+++ b/include/linux/gfp_types.h
@@ -136,7 +136,8 @@ enum {
* %__GFP_THISNODE forces the allocation to be satisfied from the requested
* node with no fallbacks or placement policy enforcements.
*
- * %__GFP_ACCOUNT causes the allocation to be accounted to kmemcg.
+ * %__GFP_ACCOUNT causes the allocation to be accounted to the active
+ * cgroup context.
*
* %__GFP_NO_OBJ_EXT causes slab allocation to have no object extension.
* mark_obj_codetag_empty() should be called upon freeing for objects allocated
@@ -320,7 +321,7 @@ enum {
* %ZONE_NORMAL or a lower zone for direct access but can direct reclaim.
*
* %GFP_KERNEL_ACCOUNT is the same as GFP_KERNEL, except the allocation is
- * accounted to kmemcg.
+ * accounted to the active cgroup context.
*
* %GFP_NOWAIT is for kernel allocations that should not stall for direct
* reclaim, start physical IO or use any filesystem callback. It is very
--
2.55.0
^ permalink raw reply related [flat|nested] 3+ messages in thread
* Re: [PATCH] mm: gfp_types: fix __GFP_ACCOUNT, GFP_KERNEL_ACCOUNT documentation
2026-07-01 18:21 [PATCH] mm: gfp_types: fix __GFP_ACCOUNT, GFP_KERNEL_ACCOUNT documentation Johannes Weiner
@ 2026-07-01 18:27 ` Vlastimil Babka (SUSE)
2026-07-01 18:37 ` Shakeel Butt
1 sibling, 0 replies; 3+ messages in thread
From: Vlastimil Babka (SUSE) @ 2026-07-01 18:27 UTC (permalink / raw)
To: Johannes Weiner, Andrew Morton
Cc: Gregory Price, Michal Hocko, Roman Gushchin, Shakeel Butt,
Muchun Song, David Hildenbrand, Lorenzo Stoakes, Liam R. Howlett,
Vlastimil Babka, Mike Rapoport, Suren Baghdasaryan, cgroups,
linux-mm, linux-kernel
On 7/1/26 20:21, Johannes Weiner wrote:
> Gregory points out that these descriptions are cursed and confusing,
> considering what these flags actually do. This is mostly due to
> historic implementation choices and cgroup1 baggage. Improve the
> description of their actual effects.
>
> Reported-by: Gregory Price <gourry@gourry.net>
> Signed-off-by: Johannes Weiner <hannes@cmpxchg.org>
Reviewed-by: Vlastimil Babka (SUSE) <vbabka@kernel.org>
> ---
> include/linux/gfp_types.h | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/include/linux/gfp_types.h b/include/linux/gfp_types.h
> index 54ca0c88bab6..463b551d12d9 100644
> --- a/include/linux/gfp_types.h
> +++ b/include/linux/gfp_types.h
> @@ -136,7 +136,8 @@ enum {
> * %__GFP_THISNODE forces the allocation to be satisfied from the requested
> * node with no fallbacks or placement policy enforcements.
> *
> - * %__GFP_ACCOUNT causes the allocation to be accounted to kmemcg.
> + * %__GFP_ACCOUNT causes the allocation to be accounted to the active
> + * cgroup context.
> *
> * %__GFP_NO_OBJ_EXT causes slab allocation to have no object extension.
> * mark_obj_codetag_empty() should be called upon freeing for objects allocated
> @@ -320,7 +321,7 @@ enum {
> * %ZONE_NORMAL or a lower zone for direct access but can direct reclaim.
> *
> * %GFP_KERNEL_ACCOUNT is the same as GFP_KERNEL, except the allocation is
> - * accounted to kmemcg.
> + * accounted to the active cgroup context.
> *
> * %GFP_NOWAIT is for kernel allocations that should not stall for direct
> * reclaim, start physical IO or use any filesystem callback. It is very
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] mm: gfp_types: fix __GFP_ACCOUNT, GFP_KERNEL_ACCOUNT documentation
2026-07-01 18:21 [PATCH] mm: gfp_types: fix __GFP_ACCOUNT, GFP_KERNEL_ACCOUNT documentation Johannes Weiner
2026-07-01 18:27 ` Vlastimil Babka (SUSE)
@ 2026-07-01 18:37 ` Shakeel Butt
1 sibling, 0 replies; 3+ messages in thread
From: Shakeel Butt @ 2026-07-01 18:37 UTC (permalink / raw)
To: Johannes Weiner
Cc: Andrew Morton, Gregory Price, Michal Hocko, Roman Gushchin,
Muchun Song, David Hildenbrand, Lorenzo Stoakes, Liam R. Howlett,
Vlastimil Babka, Mike Rapoport, Suren Baghdasaryan, cgroups,
linux-mm, linux-kernel
On Wed, Jul 01, 2026 at 02:21:02PM -0400, Johannes Weiner wrote:
> Gregory points out that these descriptions are cursed and confusing,
> considering what these flags actually do. This is mostly due to
> historic implementation choices and cgroup1 baggage. Improve the
> description of their actual effects.
>
> Reported-by: Gregory Price <gourry@gourry.net>
> Signed-off-by: Johannes Weiner <hannes@cmpxchg.org>
Acked-by: Shakeel Butt <shakeel.butt@linux.dev>
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2026-07-01 18:38 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-01 18:21 [PATCH] mm: gfp_types: fix __GFP_ACCOUNT, GFP_KERNEL_ACCOUNT documentation Johannes Weiner
2026-07-01 18:27 ` Vlastimil Babka (SUSE)
2026-07-01 18:37 ` Shakeel Butt
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox