From: Lucas De Marchi <lucas.de.marchi@gmail.com>
To: linux-modules@vger.kernel.org
Cc: rusty@rustcorp.com.au, linux-kernel@vger.kernel.org
Subject: [ANNOUNCE] kmod 18
Date: Sat, 14 Jun 2014 15:57:16 +0000 [thread overview]
Message-ID: <20140614155714.GA16582@politreco> (raw)
kmod 18 is out:
ftp://ftp.kernel.org/pub/linux/utils/kernel/kmod/kmod-18.tar.xz
ftp://ftp.kernel.org/pub/linux/utils/kernel/kmod/kmod-18.tar.sign
Small fixes to libkmod, tools and testsuite. The biggest visible change is in
depmod, that now fails if dependency loops are present.
- Bug fixes:
- Fix leaks in error paths
- Fix use-after-free in hash implementation causing a wrong index to be
generated by depmod with out-of-tree modules
- New features:
- Calling depmod with modules creating a dependency loop will now make
depmod return an error and not update the indexes. This is to protect
the current index not being overridden by another index that may cause
a boot failure, depending on the buggy module. It's a necessary
change in behavior regarding previous kmod releases and
module-init-tools. The error message was also improved to output
the modules that caused the dependency cycle.
- Improvements to testsuite:
- Fix and improve expected-fail test
- Add tests for hashmap implementation
And the shortlog:
Joe Lawrence (1):
man: fixup spacing/parens in modprobe.d(5)
Leandro Pereira (5):
Bail out of index_mm_open() if fstat() fails
Ensure read_long() reads the correct number of bytes from the index
Free realnames if kmod_lookup_alias_from_alias_bin() fails
Free abspath if kmod_module_new_from_path() fails.
Close /sys/module/$NAME directory if opening /proc/module fails.
Lucas De Marchi (17):
Update .travis.yml
Add strndupa to missing.h
Make sure there's NUL byte at the end of strndupa
testsuite: Add module playground dir
Add gitignore to module playground
depmod: Make dependency loops be fatal
depmod: Rename variable to clarify its meaning
testsuite: add test to fail depmod on module loops
depmod: Add better error messages when facing loops
testsuite: Add braces
testsuite: Fix expected_fail parsing
testsuite: check for correct error message in detect-loop
testsuite: separate testcases on log
testsuite: Add assert_return
testsuite: Add basic tests for hash implementation
testsuite: Fix macro missing format string
kmod 18
Lukas Anzinger (1):
Fix use-after-free in hash implementation.
Marco d'Itri (1):
Remove references to systemd from the bash completion file
--
Lucas De Marchi
reply other threads:[~2014-06-14 15:57 UTC|newest]
Thread overview: [no followups] expand[flat|nested] mbox.gz Atom feed
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140614155714.GA16582@politreco \
--to=lucas.de.marchi@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-modules@vger.kernel.org \
--cc=rusty@rustcorp.com.au \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox