Linux Modules
 help / color / mirror / Atom feed
* [ANNOUNCE] kmod 18
@ 2014-06-14 15:57 Lucas De Marchi
  0 siblings, 0 replies; only message in thread
From: Lucas De Marchi @ 2014-06-14 15:57 UTC (permalink / raw)
  To: linux-modules; +Cc: rusty, linux-kernel

kmod 18 is out:

        ftp://ftp.kernel.org/pub/linux/utils/kernel/kmod/kmod-18.tar.xz
        ftp://ftp.kernel.org/pub/linux/utils/kernel/kmod/kmod-18.tar.sign

Small fixes to libkmod, tools and testsuite. The biggest visible change is in
depmod, that now fails if dependency loops are present.

- Bug fixes:
	- Fix leaks in error paths
	- Fix use-after-free in hash implementation causing a wrong index to be
	  generated by depmod with out-of-tree modules

- New features:
	- Calling depmod with modules creating a dependency loop will now make
	  depmod return an error and not update the indexes. This is to protect
	  the current index not being overridden by another index that may cause
	  a boot failure, depending on the buggy module. It's a necessary
	  change in behavior regarding previous kmod releases and
	  module-init-tools. The error message was also improved to output
	  the modules that caused the dependency cycle.

- Improvements to testsuite:
	- Fix and improve expected-fail test
	- Add tests for hashmap implementation


And the shortlog:

Joe Lawrence (1):
      man: fixup spacing/parens in modprobe.d(5)

Leandro Pereira (5):
      Bail out of index_mm_open() if fstat() fails
      Ensure read_long() reads the correct number of bytes from the index
      Free realnames if kmod_lookup_alias_from_alias_bin() fails
      Free abspath if kmod_module_new_from_path() fails.
      Close /sys/module/$NAME directory if opening /proc/module fails.

Lucas De Marchi (17):
      Update .travis.yml
      Add strndupa to missing.h
      Make sure there's NUL byte at the end of strndupa
      testsuite: Add module playground dir
      Add gitignore to module playground
      depmod: Make dependency loops be fatal
      depmod: Rename variable to clarify its meaning
      testsuite: add test to fail depmod on module loops
      depmod: Add better error messages when facing loops
      testsuite: Add braces
      testsuite: Fix expected_fail parsing
      testsuite: check for correct error message in detect-loop
      testsuite: separate testcases on log
      testsuite: Add assert_return
      testsuite: Add basic tests for hash implementation
      testsuite: Fix macro missing format string
      kmod 18

Lukas Anzinger (1):
      Fix use-after-free in hash implementation.

Marco d'Itri (1):
      Remove references to systemd from the bash completion file


-- 
Lucas De Marchi

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2014-06-14 15:57 UTC | newest]

Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2014-06-14 15:57 [ANNOUNCE] kmod 18 Lucas De Marchi

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox