* Re: [PATCH] mtd: rawnand: Prefer struct_size over open coded arithmetic
2024-02-10 16:16 [PATCH] mtd: rawnand: Prefer struct_size over open coded arithmetic Erick Archer
@ 2024-02-10 16:52 ` Gustavo A. R. Silva
2024-02-10 17:22 ` Uwe Kleine-König
2024-02-12 8:45 ` AngeloGioacchino Del Regno
2 siblings, 0 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2024-02-10 16:52 UTC (permalink / raw)
To: Erick Archer, Miquel Raynal, Richard Weinberger,
Vignesh Raghavendra, Matthias Brugger, AngeloGioacchino Del Regno,
Martin Blumenstingl, Heiko Stuebner, Philippe Mathieu-Daudé,
Rob Herring, Li Zetao, Uwe Kleine-König, Gustavo A. R. Silva,
Kees Cook
Cc: linux-mtd, linux-kernel, linux-arm-kernel, linux-mediatek,
linux-hardening
On 2/10/24 10:16, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> As the "chip" variable is a pointer to "struct mtk_nfc_nand_chip" and
> this structure ends in a flexible array:
>
> struct mtk_nfc_nand_chip {
> [...]
> u8 sels[] __counted_by(nsels);
> };
>
> the preferred way in the kernel is to use the struct_size() helper to
> do the arithmetic instead of the argument "size + count * size" in the
> devm_kzalloc() function.
>
> This way, the code is more readable and more safer.
>
> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/160 [2]
> Signed-off-by: Erick Archer <erick.archer@gmx.com>
LGTM:
Reviewed-by: Gustavo A. R. Silva <gustavoars@kernel.org>
Thanks!
--
Gustavo
> ---
> drivers/mtd/nand/raw/mtk_nand.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/mtd/nand/raw/mtk_nand.c b/drivers/mtd/nand/raw/mtk_nand.c
> index 60198e33d2d5..17477bb2d48f 100644
> --- a/drivers/mtd/nand/raw/mtk_nand.c
> +++ b/drivers/mtd/nand/raw/mtk_nand.c
> @@ -1356,7 +1356,7 @@ static int mtk_nfc_nand_chip_init(struct device *dev, struct mtk_nfc *nfc,
> return -EINVAL;
> }
>
> - chip = devm_kzalloc(dev, sizeof(*chip) + nsels * sizeof(u8),
> + chip = devm_kzalloc(dev, struct_size(chip, sels, nsels),
> GFP_KERNEL);
> if (!chip)
> return -ENOMEM;
> --
> 2.25.1
>
>
______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/
^ permalink raw reply [flat|nested] 4+ messages in thread* Re: [PATCH] mtd: rawnand: Prefer struct_size over open coded arithmetic
2024-02-10 16:16 [PATCH] mtd: rawnand: Prefer struct_size over open coded arithmetic Erick Archer
2024-02-10 16:52 ` Gustavo A. R. Silva
@ 2024-02-10 17:22 ` Uwe Kleine-König
2024-02-12 8:45 ` AngeloGioacchino Del Regno
2 siblings, 0 replies; 4+ messages in thread
From: Uwe Kleine-König @ 2024-02-10 17:22 UTC (permalink / raw)
To: Erick Archer
Cc: Miquel Raynal, Richard Weinberger, Vignesh Raghavendra,
Matthias Brugger, AngeloGioacchino Del Regno, Martin Blumenstingl,
Heiko Stuebner, Philippe Mathieu-Daudé, Rob Herring,
Li Zetao, Gustavo A. R. Silva, Kees Cook, linux-mtd, linux-kernel,
linux-arm-kernel, linux-mediatek, linux-hardening
[-- Attachment #1.1: Type: text/plain, Size: 885 bytes --]
On Sat, Feb 10, 2024 at 05:16:19PM +0100, Erick Archer wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> As the "chip" variable is a pointer to "struct mtk_nfc_nand_chip" and
> this structure ends in a flexible array:
>
> struct mtk_nfc_nand_chip {
> [...]
> u8 sels[] __counted_by(nsels);
> };
>
> the preferred way in the kernel is to use the struct_size() helper to
> do the arithmetic instead of the argument "size + count * size" in the
> devm_kzalloc() function.
>
> This way, the code is more readable and more safer.
Unless you intend this non-English comparative: s/more safer/safer/
Best regards
Uwe
--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | https://www.pengutronix.de/ |
[-- Attachment #1.2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]
[-- Attachment #2: Type: text/plain, Size: 144 bytes --]
______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/
^ permalink raw reply [flat|nested] 4+ messages in thread* Re: [PATCH] mtd: rawnand: Prefer struct_size over open coded arithmetic
2024-02-10 16:16 [PATCH] mtd: rawnand: Prefer struct_size over open coded arithmetic Erick Archer
2024-02-10 16:52 ` Gustavo A. R. Silva
2024-02-10 17:22 ` Uwe Kleine-König
@ 2024-02-12 8:45 ` AngeloGioacchino Del Regno
2 siblings, 0 replies; 4+ messages in thread
From: AngeloGioacchino Del Regno @ 2024-02-12 8:45 UTC (permalink / raw)
To: Erick Archer, Miquel Raynal, Richard Weinberger,
Vignesh Raghavendra, Matthias Brugger, Martin Blumenstingl,
Heiko Stuebner, Philippe Mathieu-Daudé, Rob Herring,
Li Zetao, Uwe Kleine-König, Gustavo A. R. Silva, Kees Cook
Cc: linux-mtd, linux-kernel, linux-arm-kernel, linux-mediatek,
linux-hardening
Il 10/02/24 17:16, Erick Archer ha scritto:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1].
>
> As the "chip" variable is a pointer to "struct mtk_nfc_nand_chip" and
> this structure ends in a flexible array:
>
> struct mtk_nfc_nand_chip {
> [...]
> u8 sels[] __counted_by(nsels);
> };
>
> the preferred way in the kernel is to use the struct_size() helper to
> do the arithmetic instead of the argument "size + count * size" in the
> devm_kzalloc() function.
>
> This way, the code is more readable and more safer.
This way, the code is more readable and safer.
Apart from that,
Reviewed-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
>
> Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/160 [2]
> Signed-off-by: Erick Archer <erick.archer@gmx.com>
> ---
> drivers/mtd/nand/raw/mtk_nand.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/mtd/nand/raw/mtk_nand.c b/drivers/mtd/nand/raw/mtk_nand.c
> index 60198e33d2d5..17477bb2d48f 100644
> --- a/drivers/mtd/nand/raw/mtk_nand.c
> +++ b/drivers/mtd/nand/raw/mtk_nand.c
> @@ -1356,7 +1356,7 @@ static int mtk_nfc_nand_chip_init(struct device *dev, struct mtk_nfc *nfc,
> return -EINVAL;
> }
>
> - chip = devm_kzalloc(dev, sizeof(*chip) + nsels * sizeof(u8),
> + chip = devm_kzalloc(dev, struct_size(chip, sels, nsels),
> GFP_KERNEL);
> if (!chip)
> return -ENOMEM;
> --
> 2.25.1
>
______________________________________________________
Linux MTD discussion mailing list
http://lists.infradead.org/mailman/listinfo/linux-mtd/
^ permalink raw reply [flat|nested] 4+ messages in thread